Hyper-V Failed to Change State Error Code 32788 RRS feed

  • Question

  • I have a Hyper-V machine running on a server with 20GB of RAM available (according to resource monitor).  When I try to start it with more than 4GB of RAM it fails with this error.  I tried creating a new VM, using a different VHD file, all create the same error.  Before I updated Hyper-V it used to report insufficient memory.  What am I missing?



    Wednesday, April 12, 2017 2:35 PM

All replies

  • Hi Sir,

    >>I have a Hyper-V machine running on a server with 20GB of RAM available (according to resource monitor).

    This is a physical server ?

    What is the version of OS ?

    >>Before I updated Hyper-V it used to report insufficient memory. 

    Have you tried to use performance monitor with counter "hyper-v dynamic memory balancer system balancer " to check if there is free memory larger than 4GB :

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Sunday, April 16, 2017 7:16 AM
  • Hi Sir,

    I'd like to check the current state of that issue .

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Sunday, April 23, 2017 9:50 AM
  • This happened to me just now. 12/7/17. I restored a Win 2012 R2 VM using DPM to a physical Windows 2012 R2 HV host like I always do. This time the VM would not start and I received error 32788 when I started the VM.

     I forgot to assign the VM a network adapter in HV settings after it was restored but before starting it. I needed the VM it to have an internal network adapter in my case. Changed the VM NIC to an internal switch and VM started right up.

    • Proposed as answer by lexschulz Friday, October 19, 2018 7:19 AM
    Friday, December 8, 2017 6:47 AM
  • This is due a problem with the virtual switch

    I have just had exactly the same issue on my machine, I had to create a new virtual switch and assign all of my virtual machines to this switch. Everything works fine now

    Monday, December 11, 2017 3:06 AM
  • Exactly, I had my Virtual Switch in Configuration Error in the HyperV Settings. Changing it to a valid virtual switch solved the problem.


    • Proposed as answer by VWSurfer69 Friday, May 4, 2018 4:22 PM
    Tuesday, February 13, 2018 2:06 AM
  • I had exactly the same error with a virtual machine. The virtual switch was ok, even removing the network adapter and starting without network did not help. I solved it with stopping the VM Service on the server (VM continued to run) and starting it again - now the VM started without any error.
    Wednesday, March 28, 2018 9:57 AM
  • This worked for me. 


    Wednesday, July 11, 2018 4:22 PM
  • I tried everything in this thread. Ultimately I just recreated a new machine > Attached the Drive to the New Machine > Everything worked fine. 
    Sunday, August 19, 2018 7:23 PM
  • This can be a virtual memory issue also, so maybe check how much disk space is available on the disk where the VM files are stored (e.g. C: instead of D:).

    Monday, October 1, 2018 3:12 PM
  • Under the "Actions" column, a refresh quickly resolved the error for me however, its unclear why it did..
    Monday, March 25, 2019 1:46 PM
  • restarting the host computer fixed it for me. I feel it was more likely caused by not enough free memory in my case, since I tried restarting two running  services related to Hyper-V, which did not help. 

    But I really don't understand what type of memory is not enough just looking at the performance tab of task manager, instead, the available memory on it was a little bit more then memory for my saved  VM.

    • Edited by GuYuming Friday, May 31, 2019 6:19 AM
    Wednesday, May 29, 2019 10:27 AM
  • I get this error again today, my VM need 6000MB memory, the Available number on Task manager is 8G. 

    I tried Stop Service in Hyper-V manager, which does not fix.

    Then, I closed Edge browser and JustDecompile, I see a memory usage drop in Task manager and I can start the VM after that.

    Thursday, June 6, 2019 1:35 AM
  • Same issue on my side (starting with more than 4GB or RAM fails the start).

    I guess there is some bug with hyper-v implementation.


    Friday, June 14, 2019 10:47 AM
  • this time, I use RAMMAP to help with troubleshoot, now my VM need 9000M memory. The first screenshot is what I get after clicked every item in Emty menu in RAMMAP. The second is what I get after restart computer. I wonder how can I get enough free memory without restart computer.

    guess I need to first find out which process hold the large amount of modified memory which cannot be released by "Empty"
    • Edited by GuYuming Thursday, June 20, 2019 10:06 AM
    Thursday, June 20, 2019 9:57 AM
  • That was my issue.
    Saturday, August 17, 2019 3:30 AM
  • 非常感谢
    Friday, September 20, 2019 3:24 AM
  • From the answers I understand this maybe a generic error that appears under several occasions.
    In my case it was due to the available memory and in fact when I tried a second restart of the machine the error message was about the memory instead of the 32788.

    I am running 2 linux VMs on a 16G PC each with 6G of RAM.
    When I start the first one it shows that it occupies the 6G of RAM I set in settings.
    During this time I cannot start the second virtual machine.
    After some time the consumed memory drops at about 2G or maybe less, it seems the memory is allocated dynamically and released when not needen by the VM.
    When this happens I can start the second VM and the run both quite happy.
    Whenever they need more memory they are given memory and the usual memory consumption for each of the 2 VMs is about 4G.

    So, all I have to do in order to start the second VM is to wait, for about 1 minute or so, the first to release some memory and then I start the second.
    It is possible that if I change some settings of the VMs I wont have to wait at all, I 'll try it some time.

    Friday, September 27, 2019 8:52 AM