none
How to disable the "Updates are available" pop-up? RRS feed

  • Question

  • I have a Windows Server 2012 R2 server that due to special requirements on timing, has windows updates initiated by script.  Therefore, by group policy, it is set to "download but do not install" and windows updates by automatic maintenance is disabled.  So basically, updates are not applied until the script kicks off the process.

    When updates are released by our WSUS server, the server downloads them as it is supposed to at the next refresh cycle.  This is necessary so that the updates are ready-to-go when the script kicks off updates instead of having to wait another 5-10 minutes to download before installation begins.

    When updates are downloaded, but before they are installed, whenever I log into the server I see a pop-up "Updates are available."  It interrupts my workflow and gives me a chance to accidentally click "install" which would be bad.  Even more annoyingly, when you click "close" to dismiss the dialog it pops back up 5 minutes later.

    How do I disable this dialog?

    Friday, October 17, 2014 2:00 PM

Answers

  • Hi Timothy,

    Sorry to bump your 4 years old thread but I came across your question because I'm in the same situation as you, only difference is I have a Windows Server 2016. I found a solutions to disable the pop-up without side effects.

    Credits will go to this site:

    https://winaero.com/blog/disable-updates-available-windows-10/

    In short follow these steps:

    Start an elevated command prompt and enter these commands:
    cd /d "%Windir%\System32"
    takeown /f musnotification.exe
    icacls musnotification.exe /deny Everyone:(X)
    takeown /f musnotificationux.exe
    icacls musnotificationux.exe /deny Everyone:(X)

    Tuesday, March 20, 2018 9:18 AM

All replies

  • Hi Timothy,

    On current situation, please open GPME and follow the path:

    Computer Configuration\Policies\Administrative Templates\Windows Components\Windows Update\ Allow non-administrators to receive update notifications

    If disable this setting, it will only logged-on administrators receive update notifications.

    Please also follow the path: User Configuration\Policies\Administrative Templates\Windows Components\Windows Update\Remove access to use all Windows Update feature

    If enable this setting, you can configure option: 0-Do not show any notifications. It will remove all Windows Update feature and no notifications will be shown.

    Please check if those two settings can help you.

    à by group policy, it is set to "download but do not install" and windows updates by automatic maintenance is disabled.

    By the way, I guess that you enable Configure Automatic Updates setting and select option “3-Auto download and notify for install”. If select “4-Auto download and schedule the install”, you will be able to schedule the installation of updates in a free time. It may be a better option for maintenance.

    If anything I misunderstand or any update, please don’t hesitate to let me know.

    Hope this helps.

    Best regards,

    Justin Gu

    Monday, October 20, 2014 10:49 AM
    Moderator
  • Thank you for the reply.

    1. The first policy is not applicable because there are no non-admins accessing the server in a remote desktop.

    2. The second policy is not an acceptable solution because it will not allow administrators to access Windows Update.

    3. Changing it to mode "4" will not satisfy the requirements for updating the server, as stated in the original post.  This server must have updates initiated by an outside script due to timing conditions.  It is not the same time every week.

    I need to disable that pop-up (any other notification is fine, including task bar balloon notification).  The problem is that pop-up is too easy to accidentally click "Install" and it pops up every couple minutes even after being dismissed.

    Monday, October 20, 2014 3:15 PM
  • So the prompt is happening about every 15-20 seconds.  I thought it was less often, but maybe I was brain farting earlier.  I made a video.  This is absolutely killing my productivity.  https://www.youtube.com/watch?v=kQe3PdIRp7A


    • Edited by Timothy Carroll Wednesday, October 22, 2014 7:41 PM
    • Proposed as answer by Microrock Tuesday, January 15, 2019 3:46 PM
    • Unproposed as answer by Microrock Tuesday, January 15, 2019 3:47 PM
    Wednesday, October 22, 2014 7:41 PM
  • Did you ever figure out a solution for this?  We have the same problem as you did (do).  Accidentally pressing "Install" causes problems.

    Thursday, November 13, 2014 5:57 PM
  • I never did.  My workaround is to set it to no longer auto download.  It adds 5-15 minutes to the update process, but at least the server is usable.  If I have left over support tickets by the time of our Microsoft Partner anniversary, I'll might burn one to see if they can figure this out.
    Sunday, November 16, 2014 3:49 AM
  • In Group Policy Editor, look for Configuration\Policies\Administrative Templates\Windows Components\Windows Update\Configure Automatic Update and disable it.

    No more pop-ups. Windows update stays available through the Windows Update software.

    Friday, January 8, 2016 9:06 PM
  • That's functionally no different than my other workaround, but is not an actual solution to the problem as updates cannot be staged ahead of time.
    Saturday, January 9, 2016 2:23 AM
  • Hi Timothy,

    Sorry to bump your 4 years old thread but I came across your question because I'm in the same situation as you, only difference is I have a Windows Server 2016. I found a solutions to disable the pop-up without side effects.

    Credits will go to this site:

    https://winaero.com/blog/disable-updates-available-windows-10/

    In short follow these steps:

    Start an elevated command prompt and enter these commands:
    cd /d "%Windir%\System32"
    takeown /f musnotification.exe
    icacls musnotification.exe /deny Everyone:(X)
    takeown /f musnotificationux.exe
    icacls musnotificationux.exe /deny Everyone:(X)

    Tuesday, March 20, 2018 9:18 AM
  • Thanks for the bump.  I'm marking as answer since it's relevant to today's environments and people coming here via search may find it useful.
    Tuesday, March 20, 2018 12:13 PM
  • Talking about a sledgehammer approach haha.

    Then again MS is doing its best at making Windows unusably annoying...

    Friday, August 10, 2018 10:36 AM
  • I assume other people have a glut of 2012, or earlier machines, out there I was about to clear the re-prompt issue, but still get the pop-up on first log-in. I don't want to lose the pre-download updates, but I might.

    Using GPOs:

    First prevent a reboot while your logged on in case you did accidentally hit 'install'
    Folder Id: Software\Policies\Microsoft\Windows\WindowsUpdate\AU\NoAutoRebootWithLoggedOnUsers
        Value:       1, 0, 0, 0
        State:       Enabled

    Folder Id: Software\Policies\Microsoft\Windows\WindowsUpdate\AU\RebootRelaunchTimeout
        State:       disabled

    Folder Id: Software\Policies\Microsoft\Windows\WindowsUpdate\AU\RebootRelaunchTimeoutEnabled
        Value:       0, 0, 0, 0
        State:       Enabled

    Can't believe I'm commenting on a 4 year old thread about a issue on a 7 year old OS, but here we are.

    Tuesday, January 15, 2019 3:57 PM