none
How to set up remote desktop licensing mode in windows server 2012

    Question

  • Hi,

    I've deployed yesterday a windows 2012 server (RTM) and set up the license server for my 10-CAL licenses. That's ok.

    But I can not see a way to point my server to see the license server. Every time I log in, I receive a message that the RD services will expire in 119 days.

    Using the diagnosis tool it says that licensing mode isn't set up.

    Where I can find the tool to set up this licensing mode? In windows server 2008 this question was asked in the setup wizadr.

    Thanks a lot!

    Ricardo Almeida

    Wednesday, September 5, 2012 12:18 PM

Answers

  • I had a similar issue with server 2012, if it was set to per user mode (after the 120 days expired) no user could logon, it would say no license server was available even though the license server was active and it was specified.

    If I switched the mode to per device they could logon but would get a temp device license.

    I called Microsoft support, their solution was as follows, he mentioned there should be a KB article released in the future.

    Issue: Unable to do RDP in per user mode

    Resolution: Deleted the following key from registry HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Grace Period

    Note: Take registry backup before making any changes


    • Edited by kozzy303 Thursday, February 21, 2013 2:36 AM typo
    • Marked as answer by Aiden_CaoModerator Tuesday, March 19, 2013 8:34 AM
    Thursday, February 21, 2013 2:34 AM

All replies

  • http://www.virtualizationadmin.com/articles-tutorials/vdi-articles/general/using-powershell-control-rds-windows-server-2012-Part2.html

    Hope this helps...

    Best regards,

    Wim

    Wednesday, September 5, 2012 3:05 PM
  • Hi Ricardo,

    In Server Manager -- Remote Desktop Services -- Overview -- Deployment Overview -- Tasks -- Edit Deployment Properties.

    -TP

    • Proposed as answer by DMCSOK Monday, February 11, 2013 4:07 AM
    Wednesday, September 5, 2012 3:24 PM
    Moderator
  • Hi TP

    That seems to be my problem. The "Overview" tab says that I am logged in as a local user. This server is set up as a workgroup member, not a domain member. What can I do to remedy this? I understand that I can't promote a licensing server to a domain controller.

    Thanks!

    Wednesday, September 5, 2012 4:17 PM
  • Hi,

    How are things going? I just want to check the status of the issue. If you have any update or concern, please feel free to let us know.

    Best Regards,

    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    • Proposed as answer by Malachi Brown Tuesday, August 4, 2015 3:06 PM
    • Unproposed as answer by Malachi Brown Tuesday, August 4, 2015 3:06 PM
    Thursday, September 13, 2012 2:35 AM
    Moderator
  • Hi Aiden,

    Unfortunately I didn't find yet a way to set up the licensing mode in a W2012 server running in workgroup mode.

    As it was hapenning in a production environment, I've rolled back to 2008 and will install the 2012 in a test server for look this issue more deeply.

    Thank you for your interest!

    Ricardo

    Thursday, September 13, 2012 9:05 AM
  • When I open up the Overview I do not see an option for Deployment Overview. I only have two options on the left pane; Overview and Servers. When I click on Overview the right pane says: "There are no RD Connection Broker servers in the pool. To manage a deployment, you must add all the servers in the deployment to the
    server pool..."

    In Server 2008r2 the Connection Broker was for pooling RD Session Host servers. I am just trying to remote in to this particular server (It will be a virtual host for one of my departments and many people will be remoted in to manage the virtuals, basically a supped up remote Administration is the purpose). I already have a RD Licensing server set up and with my 2008 servers I simply needed to point the Session Host servers to this Licensing server. In the 2012 RD Licensing Diagnoser it suggests to "Set the licensing mode on the RD Session Host server" but doesn't specify how, awesome help.

    I have not yet abandoned the idea that 2012 may not work with 2008r2 Licensing servers. MS has a tendency to not be backward compatible with older licensing servers. Any thoughts?



    Jeh


    • Edited by Jeh1138 Friday, September 21, 2012 9:49 PM
    Sunday, September 16, 2012 4:02 PM
  • Hi,

    This is no direct way to configure the licensing mode in Windows Server 2012 Remote Desktop enviornment. We could configure it via following steps:

    1. Settings that apply to every Remote Desktop Services server in a deployment, such as licensing settings, are configured using the Deployment Properties user interface in RDMS. From this interface and administrator can configure settings for Remote Desktop Gateway, Remote Desktop Licensing, digital certificates, and Active Directory.

    To configure global deployment settings, do the following:

      • Open Server Manager and Click on the Remote Desktop node in the left pane.
      • Click on Collections, and then in the Collections tile, click on the Tasks Menu and then click on Edit Deployment Properties.
      • By default, an RD Gateway server is not configured. To use a RD Gateway server to connect to the servers in the deployment, click on either Automatically Detect RD Gateway server settings or Use these RD Gateway Server settings and specify the FQDN of the RD Gateway server. If the RD Gateway server name is manually configured then the LogOn method must also be set, the default setting is Password Authentication.
      • Click on RD Licensing in the left pane and enter the RD Licensing server name and the Licensing mode. If multiple RD Licensing servers are used then configure the order in which they will be used by using the Move Up or Move Down buttons.
      • Click on RD Web Access in the left pane and modify the URL for the RD Web Access site if you do not wish to use the default site.
      • Click on Certificates to manage certificates for the deployment. Details are in the following section titled Certificate Management.
      • Click on Active Directory in the left pane to configure Active Directory settings. These settings are only required for VDI deployments and virtual machine collections.
      • Click on Export Location and configure the export path for virtual machine collection creation. This setting is only required for VDI deployments and virtual machine collections.

    2. Using Group Policy.

    Thanks.

    Kevin Ni


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, September 18, 2012 5:46 AM
  • I do not see a "Collections" option.  When I click on RDS on the left pane my two options on the right pane are Overview and Servers.  (As was stated in my original post.)

    When I added the Role I went through the Add Roles and Features Wizard and here is what I selected:

      • Role-based or Feature-based installation
      • I selected my server from the list of servers
      • Then from the next list I selected Remote Desktop Services
      • The Wizard prompted me to add in the administration tools and I allowed it to do so
      • Rebooted the server

    It seems that this installation approach might be for environemnts that already have a Connection Broker, Web Access server, and a Virtualization Host server.  I don't want these things.  I just want a to set this server up as a Session Host and for it to connect to my Licensing server to verify CAL usage.  Plain and simple.

    Ater I reboot the server i see a dialog bubble in the system tray that says "RDS will stop working in 119 days.  On the RD Connection Broker server, use Server Manager to specify the Remote Desktop licensing mode and the license server."  When I try to click the bubble to read or get more info it disappears (super helpful).


    Jeh




    • Edited by Jeh1138 Friday, September 21, 2012 5:45 PM
    Thursday, September 20, 2012 3:15 PM
  • I've found only one way to set up licensing mode for simple one server deployment in workgroup scenario. That way is setting up license server in server local policy (gpedit.msc). Policy settings are located in Computer Configuration - Windows Settings - Remote Desktop Services - Remote Desktop Session Host - Licensing. Hope that helps.

    I have a little question about RD Host licensing in workgroup scenario. Is it possible to use Per User license mode in workgroup? As I know it isn't possible in Server 2008R2...

    Anatoly.

    • Proposed as answer by steffen_land Sunday, January 5, 2014 11:33 AM
    Friday, September 21, 2012 7:30 AM
  • Thanks for the lead but ultimately it didn't work.  I did find the setting on the 2012 box in the following location:

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    As I am writing this I am noticing that now the notification bubble is slightly different than it was previously.  It is now saying: "No Remote Desktop license server is available.  Remote Desktop Services will stop working in 119 days if this computer does not contact at least a valid Windows Server 2008 license server.  On the RD Connection Broker server, use Server Manager to verify or configure licensing settings."

    This might be a good sign that it is recognizing the licensing mode but that I haven't installed the 2008 RDS CALs on the licensing server (which I haven't).  I'll try that now and see.

    On a side note I tried twice to add the Broker service to this machine using the method I installed the RD Session Host and both times it failed to complete stating that the server required a reboot.  After the reboot it appeared as if nothing happened with the Broker service.  It was still not there and didn't show up as an installed Role/Feature.


    Jeh


    • Edited by Jeh1138 Friday, September 21, 2012 5:34 PM
    • Proposed as answer by MrSpadge Thursday, November 15, 2012 1:51 PM
    Friday, September 21, 2012 2:44 PM
  • I ended up opening a support case with Microsoft.  You need to use a 2012 Licensing Server to issue 2012 CALs.  I wasn't even able to install 2012 CALs on my 2008r2 Licensing Server.  I was routed through 3 different departments after the Clearinghouse finally understood what I was trying to do and ended up at Tech Support.

    Long story short do not believe what the notification bubbles and the error messages tell you.  You cannot use a 2008 Licensing Server to manage 2012 CALs.  Below is what the RD Licensing Diagnoser told me after I was able to connect the server to my 2008 server using group policy (even though my server has 60 2008r2 CALs installed on it as verified by a seperate 2008r2 RD Session Host server):

    The Remote Desktop Session Host server is in Per User licensing mode and No Redirector Mode, but license server myLicenseServer does not have any installed licenses with the following attributes:
    Product version: Windows Server 2008 or Windows Server 2008 R2
    Licensing mode: Per User
    License type: RDS CALs


    Jeh


    • Edited by Jeh1138 Friday, September 21, 2012 9:48 PM
    • Proposed as answer by Jeh1138 Wednesday, October 24, 2012 6:33 PM
    • Unproposed as answer by Jeh1138 Wednesday, October 24, 2012 6:34 PM
    • Proposed as answer by Trubar Thursday, November 15, 2012 2:47 PM
    Friday, September 21, 2012 9:47 PM
  • Can you specify some more the solution. I got the same problem. I got RDS licencing server in my domain controller (2008R2), since i got  few terminal servers. Can i update licencing server there or do i need to install 2012 RDS licencing server and upgrade some licences?

    thx


    Jeh1138 has it right. You CANNOT use 2008R2 license sever even though the bubble says you can and no gpedit will help you there.....
    • Edited by Trubar Thursday, November 15, 2012 2:48 PM
    Wednesday, October 3, 2012 10:59 AM
  • Server 2012 RTM (both TS and LS)

    Type of Licenses: Per User

    Domain: NOT IN DOMAIN (both TS and LS are in workgroup)

    If above configuration matches your environment, Per USER CALS in 2012 won't work in workgroup. Either change it to Per Device or Use a domain environment.

    Thanks

    Bindusar Kushwaha

    Wednesday, October 17, 2012 9:18 PM
  • Wow, that's way off the beaten path to edit the group policy settings like this. I would expect something similar to 2008R2 where you just specify the license server from the features. Anyway I made the changes you pointed out and it looks like it will work when I call in to activate and assign the licenses. Note I am using a 2012 DC with 2012 License Server.

    Lee

    Saturday, October 20, 2012 11:13 PM
  • From My understanding the system must be on a Domain not a workgroup...
    • Proposed as answer by Hcamacho Friday, July 31, 2015 4:25 PM
    Friday, November 9, 2012 12:14 AM
  • I did find the setting on the 2012 box in the following location:

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    Thanks Jeh, that did the trick for me! Using 2012 RDS CALs on a local Server 2012. And Boy, have I been searching for a solution...

    If MS is reading this: please improve this situation ASAP. Either

    - make the error message more specific about how to actually set the server licensing mode

    - better yet, provide a link to open the UI element needed for this

    - or set this up during license installation

    - or even better: if only licenses of one type have been installed, assume this is the mode the user wants and just use it. You can still issue a warning that the mode has not explicitly been set.

    - and why not allow this setting in the "remote desktop license manager"? It appears to me there is not much you can actually manage in this manager.

    Best regards,

    MrS

    • Proposed as answer by Opwernby Monday, November 26, 2012 10:59 PM
    Thursday, November 15, 2012 1:58 PM
  • Server 2012 RTM (both TS and LS)

    Type of Licenses: Per User

    Domain: NOT IN DOMAIN (both TS and LS are in workgroup)

    If above configuration matches your environment, Per USER CALS in 2012 won't work in workgroup.

    I can not confirm this. As far as I can tell I've got that configuration and after setting the server license mode via gpedit it works for me, using either "per device" or "per user" licenses.

    MrS

    Thursday, November 15, 2012 2:00 PM
  • Worked for me, too... You have to set both of them, and then magically, the License Diagnosis thing reports no errors. Bizarrely, if you look at the RDP:\ area in Powershell, you see nothing different...
    Monday, November 26, 2012 11:00 PM
  • are you getting errors in event viewer? i get event id 1128 but license diagnosis says everything is fine with mine too.
    Thursday, December 6, 2012 3:43 AM
  • Worked for me, too... You have to set both of them, and then magically, the License Diagnosis thing reports no errors. Bizarrely, if you look at the RDP:\ area in Powershell, you see nothing different...

    @Opwernby, which both of them do you need to set so that you can use 'per user' rdp license for a workgroup server? The license server will be installed on the same workgroup server.

    If I setup the policy below, what is the other one you were referring to?

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    Wednesday, January 2, 2013 12:12 PM
  • Hello,

    Thank you all for the tips specified. I have succesfully managed to install RDS Licensing and also the 10 RDS CALS, by specifing the following 2 settings :

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    My Terminal and Licensing Server are both on the same Server, and work in Workgroup / Per User Mode.

     

    Unfortunately, I have another problem:

    Even if Licensing Diagnostics is giving me no warnings or errors and is telling me I have succesfuly installed 10 Licenses and terminal server is correctly configured with License Server, I cannot make more than 2 Users Parallel Connections. It is exactly the same as I have not installed RDS Role.

    Am i missing something? Please help!

    Any further answer will be highly appreciated!

    Thank you!

    childofb0d0m


    • Edited by radu.d Monday, January 7, 2013 7:54 AM
    Monday, January 7, 2013 7:53 AM
  • I forgot to say that I encounter the problem on Windows 2012 Server. I cannot find here rdp-tcp/ propreties/network adapter to set up the maximum connections allowed. 

    Can I make this change from Windows Registry? Or do you have any other idea why I am encountering this problem?

    Thank you!


    childofb0d0m

    Monday, January 7, 2013 9:19 AM
  • set server GPO

    You can also specify a license server for the RD Session Host server to use by applying the Use the specified Remote Desktop license servers Group Policy setting. This Group Policy setting is located in Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Licensing and can be configured by using either the Local Group Policy Editor or the Group Policy Management Console (GPMC). Note that the Group Policy setting will take precedence over the license servers configured in Remote Desktop Session Host Configuration.

                                     technet.microsoft.com/en-us/library/cc731185.aspx

    but you can find it and set at server 2012Gpo even is domain (cn't find in 2008 Gpo),

    for 2008R2 im not try

    and my wim2012 is Domain and Terminal server is on it.

    • Proposed as answer by Dr.Mabuse Saturday, March 28, 2015 6:16 PM
    Thursday, January 10, 2013 10:47 PM
  • Thank you for your answer.

    I have already specified under gpedit.msc (Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Licensing ) the Licensing Server and Per User mode. After that Licensing Diagnosis gives no more errors, everything is green, Licensing Server is discovered, RDS CALS are also available. But still no more than 2 users can connect simultaneously.

    Am I missing something?



    childofb0d0m

    Friday, January 11, 2013 8:54 AM
  • hi,are you add allowed users to list of RDP users.

    right click at computer,properties,advance,

    then remote tab add users

    Sunday, January 13, 2013 9:34 PM
  • have you tried per device instead of per user? if you're in a workgroup instead of a domain this will work better
    Monday, January 14, 2013 2:03 PM
  • im use per device ,

    but bouth need to add security list of users can acces it over RDP.

    (

    if no more users at list , only two admins users , can access at same time

    )

    Thursday, January 17, 2013 6:23 AM
  • I agree.  These settings seem so obscure.  I hope that are actually working, as the server I am using is now and is under the grace period.  I also am using a single 2012 server, in a workgroup, not a domain.  Why is simple so complicated?
    Monday, February 11, 2013 1:07 AM
  • i'm in the same boat. I couldn't get it to work properly in per user mode but it seems to be working fine in per device. no messages on screen or in event viewer. Started the server on 11/3/12 so I guess I'll find out soon.
    Monday, February 11, 2013 4:06 PM
  • Hello radu.d,

    In order to be able to connect to a session host with more than 2 concurrent connections, you need to change one more setting in the Group policy on the seesion host itself.

    Within gpedit.msc, navigate to - 

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Connections

    Then find the "Restrict Remote Desktop Services users to a single Remote Desktop Services session" and disable it,

    Changing this setting will now allow more than 2 connections to that session host and hopefully resolve your problem!

    This has been driving me insane for the last few days, but I finally have got it working.

    The only problem with configuring all of these RDS settings without being in a Domain, is that the reporting and usage stats for the CALS doesn't work. 

    No matter how many connections to any of the session hosts there are, whenever I run a report on the CAL usage on the Licensing Server, it always comes back and tells me that I have all of them available in the pool. Which can't be right?

    Does anybody know if this is correct, or am I missing something else out?

    Thanks in advance!


    Anthony

    Friday, February 15, 2013 12:20 PM
  • Hi Anthony,

    Thank you very much for your reply. In the meantime, I have installed Windows 2008 R2 configured it with RDS and everything is working perfectly, but until mid year I will need to upgrade to 2012 anyway.

    So, I am still interested in how can be figured out this issue. I have reinstalled RDS on my Win 2012 Essentials, and I have activated this option.

    Unfortunately it still doesn't allow more than 2 users to connect. Now I don't have any more a License Server configured, but still it needs to work as I am still in grace period.

    I have also tried with Per Device, but still not working.

    It is possible that also my Windows 2012 version (Essentials) could not be working with RDS ? 

    Thank you very much!



    childofb0d0m

    Friday, February 15, 2013 1:44 PM
  • Hi radu.d,

    No problem at all, 

    When you say that you have activated the setting I suggested, did you enable it? If you did ENABLE the setting it will definitely not allow you to have more than 2 concurrent sessions. You have to DISABLE the setting for it to work properly.

    From my understanding Server 2012 essentials should support RDS features out of the box. 

    Let me know how it goes.

    Thanks

    Anthony

    Friday, February 15, 2013 2:23 PM
  • Hi,

    It was initially enabled, but I have DISABLED it, and it doesn't worl :(

    I don't have any other idea!

    Thank you!


    childofb0d0m

    Friday, February 15, 2013 3:18 PM
  • I had a similar issue with server 2012, if it was set to per user mode (after the 120 days expired) no user could logon, it would say no license server was available even though the license server was active and it was specified.

    If I switched the mode to per device they could logon but would get a temp device license.

    I called Microsoft support, their solution was as follows, he mentioned there should be a KB article released in the future.

    Issue: Unable to do RDP in per user mode

    Resolution: Deleted the following key from registry HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Grace Period

    Note: Take registry backup before making any changes


    • Edited by kozzy303 Thursday, February 21, 2013 2:36 AM typo
    • Marked as answer by Aiden_CaoModerator Tuesday, March 19, 2013 8:34 AM
    Thursday, February 21, 2013 2:34 AM
  • It's correct that is the solution. To me work fine.
    Tuesday, March 19, 2013 2:44 AM
  • This a helpful configuration. 
    Tuesday, March 19, 2013 8:09 AM
  • We're having the same licensing server problems with a new Windows Server 2012 installation !

    Strange thing, I can't remove the Grace Priod key.

    Anyone has a solution ?

    Sunday, March 24, 2013 8:34 AM
  • I did find the setting on the 2012 box in the following location:

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    ^^^ This solved it for us.  Why we have to change settings in local GPO for a server that is on a domain......and even is itself the activated license server in AD for 2012 is beyond me.  Server 2008 R2, Server 2008, Server 2003 R2 and server 2003 never had these issues.

    Friday, March 29, 2013 12:01 AM
  • Hi

    Deleting key from registry help with situation. But still in Event Log I can see message 1130 TerminalServices-RemoteConnectionManager to set license server for host (with some Manager witch I coludn't find). When looking into diagnose license server it shows that everything is all right. Server is configured and there are 10 of 10 CALs free. And this is strange because we are connecting to this server via RDP.

    So, diagnose shows that everything is OK, but still are some warnings in Event Log and licenses seems not to be used.

    Best Regards

    Przemysław Staniszewski

    Thursday, April 4, 2013 8:09 AM
  • can you give me a little more info about the manager that you didn't name? not sure if I can help but if I can I will.
    Thursday, April 4, 2013 1:44 PM
  • I'm using Polish version so I don't know how to Menedżer konfiguracji hosta sesji pulpitu zdalnego would be in English.

    Also i curious  about Overview and Servers. I have read somewhere that server should be added to collection. But in Overview i have blue message that I'm using local administrator user account. To manage servers and collections I should log in as domain user. This is small network without any Active Directory.  The server is Windows 2012 Standard with 10 CAL.

    The message 

    Nazwa dziennika:System
    Źródło:        Microsoft-Windows-TerminalServices-RemoteConnectionManager
    Data:          2013-04-04 09:43:34
    Identyfikator zdarzenia:1130
    Kategoria zadania:Brak
    Poziom:        Ostrzeżenia
    Słowa kluczowe:Klasyczny
    Użytkownik:    Nie dotyczy
    Komputer:      kx-server
    Opis:
    Nie określono serwera licencji usług pulpitu zdalnego dla serwera hosta sesji pulpitu zdalnego. Aby określić serwer licencji dla serwera hosta sesji pulpitu zdalnego, użyj Menedżera konfiguracji hosta sesji pulpitu zdalnego.
    Kod XML zdarzenia:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-TerminalServices-RemoteConnectionManager" Guid="{C76BAA63-AE81-421C-B425-340B4B24157F}" EventSourceName="TermService" />
        <EventID Qualifiers="49152">1130</EventID>
        <Version>0</Version>
        <Level>3</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-04-04T07:43:34.000000000Z" />
        <EventRecordID>54038</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>System</Channel>
        <Computer>removed :)</Computer>
        <Security />
      </System>
      <EventData>
      </EventData>
    </Event>

    Best Regards

    Przemysław Staniszewski

    Friday, April 5, 2013 5:38 AM
  • Strange. Today I don't have this message. Even after reboot Windows. Yesterday all configuration has been done. But in available licenses are still 10 for 10 even if remote user is logged. 
    Friday, April 5, 2013 5:44 AM
  • i would watch it and not change anything right now. if you are in a workgroup environment you have to change group policy instead of using the terminal services gui. are you showing any used licenses?  when i first logged on from a remote desktop i had to log on as an administrator of that terminal to get the certificate. once I did that  I had no problem. It gives me a temporary that renews automatically every 60 days or so. It's been working fine and it always renews. I am set up for per device and not per user. I installed the server 11/03/13 and it seems to be working well.
    Friday, April 5, 2013 1:59 PM
  • Hi

    What that mean? "if you are in a workgroup environment you have to change group policy instead of using the terminal services gui" . What I should to change by group policy?

    Can I see any used licenses? No. I Can see Windows Server 2012 10 of 10 licenses and Windows 2000 Server unlimited build in licenses.

    How could I check utilization of temporary licenses? For this two licenses in exposed I have 0 and still connecting remotely. 

    Monday, April 8, 2013 6:54 AM
  • if you don't have active directory you're in a workgroup environment. There are several posts on here that will lead you in the right direction as far as the changes that need to be made in group policy. gpedit.msc. once it is set up correctly your license server will issue licenses to devices if it is set up to work that way. I couldn't get things to work properly issuing licensing on a per user basis but everything works great on a per device basis. if you google terminal services in a workgroup environment 2012 server you'll find a lot of info. I'd start here  http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/cbffb2d4-ff9d-49ee-a9ce-a60db2262422/ and you should be well on your way to sorting things out.
    Monday, April 8, 2013 2:38 PM
  • There is article http://support.microsoft.com/kb/2833839 but it's not working with me.
    Friday, April 19, 2013 11:24 AM
  • did you choose per device or per user? it will not work for per user.
    Friday, April 19, 2013 12:36 PM
  • I have 5 licenses per user and per device.

    After remove borker role now there are only TermServLicensing and TermService services.

    Those 2 methods throws Invalid operation Exceptions

    $obj.ChangeMode(4)
    $obj.SetSpecifiedLicenseServerList("LicServer")

    Best Regards

    Przemysław Staniszewski

    Friday, April 19, 2013 12:58 PM
  • I broke terminal services when I first installed the server and had to re-install everything. I think it broke when i tried to set up connection broker. Once I reinstalled everything i was able to get terminal services working correctly without connection broker.
    Friday, April 19, 2013 1:35 PM
  • What do You mean everything? All remote desktop roles and functions?
    Monday, April 22, 2013 1:13 PM
  • i mean everything. windows 2012 server from the beginning. When I set it up the second time I got remote desktop working before i reinstalled everything else and then made an image so that if it blew up again i wouldn't have to start over. I re-image the system at least once a month now and do nightly backups but everything is working fine right now.
    Monday, April 22, 2013 1:26 PM
  • It's not so easy. If we understand well MAPS licence for windows server 2012 once installed it can't re installed  even if there wasn't any change in hardware configuration.

    By the way, can backup of windows 2012 be restored? If yes, we should done backup right after install to escape from that restriction.

    Monday, April 22, 2013 1:34 PM
  • Once again

    Those 2 methods throws Invalid operation Exceptions

    $obj.ChangeMode(4)
    $obj.SetSpecifiedLicenseServerList("LicServer")

    And I feel I stuck. Only solution even with Microsoft KB article is to delete GracePeriod key and reboot server or install AD in virtual machine or buy second computer with second windows server license.

    Best Regards

    Przemysław Staniszewski

    Monday, April 22, 2013 1:49 PM
  • if you did an image it can be reinstalled. i'm not sure about a regular backup fixing it if it's broken. I had to call microsoft and redo the licensing. you could also do a vm for ad but that's a lot of extra headache just to get remote desktop to work.
    Monday, April 22, 2013 1:55 PM
  • Hi

    I made some test and confirm that per device working well in workgroup schema.

    On clean Windows 2012 server you can call and this not returning error. 

    $obj.ChangeMode(4)
    $obj.SetSpecifiedLicenseServerList("localhost")

    But this not working.

    So after you configure gpedit with instruction from this article and restart computer it license per device will be used. So I made another test and change via gpedit to per user and trying to call

     $obj.ChangeMode(4)
    $obj.SetSpecifiedLicenseServerList("localhost")

    I have got Exception from my previous posts. 

    Once you configure Windows 2012 as standalone RDS per device and trying change to per user old and new machines can't connect to it. You must fall back to previous setting.

    I wonder also about licensing issue. How it works? If client buy RDS and activate them as per user can he convert it to per device? Person in Microsoft telephone support tells me Yes but only if You bought Software Assurance and it expired and You renew. So if Software Assurance is for 2 years you can convert after this 2 years (not eariel which is surprise for me) and only if You buy new Software Assurance.

    Can somebody confirm that? I never used Software Assurance.

    Best Regards

    Przemysław Staniszewski
    Tuesday, May 7, 2013 7:03 AM
  • What is all about? Dose Windows 2012 Server must be in Active Directory and this enough, or it's about License Server can't be installed on the same machine where RDS services are.

    So I have old machine with Windows 2008R2, which could be AD Controller so License Server will be installed on Windows 2012 which is server for RDS. Is this good enough scenario to set up RDS running on license per user?

    Best Regards

    Przemysław Staniszewski

    Tuesday, May 7, 2013 9:27 AM
  • I was solving similar problem, single server 2012 Foundation in a workgroup, per user CALs. Thanks to the solution described above:

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    I got the server to correct shape, but my users still could not access server via RD. Then I read the topic in this link http://support.microsoft.com/kb/2833839?wa=wsignin1.0 and I noticed that I have "Remote Desktop Connection Broker role" installed, which, according to the topic, should not be in my case. So I uninstalled this role, and now everything seems to work OK.


    • Edited by Jan Curda Thursday, May 23, 2013 7:51 AM
    Thursday, May 23, 2013 7:49 AM
  • I had a similar issue with server 2012, if it was set to per user mode (after the 120 days expired) no user could logon, it would say no license server was available even though the license server was active and it was specified.

    If I switched the mode to per device they could logon but would get a temp device license.

    I called Microsoft support, their solution was as follows, he mentioned there should be a KB article released in the future.

    Issue: Unable to do RDP in per user mode

    Resolution: Deleted the following key from registry HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Grace Period

    Note: Take registry backup before making any changes


    this solution prevented me from setting up a new terminalserver environement. i could not delete the registry key while running the server as the key was somehow protected.

    i had to boot the server from a winPE, and load the registry offline:

    • Start REGEDT32
    • Highlight the HKEY_LOCAL_MACHINE-window and select the root of the tree
    • In the menu select "Registry" -> "Load Hive"
    • Select the wanted registry database file:
      • [HKEY_LOCAL_MACHINE \SYSTEM] (%windir%/system32/config/system)
    • Name it somehow
    • Modify Registry, unload hive, reboot the system.

    hope that helps.


    Stefan Gabriel

    Sunday, June 23, 2013 4:11 PM
  • So we can only use 2012 RDS User Cals on a Domain and Not a Workgroup?
    Friday, June 28, 2013 1:15 PM
  • When I look back to this problem I can see the best solution was install Windows 2012 as AD controller in Hyper-V on the same physical machine.  Windows 2012 Standard license allows that.
    Friday, June 28, 2013 2:05 PM
  • I experienced the same problem with the RDC Licensing Server being "unavailable." I tried deleting the registry key HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Grace Period, but was unable to do so because of a permissions issue. As a guess, I right-clicked on the key and examined the Permissions settings. They were read-only, even for the Administrator. I changed the settings to give the Administrator full permission on the key, after which I was able to delete it.

    Once deleted, I restarted the server and the problem I was having disappeared.

    As others on this thread, I am not using a domain controller; the server is part of a workgroup. I do not understand the reasoning for making RDC dependent on a domain; this seems to be a step backward relative to Server 2008 R2. Regardless, I used the Policy edits described elsewhere in this thread when setting up the server some time ago, since the RDC administrative plug-in will not function in a non-domain environment. It appears I did the original setup on this RDC installation 121 days ago, hence the fix here may not be permanent. During the past four months, I have received no warning that the 120 day grace period clock was running. Nothing in the Event Log either until this morning, when the server stopped accepting RDC log-ins.

    So, 120 days from now I may have the same problem. I hope I remember what I did to fix it!

    Perhaps Server 2012R2 will return Workgroup capabilities to the mainstream RDC setup system.

    As an aside, other users on this thread have noted the requirement to use Per Device licensing when using the Workgroup mode. I have been using Per User licensing on my system and it has worked fine (today's "Grace Period" issue notwithstanding). I know that other users have had different experiences, however.

    With the release of Server 2012R2 coming up later this year, I may rethink the domain controller RDC situation. I would be interested in thoughts folks have on that.

    Thanks...

    Friday, June 28, 2013 8:39 PM
  • I'm having a similar issue with Server 2012 where no RDP users can login.  Error message pops up stating there is no license server available even though the license server is active and it was specified.  Users were able to access this server prior to the expiration of the grace period.

    I have installed RDS within Windows 2012. I have installed the license manager locally on the server (Installed RDS Per User Cal) and have successfully activated the license server.

    Referring to the "fix" above regarding the deletion of the "Grace Period" key:

    Unfortunately, I am unable to change the permission on the Grace Period key thus allowing me the option to delete the key.  I am logged into the server as a Domain Admin and Windows Security is reporting that Access is denied.  Any suggestions?

    Thanks

    Tuesday, July 9, 2013 8:26 PM
  • Hi Postrows

    I've had the same issue. I could delete the key by booting the Server from a winPE (for example HirensBootCD, UltimateBootCD, ...) and delete the key offline while the RDS Servers Registry was not in use. hope you did not encrypt your disk with bitlocker..:

    this solution prevented me from setting up a new terminalserver environement. i could not delete the registry key while running the server as the key was somehow protected.

    i had to boot the server from a winPE, and load the registry offline:

    • Start REGEDT32
    • Highlight the HKEY_LOCAL_MACHINE-window and select the root of the tree
    • In the menu select "Registry" -> "Load Hive"
    • Select the wanted registry database file:
      • [HKEY_LOCAL_MACHINE \SYSTEM] (%windir%/system32/config/system)
    • Name it somehow
    • Modify Registry, unload hive, reboot the system.

    hope that helps.


    Stefan Gabriel

    Tuesday, July 9, 2013 8:34 PM
  • Thanks for the lead but ultimately it didn't work.  I did find the setting on the 2012 box in the following location:

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    As I am writing this I am noticing that now the notification bubble is slightly different than it was previously.  It is now saying: "No Remote Desktop license server is available.  Remote Desktop Services will stop working in 119 days if this computer does not contact at least a valid Windows Server 2008 license server.  On the RD Connection Broker server, use Server Manager to verify or configure licensing settings."

    This might be a good sign that it is recognizing the licensing mode but that I haven't installed the 2008 RDS CALs on the licensing server (which I haven't).  I'll try that now and see.

    On a side note I tried twice to add the Broker service to this machine using the method I installed the RD Session Host and both times it failed to complete stating that the server required a reboot.  After the reboot it appeared as if nothing happened with the Broker service.  It was still not there and didn't show up as an installed Role/Feature.


    Jeh

    Wow, Thanks, this somewhat convoluted solution "seems" to have fixed my problem, at least the balloon is gone :P  The licenses don't show they are being used though, so I remain suspicious...

    Local computer policy... I never would have found that!

    BG


    Thursday, July 11, 2013 10:03 PM
  • Hello All,

    (Date:13th Aug 2013) NOTE: You don't need to be a part of a domain to use RDS - it works with work group too.

    Please follow this article and it will work for you: http://support.microsoft.com/kb/2833839

    As I understand reading this post - most of us missed this step to Configure the Remote Desktop Session Host role with to use the local Remote Desktop Licensing server. Follow these steps:

    1. Open an elevated Windows PowerShell prompt
    2. Type the following command on the PS prompt and press Enter:

      $obj = gwmi -namespace "Root/CIMV2/TerminalServices" Win32_TerminalServiceSetting
    3. Run the following command to set the licensing mode: 
      Note: Value = 2 for Per device, Value = 4 for Per User

      $obj.ChangeMode(value)
    4. Run the following command to replace the machine name with License Server:

      $obj.SetSpecifiedLicenseServerList("LicServer")
    5. Run the following command to verify the settings that are configured using above mentioned steps:

      $obj.GetSpecifiedLicenseServerList()

      You should see the server name in the output.

    Thanks,

    Vic

    Tuesday, August 13, 2013 7:44 AM
  • I have the same problem. However regedit refuses to delete the Grace Period key. I tried stopping the remote desktop services but that did not help.

    Tuesday, September 3, 2013 9:43 AM
  • Hi William Van der Sypt,

    You need to change the Owner of the Key and then set Administrator with Full Rights. To do this,

    Right click the key Grace Period, Permission -> Click Advance -> Change the owner to Administrator. Press OK -> OK -> OK.

    Then Right Click the key Grace Period -> Permission -> Click Advance -> Double Click the Administrators -> Select Full Control. Press OK -> OK -> OK.

    Now try to delete it.

    Friday, September 20, 2013 2:30 PM
  • worked for me too.

    i cant believe this is STILL not fixed !!!

    Thursday, October 17, 2013 10:06 AM
  • I have the same problem here:

    The Remote Desktop Session Host server is in Per User licensing mode and No Redirector Mode, but license server <servername>does not have any installed licenses with the following attributes:
    Product version: Windows Server 2008 or Windows Server 2008 R2
    Licensing mode: Per User
    License type: RDS CALs

    I'm using Server 2012 and suddenly this happened. I dont know why, it seems to be a problem related to the Licence Server, because I was able to test in another environment. However, maybe its one more windows 2012 issue . The users can connect normally and no other messages related to are present.

    Any ideas ?

    Saturday, October 19, 2013 11:06 PM
  • i was never able to get per user mode to work correctly without ad. i use per device mode and it works great.you might want to try per device instead of per user. you can change it because i did once i figured out i couldn't get everything to work without per device. mine has been working fine since last november in per device mode. i get temporary  licenses but they renew and i've had no problems at all otherwise. i just tried an android tablet friday with microsoft remote desktop for android and it issued a license for the tablet set up this way with no problems.
    • Edited by badhabit_wb Sunday, October 20, 2013 1:21 PM
    Sunday, October 20, 2013 3:40 AM
  • thanks for the answer. Unfortunately I bought the user licences, so I supose this should be working to avoid any licence problems. However, 2012 server has a lot of bugs, and maybe this is just one more. Bad.. :(
    Sunday, November 10, 2013 9:27 PM
  • you can change the per user license to per device. that's what I did and it's been working fine this way for almost a year.
    Sunday, November 10, 2013 10:19 PM
  • Thanks for the lead but ultimately it didn't work.  I did find the setting on the 2012 box in the following location:

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    Jeh


    Jeh,

    Thank you so much! This fixed my issue. Once I did this I had no issues with my RD Licensing server and it saw the licenses I have installed.

    Thanks again!

    Dennis

    Wednesday, November 13, 2013 9:37 PM
  • I'm working with several hundred Windows servers running Remote Desktop Services (and Citrix) without access to AD GPOs. I found log in into a server and use gpedit painful.

    I created a tool to report TS/RDS settings and change RDS license mode or assign license servers with a simple right click.

    i

    The tool is available to download at http://tsandrdslicensemanager.ctxadmtools.com

    Guillermo Musumeci

    CtxAdmTools

    Monday, November 18, 2013 12:25 AM
  • This fixed my issue as well S2k12 R2
    Monday, January 13, 2014 2:17 AM
  • Thank you for the solution!

    I had the similar problem on Server 2012 R2. although this is a DC, I've got the same error.

    Just to note that in case the server is DC, you make the changes not in Local Computer Policy but in Group Policy under Default Domain Controllers Policy>Computer Configuration>Policies>Administrative Templates>etc...


    System Administrator

    Wednesday, January 29, 2014 11:54 AM
  • I get Access is denied when I'm trying to delete the Grace Period Key from the registry!!

    .. Current stated of machine is  remote desktop services is uninstalled and remote access to the machine is enabled however I still can't RDP into the machine.. I can ping the port just fine

    Wednesday, January 29, 2014 9:36 PM
  • Is this really still the best answer?  Nobody else has resolved this issue through a patch or advice from Microsoft?  I mean, sure, I'll delete the registry key if I have to... But just wanted to check in since it's been a year and now I'm having this issue with a Windows Server 2012 machine.

    Remote Desktop License server is Activated, configuration "OK", 6 licenses installed, Per User... 

    Tuesday, February 25, 2014 5:18 AM
  • Hi, you can try this here link

    It worked for me using psexec option

    regards,

    
    

    Thiago Beier Se foi útil marca como resposta! Don´t forget to mark as answer!

    Wednesday, February 26, 2014 2:47 PM
  • Hotfix released for this issue:

    http://support.microsoft.com/kb/2916846

    Tuesday, March 18, 2014 1:33 AM
  • The Hotfix did not work for me.

    The only way I was able to resolve this was to temporary set the License Mode to “Device” and then change back to “user” after reboot.

    For now I am no longer getting any grace period notification, hope it stays that way.

    Thursday, July 17, 2014 11:00 AM
  • Here is the solution to configure the TS License servers in windows server 2012 R2.

    1.Open an elevated Windows PowerShell prompt
    2.Type the following command on the PS prompt and press Enter:

    $obj = gwmi -namespace "Root/CIMV2/TerminalServices" Win32_TerminalServiceSetting

    3.Run the following command to set the licensing mode:
    Note: Value = 2 for Per device, Value = 4 for Per User

    $obj.ChangeMode(value)

    4.Run the following command to replace the machine name with License Server:

    $obj.SetSpecifiedLicenseServerList("LicServer")

    5.Run the following command to verify the settings that are configured using above mentioned steps:

    $obj.GetSpecifiedLicenseServerList()

    You should see the server name in the output.

    But I found that in HDC Servers I am not able to see communication to TS License server.

    Thursday, September 11, 2014 10:33 AM
  • I had a similar issue with server 2012, if it was set to per user mode (after the 120 days expired) no user could logon, it would say no license server was available even though the license server was active and it was specified.

    If I switched the mode to per device they could logon but would get a temp device license.

    I called Microsoft support, their solution was as follows, he mentioned there should be a KB article released in the future.

    Issue: Unable to do RDP in per user mode

    Resolution: Deleted the following key from registry HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Grace Period

    Note: Take registry backup before making any changes


    Deleting the grace period and restarting server solved our issue. Thank you so very much.
    Wednesday, September 24, 2014 12:34 PM
  • setting up server farm and this is still a problem! Holy shit MS what are U doing here?dumb dumb dumb.
    i have domain

    i cant delete reg key on one server others did not fixed.

    solution; install broker, host and web roles on one server. Perfect license tool says ok! one down 3 to go

    All the other crap listed here was waste of time. no servers working



    • Edited by wilspin Wednesday, September 24, 2014 8:02 PM
    Wednesday, September 24, 2014 7:48 PM
  • tried to configure other 3 server same as working one. They all adopt the working server as broker and do not work.

    Conclusion you can only HAVE ONE SERVER WORKING!

    Wednesday, September 24, 2014 8:35 PM
  • tried to configure other 3 server same as working one. They all adopt the working server as broker and do not work.

    Conclusion you can only HAVE ONE SERVER WORKING!

    wilspin,

    Please create a new question on the forum and describe your environment, the issue you are having, error messages you are seeing, etc., and we will assist you.

    Thanks.

    -TP

    Wednesday, September 24, 2014 8:44 PM
    Moderator
  • spent more time removing broker roles on 3 non working and deleteing reg key STILL NO!
    Wednesday, September 24, 2014 8:58 PM
  • Thank You Mr. S.

    Fixed!!

    I was thrashing around 2012 server trying to find the correct GUI, Your inclusion of gpedit helped me tie it all together. On my 2012 server entering gpedit did not cut it, I had to type the entire file name with extension (gpedit.msc) and voila! I was at the correct GUI and then followed the rest of the steps

    Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    BAM!

    edit -- My server is not in a domain ... it is stand alone

    Wednesday, October 8, 2014 3:49 PM
  • GPEDIT.msc from Run.

    then set above configuration

    Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User.

    if your server is not in domain use powershell  and paste

    $obj = gwmi -namespace "Root/CIMV2/TerminalServices" Win32_TerminalServiceSetting

    $obj.SetSpecifiedLicenseServerList("myservername").

    this will work and you don't need a domain server

    • Proposed as answer by Zycom Tech Friday, January 23, 2015 4:44 PM
    Friday, January 16, 2015 11:36 AM
  • After reading this discussion, and configuring the server with a local policy, I discovered that I could open tsconfig.msc on a 2008 R2 server and connect to the 2012 server.  At that point, I could see the effect of the local policy and presumably configure it manually if the policy setting were not enabled.


    Monday, January 26, 2015 6:43 PM
  • Friday, March 6, 2015 8:22 AM
  • Thanks.

    Monday, March 16, 2015 3:48 PM
  • After deleting the grace period folder what do I need to do?  I am still getting an error trying to rdp into the server.
    Thursday, March 19, 2015 6:25 PM
  • Thanks Friend, i have been in trouble for a long time to get this solution that my stores are running in 2012 and in work group. I did the changes as as you mentioned and started working properly.

    Thanks.

    gpedit.msi

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername ( i set my server name)

    "Set the Remote Desktop licensing mode" = Per User

    Tuesday, April 21, 2015 9:16 AM
  • Worked for me.

    Thank you so much for sharing.

    Tuesday, April 28, 2015 6:25 PM
  • September 21, 2012, Jeh1138 had the first entry on this forum for the solution that works for me too.
    It was repeated by Opwernby Nov. 26, 2012... and many times after.

    Give them your vote.

    After days of brain racking and reading all about RDS on a server 2012 workgroup,
    it's seems like my torture is over.


    I wish I had found this forum earlier, way earlier before considering retiring without a warning.

    &?%$&%* MS server can make a techy creazy more efficiently than a love crush.

    Thanks to all the ONE who posted and help save my sanity. Now I can cancel my psy appointment unless I 
    dig in Hyper-V install a DC and a RDS server instance in a VM.   Na!

    I wonder if installing the certificate as I did (trying many things) and explained here was necessary

    http://ryanmangansitblog.com/2013/10/30/deploying-a-rdsh-server-in-a-workgroup-rds-2012-r2/ 



    • Edited by mgascon Friday, August 14, 2015 6:38 PM
    Friday, August 14, 2015 6:31 PM
  • I applied the solution above but it is only a temporary fix. It actually reset the Grace Period back to 120 days. I do not want to do this every 120 days. I have a 5 user license this has happened before with another Dell server I have and it took 5 Dell technicians and 2 engineer level technicians to resolve permanently. BUT they charge by the server to work the same issue on another server. I know there is a permanent fix. Does anyone know what it is short of removing and reinstalling program???

    Steady Sailing

    Monday, August 31, 2015 12:15 AM
  • Hi i know is an old post but maybe will help someone,

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing
    "Use the specified RD license servers" = myservername
    "Set the Remote Desktop licensing mode" = Per User or per device

    Have a nice day



    • Edited by GUZAK Friday, October 9, 2015 10:32 AM
    Friday, October 9, 2015 10:28 AM
  • Thanks for the lead but ultimately it didn't work.  I did find the setting on the 2012 box in the following location:

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    As I am writing this I am noticing that now the notification bubble is slightly different than it was previously.  It is now saying: "No Remote Desktop license server is available.  Remote Desktop Services will stop working in 119 days if this computer does not contact at least a valid Windows Server 2008 license server.  On the RD Connection Broker server, use Server Manager to verify or configure licensing settings."

    This might be a good sign that it is recognizing the licensing mode but that I haven't installed the 2008 RDS CALs on the licensing server (which I haven't).  I'll try that now and see.

    On a side note I tried twice to add the Broker service to this machine using the method I installed the RD Session Host and both times it failed to complete stating that the server required a reboot.  After the reboot it appeared as if nothing happened with the Broker service.  It was still not there and didn't show up as an installed Role/Feature.


    Jeh


    Just wanted to say thanks. Configuring the license server and mode under local computer policy did the trick for me on a Server 2012 R2 box.
    Sunday, October 25, 2015 7:37 AM
  • Exactly the same for me!!!

    Thanks Jeh, that did the trick for me! Using 2012 RDS CALs on a local Server 2012. And Boy, have I been searching for a solution...

    If MS is reading this: please improve this situation ASAP. Either

    - make the error message more specific about how to actually set the server licensing mode

    - better yet, provide a link to open the UI element needed for this

    - or set this up during license installation

    - or even better: if only licenses of one type have been installed, assume this is the mode the user wants and just use it. You can still issue a warning that the mode has not explicitly been set.

    - and why not allow this setting in the "remote desktop license manager"? It appears to me there is not much you can actually manage in this manager.

    Best regards,

    SM


    • Edited by SirManor Friday, October 30, 2015 12:09 PM
    Friday, October 30, 2015 11:55 AM
  • What I wanted was the simplest installation that allowed for more than the built-in "two client connection limit" on my W2K12-R2 workgroup (not domain) computer.

    I made the following screen shots to maybe save someone else the many hours it took me to figure this one out. Hope it helps someone else!

    ________________________________________________________________________________________________________________

    • Proposed as answer by Stancey Sunday, January 22, 2017 8:55 AM
    Saturday, January 2, 2016 5:10 AM
  • Dear Byron K 

    Thanks a Lot these steps only worked, else registry...etc not worked in my case.

    thanks very much

    Tuesday, January 12, 2016 7:49 AM
  • license installed successfully and recognized certinho the license number per device, the managed however the only thing that did not work not bound when user accessed the server via RDP.
    Tuesday, January 12, 2016 12:41 PM
  • This worked beautifully.  I had the same issues and it fixed the issues.

    Bill Bollinger

    Wednesday, May 11, 2016 2:26 PM
  • If you have the Mode or the License Server List defined by policy you will receive this error message when you try to set it by these WMI commands.

    You can confirm that using gpedit.msc, in

    Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing,

    -> Use the specified Remote Desktop license servers

    -> Set the Remote Desktop licensing mode

    Regards,

    Cassio.

    Wednesday, July 6, 2016 6:54 PM
  • nice. working now.

    ty.

    Monday, September 5, 2016 1:34 PM
  • Byron K , did the steps, rebooted, it works! Thank you!
    Tuesday, December 6, 2016 6:49 PM
  • I think its high time that window server to see over this error, I am breaking my head on this, though tried to fix with many methods like RD licensing and grace period, I am left with with no positive results. :( :( 
    Wednesday, December 20, 2017 2:27 PM
  • same bro ... worked but no result . 
    Wednesday, December 20, 2017 2:28 PM
  • I think its high time that window server to see over this error, I am breaking my head on this, though tried to fix with many methods like RD licensing and grace period, I am left with with no positive results. :( :( 

    Hi geek2323,

    Please create a new question describing your environment, the issue you are experiencing, error messages, symptoms, things you have already tried, etc., and we will assist you.

    Thanks.

    -TP

    Wednesday, December 20, 2017 2:41 PM
    Moderator
  • Thanks for the lead but ultimately it didn't work.  I did find the setting on the 2012 box in the following location:

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Licensing

    "Use the specified RD license servers" = myservername

    "Set the Remote Desktop licensing mode" = Per User

    This seems to have done it for me.

    This Tech Guy

    Wednesday, February 7, 2018 7:47 PM