SSTP VPN on IPv6 Netowork


  • Hi Everyone

    I'm having a hard time trying to configure a IPv6 SSTP VPN on server 2008. I found out its a bit different from the IPv4 especially the routing and remote access part of the configuration. In the IPv4 network i didn't have a DHCP server to server client who's trying to access a SSTP connection with IPv4 address but i did put down scope of address in the RRAS configuration to do that. Now in IPv6 i can't find any configuration part which will allow me to do put down a range of IPv6 address to give to the client.


    Can someone please help me out, I did found a documentation with this technet but it was only for IPv4 i'm looking for some help setting this up on IPv6




    Sunday, September 26, 2010 10:29 PM

All replies

  • Hi,

    Please understand that we should configure IPv6 Prefix assignment in the IPv6 tab. Prefix Advertisement (or Router Advertisement) is an IPv6 feature where routers (or in this case the ASG) behave like a DHCP server in IPv4.

    For more information, you could search for "IPv6" in the following article and check the related information.

    Hope this helps.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, September 27, 2010 9:43 AM
  • Hi Miles

    Thanks heaps, i managed to get the SSTP VPN working but ended up with another problem, i can't seem to ping an internal client nor able to share a file from the internal client to the external client. I test connectivity by ping and seems like i can only ping from the remote client to the vpn server but can't go pass that.

    My set up was as follows, i had a vpn server and internal client which is connect to the server's domain, than i have the remote client accessing the share files through the sstp tunnel. I did this in IPv4 and as soon as there is a sstp tunnel connections i shared a folder from the internal client and the remote client can access it but when i switch to ipv6 it can't ping passed the vpnserver. I tried disabling all firewall but still no luck. ANy suggestion to why is this happening????



    Thursday, September 30, 2010 6:48 AM
  • hi everyone

    finally fixed, that problem was simple azz just needed to look the right way, well i haven't got much time to write here but just wanted you do know that i have fixed the problem and will do send anyone a documentation on deployement of SSTP in IPV6 infrastructure wriiten by my self as part of my research i have explain wat was wrong and the step by step on how i did this configuration, it is similar to the deployment documentation made available by microsft but with a little more than the usual configuration to make sstp work in ipv6.. so yeah holla at me if anyones wants to know or if you can't manage to do this configuration my email is just subject your emails as sstp ipv6 so i will know


    cheers to Miles Zheng for the help and Esha Sharma rras blogger

    Monday, October 04, 2010 11:46 AM