none
Hyper-V ('machine name' unable to change state) RRS feed

  • Question

  • I do not find an answer to my problem and i can't image i am the first one to have encountered this problem.
    Installed Windows Server 2008 x64, installed active directory on management server, installed hyper-V (updated one) on management and the 2 hypervisors. I can add the hypervisors to the hyper-v management utility on the management server. I am able to create a VM on a hypervisor, i can do this local or remote. After creating the harddrive etc the machine is standing  in the menu, when i try to start is i receive the following error.

    'machine name' unable to change state

    http://www.easywebhost.be/upload/index.php?dir=&file=unablechangestate.JPG

    that's the end of the story, i tried to unmount all the devices to see if the problem was with an iso or network issue, but still the same problem. I tried to create / start local on the hypervisor aswell remote.

    http://www.easywebhost.be/upload/index.php?dir=&file=error.JPG

    Doen anyone has an idea?

    kind regards
    Wednesday, April 23, 2008 8:16 AM

Answers

  • i found the sollution, in an IBM blade there is a bios option called

    Proccessor execute disable bit

    be sure this option is enabled and Hyper-V will work.
    Friday, April 25, 2008 1:11 PM
  • Hi!

    I had the same issue with a Dell R200 server. The solution is to enable the VT Technology in the BIOS (submenu CPU)

    kind regards,
    Matthias

    Friday, May 16, 2008 3:01 PM

All replies

  • We recently got some HP xw8400 workstations, here is my story. I have installed WS08 x64, upgraded the BIOS, enabled Intel-VT and DEP, called HP support, checked machine using http://www.grc.com/securable.htm everything looks like it should work.

     

    After I create a new VM Hyper-V gives me the "unable to change state error" when trying to start a Virtual Machine.  I am extremely suprised as these machines should be able to run Hyper-V.  I am completely at a loss why Hyper-V does not work.

     

    Hoping someone has some ideas as to why?

     

    This is the error from the event log:

     

    Log Name:      Microsoft-Windows-Hyper-V-Worker-Admin

    Source:        Microsoft-Windows-Hyper-V-Worker

    Date:          23/04/2008 1:19:11 PM

    Event ID:      3112

    Task Category: None

    Level:         Error

    Keywords:     

    User:          NETWORK SERVICE

    Computer:      XXXXXXX

    Description:

    The virtual machine could not be started because the hypervisor is not running.  The following actions may help you resolve the problem:

    1) Verify that the processor of the physical computer has a supported version of hardware-assisted virtualization.

    2) Verify that hardware-assisted virtualization and hardware-assisted data execution protection are enabled in the BIOS of the physical computer.  (If you edit the BIOS to enable either setting, you must turn off the power to the physical computer and then turn it back on.  Resetting the physical computer is not sufficient.)

    3) If you have made changes to the Boot Configuration Data store, review these changes to ensure that the hypervisor is configured to launch automatically.

     

    Thanks

     

     

    Thursday, April 24, 2008 11:07 AM
  • i found the sollution, in an IBM blade there is a bios option called

    Proccessor execute disable bit

    be sure this option is enabled and Hyper-V will work.
    Friday, April 25, 2008 1:11 PM
  • I was unable to find such an option in the current HP xw8400 BIOS.  I had already enabled Data Execution Protection which I think refers to the same option.

     

    Friday, April 25, 2008 4:14 PM
  • I decided it might be good idea to remove the Hyper-V Role and re-add it again and it worked.  What the reason was that was preventing it from working still escapes me but at least it works!

     

     

     

    Friday, April 25, 2008 7:59 PM
  • Hi!

    I had the same issue with a Dell R200 server. The solution is to enable the VT Technology in the BIOS (submenu CPU)

    kind regards,
    Matthias

    Friday, May 16, 2008 3:01 PM
  • I was having the same issue with xw8400 model workstation with E5345 Xeon Quad Core CPU,

    If you update the bios to HP v2.31, under security there are options to enable DEP and Intel VT, took me a while to find it :(

    Also you need to power cycle the workstation when you have updated the settings, pull the power cord and press the power button to purge cache power

    This should help but you will still need to uninstall and add Hyper-V role which I agree is mundane!

    SaJ...good luck
    Wednesday, August 6, 2008 9:18 PM