none
Server 2008 cannot see XP workstations

    Question

  • I have a mixed network with XP and Vista machines. The current "server" (it's only actually used for centralised file sharing on the network) is an XP machine. Since monday I have been trying to install a Server 2008 machine so that I could have a decent and funstional machine that could run the network tasks that I want to assign to it.

    Problem is, my XP workstations cannot see my server and my server does not see my XP workstations. Everything works fine between Vista and 2008, but not XP (upgrading the XP workstations to Vista is not an option as it would stop the work of employees that we cannot afford not doing their work).

    I am wondering if this is related to an option chosen in the installation process and if I have to reinstall fresh the Server station or if there is a workaround or way to fix this problem. I really need help as the file sharing service is due to be up and running by the end of the day and I need to format the station the current "server" is running on to hand over to a new employee with a fresh Vista Buisness install.

    I can't seem to find any help topics about this subject anywhere I looked on the internet and I have no idea how to fix this myself so help would be greatly apreciated!
    Wednesday, December 03, 2008 4:17 PM

Answers

  • Hi,

     

    Based on my research, before we can browse a Windows XP from Windows Server 2008 in the network, we need to make sure a few things are set up. I list some important prerequisites as below to, vice versa. Please check them one by one and see how everything is going.

     

    1. By default, Computer Browser service is disabled on Windows Server 2008, which is required for NETBIOS work on Windows server 2008 to browser Windows XP. Please enable and start the Computer Browser service on Windows Server 2008 servers to see whether it works.

     

    Service.msc -> Computer Browser -> Set "Startup Type" as Automatic -> Apply -> Start

     

    2. Make sure all computers on the network are on the same workgroup.

     

    3. Make sure all the computers on your network have their network locations set to Private.

     

    About how to set network locations as Private, please refer to:

     

    A. Open the Start Menu and type network in the search box and then click Network and Sharing Center.

     

    B. Click Customize all the way to the right of the network you want to change the location type to 'Private'.

     

    4. Make sure Network Discovery is turned on. As Windows Vista and Windows Server 2008 have been changed to new Network Discovery, this is the reason why Windows Vista and Windows Server 2008 can see each other properly.

     

    To do so, please logon as Administrator and open Control Panel -> Network and Sharing Center. In the "Sharing and Discovery" column, configure 'Network discovery' as on.

     

    5. If you're using a 3rd party firewall you might have to change its settings to allow file and printer sharing.

     

    6. On Windows server 2008, open gpedit.msc from the start menu (this will prompt for elevation). Then open up Computer Configuration, then Administrative Templates, then Network, then Link-Layer Topology Discovery.

     

    For the two settings on the right, right click and select the properties. You can then ensure that it is enabled and configure the options to allow operation while in domain, (if you wish, on public networks) and ensure it is not disabled on private networks.

     

    7. Windows server 2008 use a discovery protocol called Link-Layer Topology Discovery (LLTD) to query other devices on the network to determine how the network is organized.

     

    Link-Layer Topology Discovery (LLTD) Responder component is not installed on the Windows XP-based computer. Please check if LLTD installed on your Windows XP clients is the latest. If not, please uninstall them and install the updated one.

     

    Network Map in Windows Vista does not display computers that are running Windows XP

    http://support.microsoft.com/kb/922120/en-us

     

    8. Run 'services.msc' and Enable Computer Browser service on Windows Server 2008 servers, which is disabled by default.

     

    In term of platform, Window Vista and Windows server 2008 are roughly same. If this issue still persists, please refer to the following page which provides more detailed information about how to remove 'Window XP based PCs cannot browse Vista based PCs issue'.

     

    Vista ↔ XP networking resolved

     

    www.svabhinava.org/Dia-Gnosis/SuntharVisuvalingam/ComputerBlogs/VistaXP-frame.php

     

    Hope this can be helpful.


    David Shen - MSFT
    • Edited by David Shen Thursday, December 04, 2008 11:35 AM modify
    • Marked as answer by David Shen Monday, December 08, 2008 2:31 AM
    Thursday, December 04, 2008 10:47 AM