none
VM can't be exported to local SDD, error 0x80070005 RRS feed

  • Question

  • Hello

    I have a test server with Windows 2012 R2 installed, which acts as a standalone Hyper-V Server (not joined to a domain). Among others there are two VM's (Windows 7 and Windows Vista) that I had transferred from a Windows 2008 R2 server. Both can be started and stopped without any problems, I can add and delete snapshots etc.

    When I export the Windows Vista machine, all is ok. However, when I try to export the Windows 7 machine to a local SDD (drive E), I get the following error:

    An error occurred while attempting to export the virtual machine "CL1" (E1FF00DC-B841-4D80-8FCE-4D6D39BA2370). Error: General access denied error (0x80070005).

    What can I do to solve that? The suggestions I found so far, either didn't apply to my case or didn't solve the problem. I tried adding "Everyone" with full access to the VM source folder, but the error message keeps popping up at the very end of the export process.

    Please note: Drive E is NOT a connected network share, it's really attached locally to the computer and in fact is the same drive, where all the active VM's are stored.

    I need to mentioned a few additional points, which might be important.

    1. Both VMs have differential hard disks connected to base disks.
    2. The Windows Vista VM could be imported to Windows Server 2012 R2 without problems. - I first exported it in Windows Server 2008 R2, imported it in Windows Server 2012, exported it again, and finally imported it in Windows Server 2012 R2. For the Windows 7 VM, that didn't work. I had to restore the data from a backup to the new folders and manually add them to Hyper-V.
    3. One of the base VHDs of the Windows 7 VM is on drive C instead of E and when I move it to the folder, where the other VHDs are and try to repair the connection, I get an error message stating that the superior element can't be set for the virtual drive. I do suppose if I could repair that connection successfully, the problem with the export would be solved as well.

    Does anyone have a suggestion what I could try to do to solve the problem?

    Saturday, December 6, 2014 4:23 PM

Answers