none
S2D cache disk issue RRS feed

  • Question

  • Hi all,

    I've had a look around with no luck on this problem.

    Essentially I created a 6 node cluster with HDDs and SSDs, and enabled S2D. I configured the pools, tiers, etc, and have a few VMs on there which are running quite happily.

    What i've then done is added 2x NVME cards to each node, and I wanted those to be the cache disks now rather than the SSDs, however what seems to be happening is the SSDs are remaining as Journal disks even though the NVME is detected and is also Journal. I've tried retiring and re-adding the SSDs, setting the cache disk model on the storage pool, retiring/removing the SSDs and running Enable-ClusterS2D to see if it'll refresh what disks it has. Unfortunately all to no avail.

    Has anyone ever come across this before? I'm at my wits end. I'd like to do it without having to bin off the entire storage cluster, although if I have to do that I guess that'll have to be the answer.

    Thanks in advance,

    Tom W

    Tuesday, May 29, 2018 8:48 PM

All replies

  • Hi,

    This is an interesting phenomenon as the NVMe are faster and should automatically be chosen as cache disks. Maybe the S2D doesn't somehow realize/identify the NVMe properly since they were added later on.. hard to tell.

    Have you checked the drivers etc?

    Otherwise it does seem like you've tried everything except rebuilding the entire cluster.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Tuesday, May 29, 2018 9:13 PM
  • Hi Leon

    Thanks for your reply. Yeah so I've checked the drivers etc and all looks fine. The disks are detected as SSDs on NVME Bus, and the "SSDs" are detected as SSDs on SAS Bus.

    When running Enable-ClusterS2D -verbose, I can see it detects 3 disk types, however doesn't then set the SSDs to Automatic, just to Journal. It's a rather frustrating predicament. I'm hoping to not have to rebuild the cluster as I'll have to migrate all the VMs off.

    Perhaps it's a bug?

    Tuesday, May 29, 2018 9:17 PM
  • There's a possibility that this could be a bug, as this is quite a new feature there's not much information so it's hard to find solution.

    You could create a ticket to Microsoft about this issue to see if they have a fix for this.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Tuesday, May 29, 2018 9:48 PM