none
Can not enable NetBios over TCP/IP on shared network interface

    Question

  • Hi,

    I have two 2008 Server Core boxes with the Hyper-V and Failover Cluster roles enabled.

    Both servers have six network interfaces, four of the interfaces are connected to virtual switches, two of the interfaces is shared between the host partition and Hyper-V.  Each interface is on a seperate VLAN.

    My problem is when I try to perform a "net use" command on the shared interfaces, I get a "The network path was not found" error.  IPCONFIG shows that the NetBios over TCP/IP is disabled.

    This is the IPCONFIG output for one of the shared interfaces.

    Ethernet adapter prodA_vlan_102:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : ProdA
       Physical Address. . . . . . . . . : 00-1B-21-35-17-48
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::f1f8:27b:4b91:79a1%15(Preferred)
       IPv4 Address. . . . . . . . . . . : 10.24.10.165(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       IPv4 Address. . . . . . . . . . . : 10.24.10.166(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 10.24.10.1
       DNS Servers . . . . . . . . . . . : 10.24.10.20
                                           10.24.10.60
       NetBIOS over Tcpip. . . . . . . . : Disabled

    I've tried changing the NetbiosOptions to "1" under HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NetBT\Parameters\Interfaces\<interface GUID> and rebooting the server but NetBios still shows disabled on the interface.

    This problem occurs on both servers.  It's a major issue because one of the shared interfaces is for my AD network.  And since the server gets the error when trying to connect to a UNC share, it can't connect to the SYSVOL or NETLOGON shares.

    If I perform a "net use" command over one of the interfaces that is not allocated to Hyper-V it works fine.

    Can anyone offer any suggestions on how to resolve this? 

    Thursday, June 18, 2009 6:48 AM

Answers

  • Yes, one of the limitations of using Server Core is the need to make these sorts of configuration changes using NETSH.  However, there are certain settings (like this and duplex/speed settings) that you can't configure with NETSH.

    In this case, I believe you can manipulate the NetBIOS setting via the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NetBT\Parameters\Interfaces

    Look for the GUID of the specific interface and then:

    "NetbiosOptions"=dword:0 (to use DHCP settings)
    "NetbiosOptions"=dword:1 (to enable NetBIOS over TCP/IP)
    "NetbiosOptions"=dword:2 (to disable NetBIOS over TCP/IP)

    Or you can use WMI:

    wmic nicconfig get caption,index,TcpipNetbiosOptions

    This returns "index number" (plug this into the next command):
    wmic nicconfig where index="index number" call SetTcpipNetbios 1

    The option numbershere do the same thing as directly editing the registry of your Server Core system.

    Hope this helps,
    --Ryan 


    Ryan Sokolowski | MCT, MCITP x3, MCTS x8, MCSE x2, CCNA, CCDA, BCFP
    Tuesday, June 23, 2009 8:09 PM

All replies

  • PS.

    The Windows Firewall is disabled on both servers.  The servers in question will respond to inbound mapping request over the problem interfaces just fine.

    Thanks,
    Henry
    Thursday, June 18, 2009 6:53 AM
  • I can only see, that I see the same for a dedicated interface on a machine, which has HyperV bound to a second network adapter.
    While the virtual machines have no problem, the server has. IP configuration is done manually, and WINS / NetBIOS configured as needed, anyway there is NetBIOS shown as disabled in ipconfig /all.
    So Hyper-V and NetBIOS over TCP/IP are not cooperating well, it seems.
    Best greetings from Germany
    Olaf
    Thursday, June 18, 2009 8:19 AM

  • Solution at least for me:
    In Network and Sharing Center click Network Connections.
    Click Advanced/Advanced Settings.
    In the section Bindings for the adapter in question Client for Microsoft Networks/Internet Protocol Version 4 (TCP/IPv4) was unchecked (and could not be checked directly).
    So I unchecked the box in front of Client for Microsoft Networks and checked it again - this did set the checkbox for both Internet Protocol Version 4 (TCP/IPv4) and Internet Protocol Version 6 (TCP/IPv6).
    This immediatly solved the issue for me and NetBIOS over TCP/IP works now.
    (This was on a Windows Server 2008 with installed SP2.)
    Best greetings from Germany
    Olaf
    • Proposed as answer by Olaf Engelke Saturday, June 20, 2009 9:28 AM
    Friday, June 19, 2009 9:19 AM
  • Thanks for the response Olaf.

    Unfortunately, I'm working with the Core installation and I don't have the luxury of a GUI to make the changes you suggested...
    Monday, June 22, 2009 6:25 PM
  • Hi,
    I wonder, if either a parameter of netsh or editing the registry in the proper place could be able to solve the problem with server core.
    Unfortunately I have no reference available (and no Server Core system installed) and it's already late in the night here.

    Best greetings from Germany
    Olaf
    Monday, June 22, 2009 10:19 PM
  • In the olden days it was a value of "2" in the registry to Enable NBT.
    Can you give that a try?
    Tuesday, June 23, 2009 7:24 PM
  • Yes, one of the limitations of using Server Core is the need to make these sorts of configuration changes using NETSH.  However, there are certain settings (like this and duplex/speed settings) that you can't configure with NETSH.

    In this case, I believe you can manipulate the NetBIOS setting via the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NetBT\Parameters\Interfaces

    Look for the GUID of the specific interface and then:

    "NetbiosOptions"=dword:0 (to use DHCP settings)
    "NetbiosOptions"=dword:1 (to enable NetBIOS over TCP/IP)
    "NetbiosOptions"=dword:2 (to disable NetBIOS over TCP/IP)

    Or you can use WMI:

    wmic nicconfig get caption,index,TcpipNetbiosOptions

    This returns "index number" (plug this into the next command):
    wmic nicconfig where index="index number" call SetTcpipNetbios 1

    The option numbershere do the same thing as directly editing the registry of your Server Core system.

    Hope this helps,
    --Ryan 


    Ryan Sokolowski | MCT, MCITP x3, MCTS x8, MCSE x2, CCNA, CCDA, BCFP
    Tuesday, June 23, 2009 8:09 PM
  • I've tried changing the registry entries to enable NBT and rebooting.  Nothing seems to work, 0, 1 or 2.

    I've also disabled the NIC for use by the parent partition and re-enabled it, which removed the virtual NIC and recreated it.  This didn't help either.

    I'm still getting the "System error 53 occurred.  The network path was not found." error.  This problem only occurs on NICs that's been assigned for use by Hyper-V and with the option to share the NIC with the parent partition enabled.


    Monday, July 06, 2009 3:54 PM
  • I know this is old but just in case if someone find it as me.

    The symptom: you can't browse computers in the Network, WINS displayed as not assigned, NetBIOS over Tcp/ip is marked as disabled despite of setting (either via GUI or registry keys mentioned above).

    In my case the the problem was caused by loosing active adapters GUID (e.g. WLAN) from some of registry keys responsible for binding adapter to services. I had to review them and add GUID manually to ensure that all keys contains my GUID.

    [HKEY_LOCAL_MACHINE\vzVEID\MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\Linkage]

    "Bind"=multi_sz: \Device\NetbiosSmb \Device\NetBT_Tcpip_GUID 
    "Export"= multi_sz: \Device\LanmanServer_NetbiosSmb \Device\LanmanServer_NetBT_Tcpip_GUID 
    "Route"= multi_sz: "NetbiosSmb" "NetBT" "Tcpip" "GUID" 

    [HKEY_LOCAL_MACHINE\vzVEID\MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\Linkage] "Bind"=multi_sz: \Device\NetbiosSmb \Device\NetBT_Tcpip_GUID 
    "Export"= multi_sz: \Device\LanmanWorkstation_NetbiosSmb \Device\LanmanWorkstation_NetBT_Tcpip_GUID 
    "Route"= multi_sz: "NetbiosSmb" "NetBT" "Tcpip"
     
    "GUID" [HKEY_LOCAL_MACHINE\vzVEID\MACHINE\SYSTEM\CurrentControlSet\Services\NetBIOS\Linkage] "Bind"=multi_sz: \Device\NetBT_Tcpip_GUID 
    "Export"= multi_sz: \Device\NetBIOS_NetBT_Tcpip_GUID 
    "Route"= multi_sz: "NetBT" "Tcpip"
     
    "GUID" [HKEY_LOCAL_MACHINE\vzVEID\MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Linkage] "Bind"=multi_sz: \Device\Tcpip_GUID 
    "Export"= multi_sz: \Device\NetBT_Tcpip_GUID 
    "Route"= multi_sz: "Tcpip"
     
    "GUID" [HKEY_LOCAL_MACHINE\vzVEID\MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters\Interfaces\Tcpip_GUID] "NameServerList"= multi_sz:”” 

    [HKEY_LOCAL_MACHINE\vzVEID\MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Linkage] "Bind"=multi_sz: \Device\GUID 
    "Export"= multi_sz: \Device\Tcpip_GUID 
    "Route"= multi_sz: GUID 

    • Proposed as answer by andrei_g Tuesday, June 27, 2017 7:58 PM
    Sunday, May 14, 2017 1:14 AM
  • Thanks Nikriaz, that is exactly the problem I was having too - after upgrading in situ to Windows 10 I've been struggling to get 'net view' to work correctly, I had to manually set the IP address of my NAS box in LMHOSTS just to access it. Hacking these bindings fixed it perfectly. 

    Of course, that does slightly beg the question, what is the 'correct' way to force Windows to re-build all its network protocol bindings...

    Sunday, May 14, 2017 11:30 AM
  • This super awsome perfectly worked.
    My problem was originally caused by installing and uninstalling the Hyper-V, I suspect.
    If the problem is on "comp1" and I tried on "comp2" this command:

    > net use \\comp1\dir1

    Then I could get on "comp2" this errors:

    System error 58
    or
    System error 59

    Whereas the problem is on "comp1", not on "comp2"
    and applying your fix on "comp1" resolved the problem.

    Thank you @Nikriaz

    • Edited by Vlakov Friday, June 09, 2017 2:26 PM
    Friday, June 09, 2017 2:17 PM
  • In a normal situation, should the driver do this?
    Tuesday, June 20, 2017 12:02 PM
  • Thanks Nikriaz, this worked for me too.  In my case, the adapter (Advanced TCP/IP settings) had NetBIOS over Tcip already Enabled, but ipconfig /all still showed "Disabled".

    I used wmic nicconfig list to get the GUID of the interface and then used the patterns above to add the interface to those keys mentioned.

    Craig.

    Sunday, June 25, 2017 10:55 PM
  • Great it worked after uninstall ethernet and scan for new hardware and netbios was ok

    Thanks

    Friday, August 04, 2017 10:04 AM
  • Thank you, it worked.

    I'm stunned that MS didnt create a tool to automate the fix of this registry keys.

    A lot of people are still having this problem and the only solution that work beside this one is to format and reinstall everything... meh..

    Wednesday, August 09, 2017 3:42 PM
  • Thanks you! It worked.

    I think the issue was raised by removing 'developer tools' on W10.

    I wanted to test Docker but figure out it will be useless for me, so I removed it. Since, I have issue with netbios.

    Tuesday, August 15, 2017 11:08 AM
  • Or not. 

    It just happened. I had network issues after using a VPN connection, W10 ask me to "reinit the network", I clicked yes and I have a card with a new GUID, without the binding.

    Wednesday, August 16, 2017 4:04 PM