locked
Integration Service 3.3 causes file system error RRS feed

  • Question

  • Hello.

    I installed RHEL 6.1 on Hyper-V 2.0 Server. Then I installed the Linux Integration Services 3.3.

    After installation of the Integration Services, I reboot the guest, then I encountered the following problem.

    The guest reports the following error:

    /dev/sda5: Group descriptor 0 has invalid unused inodes count 6929. FIXED.

    /dev/sda5 ciytaubs a fukes ststen wutg errors, check forced.

    /dev/sda5: Entry 'sudo' in /run (24) has deleted /unused inode 898. CLEARED.

    /dev/sda5: Inode 24 ref count is 31, should be 30. FIXED.

    /dev/sda5: Unattached inode 996.

    /dev/sda5: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.

    I re-installed the RHEL and Integrasion Services 3.3, the problem occured again and agin.

    However, the problem does not occur on the guest that has different size of disk partition.

    I want the guest with a disk partition whichi size trigger the problem.

    Does anyone know the solution ?

    Thank you in advances.
    Monday, July 30, 2012 8:53 AM

All replies

  • Have you tried expanding the VHD (even by 1 or 2 GB)?

    I received the same error on a RHEL image converted from a VMDK.  Expanding the VHD resolved the issue.

    Thursday, January 24, 2013 8:58 AM
  • Hello.

    Thank you for your suggestion.

    We investigated following cases for a month.

    1) Linux IC3.3, RHEL 6.1 with ext3 file systesm.

    2) Linux IC3.3, RHEL 6.1 with ext4 file systesm.

    The problem did not occur in case(1).

    The problem occured in case(2) .

    So we decided not to use ext4 file system .

    Monday, January 28, 2013 2:56 AM