none
HyperV Checkpoint/ Snapshot errors for Backup RRS feed

  • Question

  • Hi, we have recently created a Hyper-V server but after a few days of use we can no longer take backups. If we restart the VM the checkpoint still fail but if we restart the host they begin to work again. Is there a way of releasing whatever process is using the file so we can take checkpoints for backup again? I've attached a screenshot of the error.

    Is there an easy way to find out what process is using the avhdx checkpoint file and can this be deleted to allow the checkpoint process to run. Also the VM does not show it has any checkpoints in the HyperV manager so assume these are created as part of a backup process.

    

    Sunday, April 21, 2019 10:01 PM

All replies

  • Hi,

    Thanks for your question.

    From your post, may I ask that the VM you want to take checkpoints didn’t have any snapshot currently, is that? While you make a checkpoint for this VM, it encountered the error like the post mentioned?

    For now, we can try the steps to see if it can work.

    1)Please restart the Hyper-V Virtual Machine Management service “VMMS” to see if it is running normally.

    2)Then please check the VM’s checkpoints setting on the HV management console, if it selected “Production checkpoints”, we can try another method “Standard checkpoints” to see if it works.

    3)Perhaps an .avhdx file was locked, please try to turn off other third party applications and then snapshot the VM again.

    4)Please also check the Hyper-V event logs so that we can find clue about this issue.

    An Overview of Hyper-V Event Logs

    https://www.altaro.com/hyper-v/an-overview-of-hyper-v-event-logs/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    5) Please check if the host and the Integration service for the VM need to update, patch the latest update for it to see if it helps.  

    Hope above information can help. If you have any question or concern, please feel free to let me know.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, April 22, 2019 5:11 AM
    Moderator
  • Hi,

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 24, 2019 7:11 AM
    Moderator
  • Hi,

    How are things going on? Was your issue resolved?

    Please feel free to let me know if you need further assistance.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Sunday, April 28, 2019 10:42 AM
    Moderator
  • Hi,

    Was your issue resolved?

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, April 30, 2019 5:42 AM
    Moderator