none
Server 2008 R2 SP1 - RDP

    Question

  • Hi,

    I use RDP to connect to my server 2008 R2 machines.  I have applied SP1 to one of these servers, and now I can no longer connect to the machine via RDP.

    When I initiate the RDP seesion, from a windows 7 Pro SP1 client, The RDP client gets as far as Securing Remote connection at which point it bombs out without any message error or otherwise.

    Can anyone suggest  a reason?

    Logging in locally to the server reveals nothing: RDP is enabled and all looks as it should, but yet I can no-longer connect after applying the service pack!

    John.

    Friday, February 25, 2011 8:20 PM

All replies

  • Hello,

    did you make sure the Remote desktop settings on the DC still allow the connections?


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Friday, February 25, 2011 9:27 PM
  •  

    I had hoped all, would work as before(sp1).

     

    Tomorrow (almost today for me) I have set aside time to look deep at this issue.

     

    If I read you correctly.

     

    It was the DC I upgraded, nice. And yes, I have checked that it still allows connection from Administrator account (Me) :)

     

    Thank you for the response.

     

    John

     

    Friday, February 25, 2011 11:23 PM
  • Hi John,

     

     

    I have also installed the SP1 on the Windows Server 2008 R2, and it seems fine as usual. Have you checked the Remote Desktop setting on the Remote Tab of System properties? I.e. I select “Allow connections from computer running any version of Remote Desktop” on the server.

     

    Besides, if this issue persists, please check if there are event logs on the server side when this issue happens? If yes, please let me know the detail including the event ID.

     

     

     

    Thanks.

    Monday, February 28, 2011 6:33 AM
    Moderator
  • HI Alan and Meinolf,

    Yes I have checked the RDP setting on the Remote Tab; it is sett to allow me the Admin to remote onto the server in question.

    Checking the Windows Logs, under application logs, I get a Winlogon Error which states, the windows logon process has unexpectedly terminated! EventID is 4005

    I have even tried "mstsc /console" but that generates the very same Winlogon Error.

    I can logon locally to the machine without problems.

    I have just tried disabling windows firewall, just in case it was causing an issue, but no luck, it made no difference.

    Thanks

    John

    Monday, February 28, 2011 3:09 PM
  • Hi,

     

     

    Event ID 4005:

     

    This event indicates the windows logon process is unavailable, and this error might be caused by one of the following conditions:

     

    1. System resources are inadequate or unavailable.

     

    2. The Windows registry is corrupted.

     

    3. A service failed to start.

     

    You can check the below article to get a suitable solution.

     

    Event ID 4005 — Windows Logon Availability

    http://technet.microsoft.com/en-us/library/cc734097(WS.10).aspx

     

     

    Meanwhile, the third party software might cause this issue, I would perform a clean boot to isolate.

     

     

    1) Run MSCONFIG.EXE.

     

    2) In the Services tab, click "Hide All Microsoft Services" and click "Disable All".

     

    3) In the Startup tab, click "Disable All". Click OK. (This will temporarily prevent third-party programs from running automatically during start-up.)

     

    4) Restart the computer. Does the problem still persist?

     

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You can use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     

     

     

     

    Thanks.

    Tuesday, March 01, 2011 3:11 AM
    Moderator
  • We have the very same problem here. We have checked: - Remote access allowed - RDP "less secure" connections allowed - Same user allowed It first connects, then throws out. Fortunatelly, this was on non-production servers. We're definively not rolling out this SP1 on production servers unless it's fully tested.
    Microsoft Peru
    Wednesday, March 02, 2011 6:35 PM
  • Thanks for posting Marcel, it's good to know I am not the only one with this issue.

    Alan: I read the MSDN discussion on eventID 4005, thanks for the post, but since my server too, like Marcel's is non-production, I beleive it would be quicker to reinstall from scratch the OS, then apply the service pack and then add back the Role for this server.

    As a note to Microsoft:  My server has only the DC role and no third party software installed.  It's the simplest of installs, with which I expected the service pack to install over without issue.

    It will be the weekend before I can look at this again: And, I believe re-installing the OS will be far and away the quickest way of resolving this issue.

    (Though, I am kinda hoping some determined, smart individual will post the solution they found for this issue)

    Thank you

    John.

    Wednesday, March 02, 2011 7:21 PM
  • Hi,

     

     

    I would try to use the Network Monitor to see whether there is something wrong when doing RDP to the Terminal Server.

     

    Microsoft Network Monitor 3.4

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=983b941d-06cb-4658-b7f6-3088333d062f&displaylang=en

     

     

    Meanwhile, if you find other related Event log, please post here for the further research.

     

     

     

    Thanks.

    Thursday, March 03, 2011 3:19 AM
    Moderator
  • We've had the exact same issue here. During the final stage of the service pack install (after reboot) RDP abruptly fails and terminates all new sessions. Has happened on about 70-80% of the servers we've upgraded - looks like a bug in the service pack, considering these are off the shelf Dell servers with minimal reconfig.

    RDP will work after the next reboot. We used remote shutdown from another server to regain connectivity remotely:
    shutdown /t 0 /m \\servername /r

    Don't forget the "/r" or the machine will shut down rather than reboot.

    Saturday, March 05, 2011 12:59 AM
  • I have the same issue on a Windows Server 2008 R2 Core after installing SP1. Before SP1 everything was fine. I have installed SP1 on the DC (Windows 2008 R2 Standard) and this works with RDP without problem, but on the Core install there is an event message Winlogon 4005: The Windows logon process has unexpectedly terminated. - after every attempt to connect via RDP .

    The event data is: 1F000000. No other messages are shown.

    Another interesting thing on this server is, that NO TCP connections are displayed when I try the:

    netstat -a
    command. Only some UDP connections are displayed, but no TCP. However, RDP is enabled and the 3389 port is open - but it not displayed in netstat. Strange...

    Reboot does not helps either. I can log in locally.

    Any solution?

    Thanks

     

    Sunday, March 06, 2011 2:45 PM
  • Hello,

    After applied "successfully" on W2K8 R2 Web server edition I have exactly the same issue and the same problem (Event ID 4005...). I discovered this problem yesterday in my test lab and I hope to find a solution ASAP. Fortunately my ILO connection works...

    Thursday, March 10, 2011 9:17 AM
  • Hi,

     

     

    Event ID 4005:

     

    This event indicates the windows logon process is unavailable, and this error might be caused by one of the following conditions:

     

    1. System resources are inadequate or unavailable.

     

    2. The Windows registry is corrupted.

     

    3. A service failed to start.

     

    You can check the below article to get a suitable solution.

     

    Event ID 4005 — Windows Logon Availability 

    http://technet.microsoft.com/en-us/library/cc734097(WS.10).aspx

     

     

    Meanwhile, the third party software might cause this issue, I would perform a clean boot to isolate.

     

     

    1) Run MSCONFIG.EXE.

     

    2) In the Services tab, click "Hide All Microsoft Services" and click "Disable All".

     

    3) In the Startup tab, click "Disable All". Click OK. (This will temporarily prevent third-party programs from running automatically during start-up.)

     

    4) Restart the computer. Does the problem still persist?

     

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You can use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     

     

     

     

    Thanks.

     

    I also have the same problem as everyone else. The quoted steps do not resolve the issue. RDP generally works the first time following a reboot, but any subsequent connections freeze at Welcome after entering the login credentials.

    Currently working around it using VNC, but this can't be a permanent solution.

    I am running Hyper-V Server 2008 R2 SP1. with two guest VMs running Server 2008 R2 SP1. Note that the problem on the guest OSes occurred prior to updating Hyper-V Server to SP1. Using the Hyper-V manager to spawn a desktop console connection still works, as expected.

    Monday, March 21, 2011 5:11 PM
  • i have same problem on one of two systems that  I update SP1, the first system is Windows 2008 R2 SP1 is also a domain controller, RDP work from Windows 7 or  XP,  on the second system RDP only work from Windows XP but logon fail from Windows 7 or 2008 R2 it keep prompting for password.


    MAJOR
    Saturday, April 02, 2011 4:29 AM
  • Hello, I too have the same problem: two identical machines (both hardware and software) with 2008 R2 and SQL server. After a single Sp1 no longer accept RDP connections despite the port 3389 is open ... the error seems to be the fateful winlogon 4005. The other machine works perfectly ...... I've tried a different, but all to no avail. I read in a forum that would depend on the RDP and certificate should remove it (should be recreated automatically) but I do not know how to do .... Any ideas ..... thanks in advance ...
    Thursday, April 07, 2011 4:57 PM
  • Hi,

     

     

    Event ID 4005:

     

    This event indicates the windows logon process is unavailable, and this error might be caused by one of the following conditions:

     

    1. System resources are inadequate or unavailable.

     

    2. The Windows registry is corrupted.

     

    3. A service failed to start.

     

    You can check the below article to get a suitable solution.

     

    Event ID 4005 — Windows Logon Availability 

    http://technet.microsoft.com/en-us/library/cc734097(WS.10).aspx

     

     

    Meanwhile, the third party software might cause this issue, I would perform a clean boot to isolate.

     

     

    1) Run MSCONFIG.EXE.

     

    2) In the Services tab, click "Hide All Microsoft Services" and click "Disable All".

     

    3) In the Startup tab, click "Disable All". Click OK. (This will temporarily prevent third-party programs from running automatically during start-up.)

     

    4) Restart the computer. Does the problem still persist?

     

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You can use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     

     

     

     

    Thanks.

     

    I also have the same problem as everyone else. The quoted steps do not resolve the issue. RDP generally works the first time following a reboot, but any subsequent connections freeze at Welcome after entering the login credentials.

    Currently working around it using VNC, but this can't be a permanent solution.

    I am running Hyper-V Server 2008 R2 SP1. with two guest VMs running Server 2008 R2 SP1. Note that the problem on the guest OSes occurred prior to updating Hyper-V Server to SP1. Using the Hyper-V manager to spawn a desktop console connection still works, as expected.

    I found my issue and was able to fix it.

    Both my Server 2008 R2 SP1 installs seemed to only be refusing connections to one user account, so upon investigating I found my favourite data usage tracking app, Networx, had been loading for that user and was causing problems. It might be interesting to note that Networx hooks in to the network driver stack, which might be why SP1 had a problem with it. I disabled Networx and the RDP issue went away.

    Hope this helps anyone else with Networx or a similar app that could be causing problems for them. So far I haven't seen any official response from Microsoft on this issue.

    Sunday, April 10, 2011 2:24 PM
  • Anyone able to resolve this?   Having the same issue.   Event log shows Winlogon failure (4005).  Made sure RDP was still setup.   Everything was working fine prior to SP1 install.   Failure occurs from XP as well as Win7 clients.
    Friday, July 08, 2011 10:38 PM
  • Hi Raj,

    I never found a solution. I did a clean install with monitor mouse and keyboard physically plugged into the server. Did all the windows updates including SP1 before enabling RDP.  it all works fine now.

    J.

    Saturday, July 09, 2011 10:34 AM
  • Did anyone on this thread try disabling RDP, restarting, and then enabling RDP? I would also be curious to know if anyone tried enabling RDP for a new user account to see if that would work. I think it would be interesting to see if this is related to the computer or the user - and those are two things that I would certainly try when troubleshooting such an issue. If you do have this problem and do try those things, please, let us know if one or the other actually solves the issue. Thanks!
    Friday, August 12, 2011 7:51 AM
  • Did anyone on this thread try disabling RDP, restarting, and then enabling RDP? I would also be curious to know if anyone tried enabling RDP for a new user account to see if that would work. I think it would be interesting to see if this is related to the computer or the user - and those are two things that I would certainly try when troubleshooting such an issue. If you do have this problem and do try those things, please, let us know if one or the other actually solves the issue. Thanks!

    hi i tried both new user and turning off and reboot/re-enabel. niether worked.  i think the secret may be to avoid deploying sp1 remotely.  i re-installed the os locally at the server and applied sp1. rather brutal solution, but it worked.
    Friday, August 12, 2011 9:45 AM
  • Hello,

    I have 3 2008R2 standard server for 2 of these, no problem with RDP and SP1 but for the last i have the error winlogon with the event id 4005.

    I have tried all solution except reinstall the OS (it's not possible).

    I have checked all roles and features (witch are the same on all servers), the rdp services and so on ... the only exeption is with the "netstat -ano" return, on the problematic box, it show no tcp listener, only UDP (# 150 due to the dns.exe).

    Can someone help me please ?

     

    Thursday, October 27, 2011 9:35 AM
  • Hello!
    The solution for me to solve this issue was:

    1. deinstallation of webservices, terminal server gateway and terminal server licensing role and RPC over HTTP Proxy feature
    2. deinstallation of Avira antivirus and registry cleaning (avipbb system driver)
    3. winrm quickconfig and winrm test, gpupdate

    since these steps the problem is solved on my 2008r2sp1.

    regards, I hope this is also the solution for you ;)

    Thursday, March 01, 2012 10:49 AM
  • Our environment recently updated then moved to SP1. We ran into the same issue. In this case KB2667402 is the culprit. Removed it and retstarted the RDS service. No issues afterwards!!! Case being opened with Microsoft.
    • Edited by MyITNetwork Friday, March 16, 2012 12:17 PM
    • Proposed as answer by KeyurCT Friday, March 30, 2012 7:12 AM
    Friday, March 16, 2012 12:15 PM
  • There is an update for this security update that overights the remote issue that the orginal update courses.

    So once you installed the KB 2667402 update you should see anther update for this same KB that fix's the issue with out the need to remove the update and open your self and your company to a security risk.

    Hope this helps.

    • Proposed as answer by BSN_Troy Wednesday, March 21, 2012 5:46 PM
    Saturday, March 17, 2012 9:56 AM
  • I ran into this same issue tonight when updating a couple of servers - hopefully when I go onsite tomorrow this will fix the issue - I will post back and please provide case # once you have one open with MS - thanks!

    Monday, March 19, 2012 1:53 AM
  • Once I logged in directly and ran the next available updates after applying Server 2008 SP1 and rebooted after those updates were applies (including 2667402) I was then able to again use RDP without issue. This is a major pain issue for people who administer machines remotely!

    I would recommend setting up VNC or another remote solution prior to applying SP1 so that you can then run the next set of updates without having to be at the physical server.


    • Edited by jrfree Monday, March 19, 2012 8:43 PM
    Monday, March 19, 2012 8:42 PM
  • I have verified this to be true on four servers that were having the issue. Thanks Gryffon-G-Wiz!

    Keywords: Cannot RDP after installing SP1 on 2008R2 resolved with latest version of KB2667402


    • Edited by BSN_Troy Wednesday, March 21, 2012 5:51 PM added 2008R2
    Wednesday, March 21, 2012 5:50 PM
  • Newly installed 2k8r2 Server from yesterday, and we couldn't connect remote dektop to the new machine. However, as of this morning, after appyling the last couple of patches. With a reboot to follow. We can now connect remotely as normal.

    Friday, March 23, 2012 7:51 AM
  • Hi All,

    i have facing problem after the windows 2008 R2 service pack1 installation, i am unable to take RDP from windows 7 sp1

    have any solution?


    ramnath

    Sunday, March 25, 2012 5:06 PM
  • Thanks a lot Gryffon, as i faced the issue of RDP after reading this post i applied the KB 2667402 update and my RDC started working properly.
    Friday, March 30, 2012 7:15 AM
  • Adding one more datapoint -- I had MS12-020 (KB2667402) install before installed SP1 on a server, then installed SP1.  Couldn't make an RDP connection.

    Uninstalled KB2667402, and everything was sunshine and daisies. 

    Reinstalled it (KB2667402), and I can still connect via RDP.  Thank you!

    Tuesday, April 03, 2012 2:02 PM
  • I followed ALL the tips in here - including the reapplication of KB2667402 - and after all the manual updates (I benched the server and connected a mouse/keyboard/monitor) -  I was able to connect yesterday via RDP with no problem - but when I try this morning - I get:

    1) Remote Access to the server is not enabled

    2) The Remote Computer is Turned off

    3) The Remote Computer is not available on the network.

    Update: If I connect from totally different machine onsite - I was able to get a bit further. After the initial connection via RDP - I immediately received a Certificate Error but was offered the option to connect anyway. I pushed on through and finally was able to RDP into the machine as Administrator.

    Now that I am finally on the box - any ideas on what I should check or try? Gonna start with removing KB2667402...and reapplying it.

    B

    Wednesday, April 04, 2012 12:58 PM
  • If you want to uninstall hotfix KB2667402 remotely (via WMI) try:

    wmic /node:<SERVER> /user:<USER> process call create "powershell wusa /uninstall /kb:2667402 /quiet /forcerestart"
    • Proposed as answer by Krystian Bigaj Thursday, April 05, 2012 7:41 AM
    Wednesday, April 04, 2012 5:49 PM
  • If you want to uninstall hotfix KB2667402 remotely (via WMI) try:

    wmic /node:<SERVER> /user:<USER> process call create "powershell wusa /uninstall /kb:2667402 /quiet /forcerestart"
    Thank you, worked like a charm!
    Wednesday, April 04, 2012 10:04 PM
  • If you want to uninstall hotfix KB2667402 remotely (via WMI) try:

    wmic /node:<SERVER> /user:<USER> process call create "powershell wusa /uninstall /kb:2667402 /quiet /forcerestart"

    yeap, worked like a charm!!!

    thanks a lot!

    Friday, April 06, 2012 8:46 AM
  • It worked for me after installing the KB KB2667402 .Thanks a lot

    Regards, Maneesh George

    • Proposed as answer by GHTorres Saturday, April 14, 2012 3:46 AM
    Monday, April 09, 2012 2:03 PM
  • I threw in the Application Log Error to make this easier to find for others. svchost.exe_TermService 

    Uninstall of KB2667402 works.

    Log Name:      Application
    Source:        Application Error
    Date:          4/17/2012 4:10:32 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:     XXXXXXXX
    Description:
    Faulting application name: svchost.exe_TermService, version: 6.1.7600.16385, time stamp: 0x4a5bc3c1
    Faulting module name: rdpcorekmts.dll, version: 6.1.7600.16952, time stamp: 0x4f1f9e66
    Exception code: 0xc0000005
    Fault offset: 0x000000000000a793
    Faulting process id: 0xf64
    Faulting application start time: 0x01cd1cdd53afeff5
    Faulting application path: C:\Windows\System32\svchost.exe
    Faulting module path: C:\Windows\system32\rdpcorekmts.dll
    Report Id: c3abab73-88d1-11e1-b82e-78e7d194730a
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-04-17T21:10:32.000000000Z" />
        <EventRecordID>682</EventRecordID>
        <Channel>Application</Channel>
        <Computer>xxxxxx</Computer>
        <Security />
      </System>
      <EventData>
        <Data>svchost.exe_TermService</Data>
        <Data>6.1.7600.16385</Data>
        <Data>4a5bc3c1</Data>
        <Data>rdpcorekmts.dll</Data>
        <Data>6.1.7600.16952</Data>
        <Data>4f1f9e66</Data>
        <Data>c0000005</Data>
        <Data>000000000000a793</Data>
        <Data>f64</Data>
        <Data>01cd1cdd53afeff5</Data>
        <Data>C:\Windows\System32\svchost.exe</Data>
        <Data>C:\Windows\system32\rdpcorekmts.dll</Data>
        <Data>c3abab73-88d1-11e1-b82e-78e7d194730a</Data>
      </EventData>
    </Event>

    Michael Barbere
    • Edited by MidwestTech Tuesday, April 17, 2012 9:31 PM Added info
    Tuesday, April 17, 2012 9:30 PM
  • Adding one more datapoint -- I had MS12-020 (KB2667402) install before installed SP1 on a server, then installed SP1.  Couldn't make an RDP connection.

    Uninstalled KB2667402, and everything was sunshine and daisies. 

    Reinstalled it (KB2667402), and I can still connect via RDP.  Thank you!

    Ya Great! Uninstalled KB2667402 after installing SP1 and not being able to RDP nor TS anymore and now works again!

    Tonight I'll reapply KB2667402 again (after making snapshot ;-) and see what happens.

    thx!

    Wednesday, April 18, 2012 12:14 PM
  • Hit this issue in my lab, same problem, same solution.

    Thanks for sharing!

    Wednesday, April 18, 2012 3:20 PM
  • Hi,

    I had came across with the similar issue of losing RDP connection post deployment of Service Pack 1 on Windows Server 2008 R2.

    I managed to install the following windows Security Update for Windows Server 2008 R2 x64 Edition

    KB2667402

    Now, I together with other admins, can access via RDP simultaneously.

    Cheers....

    Tuesday, April 24, 2012 12:43 PM
  • Same issue has occurred after appying service pack 1.  Cannot login via RDP.  Using vCenter to access.  I looked to see if and KB2667402 was installed and it is.  I will follow suggestion of others here and uninstall it and then reinstall.  Will report back what happens, never a dull moment.
    Tuesday, April 24, 2012 7:47 PM
  • Incredible - worked for me perfectly... thanks a lot...

    Sunday, April 29, 2012 5:59 PM
  • Thanks x 10^6 Paszun!  I'm working remotely and didn't even need to drive over to the office.

    Tuesday, May 01, 2012 12:08 AM
  • Wow! Saved my bacon! Can't thank you enough for this!
    Tuesday, May 01, 2012 12:11 PM
  • Hi All,,

    Thanks for the post, after un-installing KB2667402. It works fine for me as well.

    Kudoo !!

    Thursday, May 03, 2012 7:10 AM
  • Great info. Uninstalled KB2667402. Rebooted. Went back to windows update and noticed two additional updates along with KB2667402. Installed them all. Rebooted again. Tested. RDP works.

    Thursday, May 03, 2012 10:37 AM
  • I performed the remaining Windows Updates after the SP1 install and it fixed the issue :)
    Tuesday, May 08, 2012 1:22 PM
  • Hi :)

    Thank you :) Your command is for me top 1 for these year :)

    It worked, thank you again, you are champion.

    Someone should mark these as real answer :)

    Today I've installed onto one phy svr. SP1 which already have all other updates but after installing SP1 and restart I can not login anymore :( After login I am disconnected from RDP session. Svr is in DC far away from me, so remotely running your provided command done job :)

    Best regards

    Long Live And Prosper

    Friday, May 11, 2012 9:12 PM
  • Yep, that's worked for me as well
    Thursday, May 17, 2012 12:06 PM
  • Hi ,

    I know this is a old post but i have noticed more and more organisations are now applying SP1 on windows 2008 R2 and Windows 7 what i have noticed is that as part of windows update if you have KB2667402 and then apply SP1  it corrupts the RDP dll rdpcorekmts.dll  Refer to this KB article which mentions under known issues :

    if running win7 or windows 2008 R2 the binary version of the dll is 6.1.7601.16952 and not 6.1.7601.17767 and the sp1 binary has older version.

    http://support.microsoft.com/kb/2667402

    uninstall and reinstall KB2667402 or go ahead and install

    http://support.microsoft.com/kb/2621440

    this should fix the RDP issues.

    if you are rolling out these patches from WUS or other servers ensure that both the KBs are included in the same package.

    regards

    bhanu

    

    • Proposed as answer by bhanukir7 Monday, May 21, 2012 1:59 PM
    Monday, May 21, 2012 1:59 PM
  • Thanks for the solution this worked in my environment as well !!!
    Wednesday, May 23, 2012 7:20 PM
  • Thanks - after much frustration because the server is sitting in a DC and we don't have physical access - we managed to get a "virtual physical access" device attached and then installed the remaining updates - the RDP worked again.  You would think that the original SP1 could have been withdrawn and replaced with a patched version as judging by the number of complaints on this and other threads this is costing server admin companies untold lost hours first understanding and then resolving a problem caused by an SP that breaks one of the most fundamental server support services.  Dreadful customer care!
    Monday, May 28, 2012 9:47 AM
  • AleMcMann, agreeing with you 100% as I noticed the problem the day after I finished updating this DC (today), since it worked on my first login attempt only.  Now we're in business hours so I can't run the remote fix.  Removing KB2667402 and restarting the RDP services does the trick but I had to use Dameware to connect (luckily my free license hasn't expired!).  Such a clear and simple problem should have been fixed LONG AGO.   



    Tuesday, May 29, 2012 2:47 PM
  • all you have to do is install something like team viewer before sp1 and ensure it is enabled after a reboot. when you have installed sp1, simply go on to team viewer or its preferred equivalent and log in. All you have to do then is press the close button to the screen that says you have installed sp1 and reboot!!!
    • Proposed as answer by Goonbreath Wednesday, June 06, 2012 9:02 PM
    • Edited by Goonbreath Wednesday, June 06, 2012 9:03 PM
    Wednesday, June 06, 2012 9:02 PM
  • To sum it up you will need to look for a windows update or hotfix that was released prior to SP1 that caused issues after the SP1 upgrade.  KB2667402.  Try uninstalling this update.

    _______________________

    Good luck with this and let me know if this helps.

    Chris

    Monday, June 11, 2012 8:20 AM
  • Here is a tutorial on how this specific 2667402 + SP1 issue and how to fix it:

    http://itswapshop.com/articles/fix-cant-rdp-2008-r2-or-windows-7-after-update-2667402-and-sp1-remote-desktop-services

    • Proposed as answer by cmgomes Friday, June 29, 2012 5:41 PM
    Friday, June 15, 2012 2:53 PM
  • I had the same problem with one of my production server. I found that after installing SP1, KB2667402 update was not installed. I updated my windows and it installed KB2667402 and along side other updates and it solved the problem.
    Friday, June 29, 2012 5:42 AM
  • I had the same issue, All I did to fix it was I installed the lastest microsoft kb patches from windows update and restarted. For my instance it appears the update addresses the issue and fixed it.

    Thomas

    Tuesday, October 23, 2012 7:11 PM
  • I logged into another Server 2008 R2 with SP1 and initiated a Remote Desktop Session into the server I just installed SP1 on.

    I was able to log in.

    The message was displayed that SP1 installed successfuly.

    I clicked "OK" or whatever it was. It seems I needed to "finish" the SP1 install.

    Back on my other machine, I was then able to RDP into it.

    Tuesday, June 25, 2013 2:02 PM