no remote desktop license server available to provide a license


  • hello interested readers,
    although there already are some similar questions concerning this topic they couldn't solve my problem, so here it is:

    we're running 2008 R2 Enterprise Server SP1. Installed roles include ADDS (backup/2nd dc in our domain) and Remote Desktop Services (plus license server), let's just call it dc2 for now.

    When the grace period ended one couldn't connect to the server using mstsc (you still can using /admin parameter).

    Systemlog reads:
    "The RD Licensing grace period has expired and the service has not registered with a license server with installed licenses. A RD Licensing server is required for continuous operation. A Remote Desktop Session Host server can operate without a license server for 120 days after initial start up."
    "The Remote Desktop Session Host server does not have a Remote Desktop license server specified. To specify a license server for the Remote Desktop Session Host server, use the Remote Desktop Session Host Configuration tool."

    "CAL reporting: Windows Server 2008 or Windows Server 2008 R2 : Per User CAL (TS or RDS) - Installed: 10, Issued: 0"

    Client disconnects with the following message:
    "The remote session was disconnected because there are no Remote Desktop License Servers available to provide a license."

    Anyways, checking RD Session Host Configuration > Licensing Diagnosis it tells there are no licensing problems identified. 10 User CALs available for server version 2008 R2 with 0 warnings and 1 license server in the information section - connection/credentials available. I also implemented a GPO to have "dc2" be the specific & preferred license server

    This is where my confusion starts because it directly contradicts the 2nd entry in the syslog.

    What am I missing, what else do I need to check? Edit: msconfig, disabled all services except MS - no change.
    Any help is greatly appreciated.


    Tuesday, July 26, 2011 3:39 PM

All replies

  • Hi Jorma,

    1. Please change your Licensing mode to Per User in Remote Desktop Session Host Configuration (tsconfig.msc).  Since you have purchased Per User RDS CALs the RD licensing mode on your server should be Per User.

    2. Please verify in RD Session Host Configuration that your RD License server is showing as specified, and the correct name for your RD Licensing server is listed.  This will show if your GPO setting is taking effect.  If it is not specified then go ahead and specify it manually.  Since the Licensing Diagnosis said you have a license server I think it is set, I just want you to double-check it.

    After completing the above please see if you are able to logon, and reply back with your results.



    Tuesday, July 26, 2011 3:47 PM
  • Hi TP,

    double-checked and confirmed. Settings are enforced via Local Group Policy, for now.

    1. Set the Remote Desktop licensing mode: Enabled
      Specify the licensing mode for the RD Session Host server: Per User.
    2. Use the specified Remote Desktop license servers: Enabled
      License servers to use: dc2 (tried Hostname, FQDN, IP - summary did show the GPO affected the setting as expected)

    From the example in the policysetting I'd say I can use name, fqdn, ip.. whatever I prefer, right?
    Remote logon not working, still same setup as it was before.

    Wednesday, July 27, 2011 8:08 AM
  • I have the same problem, you could fix it???
    Monday, March 18, 2013 3:24 PM