none
Easy Print - Printer Redirection not working for one of two accounts on same client.

    Question

  • Not entirely sure what the problem is, but let me lay it out... Hopefully someone will have come across this.

    I have a brand new 2008 Ent server.  After getting the server up and running all updates applied I joined the server to the domain logged on using my account (Domain Admin), installed the TS Role and all of its features. Setup everything and added some RemoteApp(s). Rebooted and logged onto the http://server/ts to test remote apps, all worked fine.  RDP'd to the box via mstsc and all worked fine.

    Now here is where it gets odd.

    When I logon using the same account I used to install the role and features on the server (From my Vista laptop) - Easy print doesn't redirect my default printer which is a network mapped LPR port using either a RemoteApp or MSTSC (ensuring that the allow redirect of printers is enabled) and that the GP(s) are enabled to force redirection of my default printer.

    When I logon using a different account (also a domain admin account) from the same Vista laptop - Easy print works without issue from both MSTSC and RemoteApp with the same LPR mapped printer as my default.

    When I logon from an XP32 SP3 RDP6.1 and .NET3.5 with the same account used to setup the server role and features - Easy print still doesn't work with the same LPR mapped printer using either MSTSC or RemoteApp.

    When I logon from the same XP desktop as above with a different account (the same as the vista step) - Easy print works without issue again from both MSTSC and RemoteApp.

     

    What could be causing this issue... Is there something in my account... Did it have to do with me using that account to install the TS Role and Features?

     

    Thursday, January 29, 2009 9:56 PM

All replies

  • Well after asking my question it got me thinking, could it be something on my account preventing printer redirection... In fact, YES it can... After comparing my acount with the account I knew worked I located the problem which wasn't really a problem but more a self inflicted "situation".

    Via ADUC if you open the account properties> Environment Tab > Under the 'Client Devices' section you have three settings which appear to take precedence over any GPO and settings applied to the RDP adapter on the host:

    Connect client drives at logon:
    Connect client printers at logon:
    Default to main client printer:

    Problem solved - Hope this helps someone.

    • Proposed as answer by JGaskell Thursday, August 23, 2012 3:16 PM
    Friday, January 30, 2009 3:00 PM
  • 3 years later - Thank you!  Don't know if I would have found this otherwise.

    Jonathan Gaskell - MCSA (2003), MCITP: Server Administrator

    Thursday, August 23, 2012 3:16 PM
  • Patrick,

    This saved my rear!  I have been on the phone with Microsoft Premier support ALL DAY and while waiting I sifted through additional TechNet posts.  There are a metric ton of posts on redirecting printers.  Everything checked out.  MPS had me installing hotfixes all day.  After some critical thinking, I came back to the conclusion that it had to be somewhere in the profile.  I looked everywhere, client side, server side, roaming side.  The environment tab is rarely used and by default that box is checked.  Some sys admin went and unchecked it for a few users!

    Again, you saved the day.  You should bill MPS since they are billing us!

    -Ryan

    Monday, September 23, 2013 9:59 PM