Unable to access internet, or join virtual machine to the domain.


  • Good evening.

    Let me explain my situation.

    The host server runs the following services/applications:

    Domain Controller
    DNS Server
    Hyper-V Host
    Exchange 2007

    The host server is a Windows Small Business Server 2008 (Premium 64x)

    The 1 and only virtual guest O/S is Windows Server 2008 Standard (64-bit)

    Now that you have a basic understanding, let me get to my problem.

    The host server has 2 physical NIC's.  We will call these LAN 1 and LAN 2.

    Currently, LAN 1 is enabled and has the IP address of  (Gateway is

    I want to setup the guest OS to use the LAN 2.  My unused, 2nd NIC. 

    Is that possible?

    For some reason (maybe you know?) Win SMS 2008 decided it was a good idea to disable LAN2. 

    When I enable it.  It shows as "Access to Local Only".  Why?  I have a Cat5 cable running between the firewall/switch and LAN2 (as well as LAN1).  Yet, I get no internet access on that port?

    My current problem is that, I created an EXTERNAL Virtual Network and it's bound to LAN1.  It will not connect to the internet and I cannot add the guest O/S (VM) to my Domain.  No updates from Microsoft, and no no domain access.

    What am I doing wrong? 

    Here are some screen shots of my configurations:


    SCREEN SHOT 1:  Virtual Machine /IPCONFIG command.
         - As you can see, it's not getting the proper IP address from DHCP.  Though, it will need a static IP eventually.

    SCREEN SHOT 2:  Cannot Join Virtual Machine to Domain
         - Error message.

    SCREEN SHOT 3:  Virtual Machine Network Connections

    SCREEN SHOT 4:  Virtual NIC Properties


    SCREEN SHOT 5:  Network Connections Overview

         -Shows the 2 physical and 1 virtual NIC's

    SCREEN SHOT 6:  Physical NIC #1
         -This is the NIC I use for the host server and the virtual NIC is bound EXTERNAL to this physical NIC. Static IP.

    SCREEN SHOT 7:  Physical NIC #2
         -For some reason, the NIC was disabled after installing Windows SMS 2008.  I have enabled it, plugged it in and only get local access from it.  Why?

    SCREEN SHOT 8:  Virtual NIC #1
         -The virtual NIC which is bound to Physical NIC #1 and only gets local access. 

    SCREEN SHOT 9:  IPCONFIG /all on host server showing local only, no IP address from DHCP obtained.

    So, what am I doing wrong?

    1.  Cannot join guest to domain.
    2.  Cannot get IP address from DHCP (have not tried static)
    3.  Cannot get host physical adapter to grant more than "local" access.
    4.  Cannot get guest virtual adapter an IP address from DHCP or get internet access.

    Thank you VERY much for your time!
    Friday, June 19, 2009 1:31 AM

All replies

  • Well, after 2 days of trouble just getting Hyper-V to work on this brand-new system... I'm going to remove the roll and give VMWare a shot.  I just don't see much support out here on the internet for Hyper-V.  Two days down and a boss that just doesn't want to spend another $300 on an incident report with Microsoft... what can I do?  I'm sure Hyper-V is fantastic when it works!
    Friday, June 19, 2009 5:01 AM
  • Wow!  It just gets better and better!  After removing the Hyper-V role from the server and restarting... it hangs up at "Configuring updates Stage 3 of 3 - 76% complete."

    What a lovely piece of software! 
    Friday, June 19, 2009 5:06 AM
  • After holding the power button down on MY SERVER I was able to get past the botched removal of the Hyper-V role.  Funny, even uninstalling it causes issues.  VMWare, here I come!
    Friday, June 19, 2009 5:16 AM
  • Hi,


    First of all, I would like you ask you have a read of the following articles about Hyper-V networking.


    Understanding Networking with Hyper-V


    How does basic networking work in Hyper-V?


    Configuring Virtual Networks


    In your environment, you have two NICs, right? Generally speaking, we recommend that you dedicate a NIC for Hyper-V management use if you have several NICs on the host machine. Then you can create an External Virtual Network bound to another NIC.(As you said, you want to use LAN2 here). After you create the External Virtual Network, the system will spawn a Virtual Network adapter(if you only have one NIC, the host will use this Virtual Network Adapter to communicate with the outside), you can disable this adapter because you have a dedicate NIC for Hyper-V management.


    In addition, we don’t recommend that you install any other services/applications on the Hyper-V host machine, the best practice should be only keep Hyper-V role on the machine. You can create the VMs for the other services/applications you want to install.



    Best regards,

    Vincent Hu


    Friday, June 19, 2009 7:47 AM
  • I have read all three. None explain how to get the virtual machine to access the external network.

    I originally bound the Virtual Network to the wron NIC. I have corrected this mistake, still not resolved. Unable to ping external network. Sometimes with Ipconfig withing the guest OS I see that the virtual adapter has a 196... IP. I have changed to a static IP and still no network. I have restarted the guest OS without resolution.

    Restarting the host OS does not resolve this issue.

    The error message in Network conncections refers to the guest os not receiving an address. IPCONFIG /RENEW returns an error that the guest OS has obtained an IP that is already in use by the client.

    Is there someplace to get this information?
    Friday, July 24, 2009 1:05 PM
  •   I would suggest that you start again from scratch. Reserve one NIC for the host (no virtual networks linked to it). Create a virtual network linked to one ot the other NICs. Connect the NIC in your vm to this network.
    Sunday, July 26, 2009 12:08 AM
  • My SBS 2008 box is stuck at 76% for over 16 hours nows, server is operational but cannot log on to it. Don't want to bounce it and it is also running exchange server :( I'll wait a bit longer in the hope it resolves itself 
    Wednesday, April 14, 2010 11:40 PM
  • I had the same symptoms as Green-Grocers and finally worked out the problem, maybe this will help someone.

    The guest OS was initially configured to use DHCP to get its IP address and I needed to change this to use a static address. When I did this I typed in all the details, but when I clicked OK it did not save the default gateway. There was nothing obvious to alert me to this so I didn't think to go check this when I saw the message about "Access to Local Only". I later discovered what was happening while trying to get it to work with a legacy adaptor. In this case I was able to rectify the problem by going back into the IPv4 properties dialog and re-entering the default gateway. 

    To verify I wasn't imagining this, I tried removing then re-adding the network adaptor from the virtual machine configuration and sure enough it did the same thing every time. The behaviour was the same for the legacy adaptor and the regular network adaptor. So if you change the IPv4 settings and you lose your internet access, go check that it hasn't ignored your default gateway setting.

    Tuesday, May 18, 2010 2:06 AM
  • Is it possible to get internet working on hyper-v virtual machine with only 1 nic on host machine? I have a developer box with hyper-v installed. I want to connect from a virtual machine to central DB servers. But I get no ip from company dhcp
    Monday, November 15, 2010 9:32 AM
  • Recreated external network a few times. It works now. Don't know what the problem was.
    • Proposed as answer by waaromikniet Friday, December 03, 2010 9:59 AM
    Friday, December 03, 2010 9:58 AM
  • Is it possible to get internet working on hyper-v virtual machine with only 1 nic on host machine? I have a developer box with hyper-v installed. I want to connect from a virtual machine to central DB servers. But I get no ip from company dhcp

    I am trying to do the same thing.
    Thursday, September 15, 2011 1:56 PM
  • Would seem " Microsoft Support" is the ultimate oxymoron


    Friday, March 30, 2012 4:39 AM