none
Internet Explorer 8 not refreshing pages RRS feed

  • Question

  • I am having a weird problem where Internet Explorer 8 (in Windows Server 2008 R2) does not refresh pages properly.  No matter what I do (clean cache) set days to store webpages = 0, etc., stale pages appear in the browser window.  This strange behavior started back in August when I updated my Server 2008 R2 beta to the RTM version.  Any ideas on what I can do? 
    Monday, November 23, 2009 4:58 AM

Answers

All replies

  • Hello,

     

    In order to narrow down the cause of the issue more efficiently, let us refer the following steps to perform a Clean Boot.

     

    Step 1: Perform a Clean Boot

     

    1. Click "Start", go to "Run", and type "msconfig" in the open box to start the System Configuration Utility.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click Disable All (if it is not gray).

     

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    4.  Restart your computer. When the "System Configuration Utility" window appears, please check the box and click "OK".

     

    Step 2: Clear Internet Explorer browsing history

     

    1. Click IE

     

    2. Click Tools

     

    3. Internet Options

     

    4. Click Delete… button in Browsing history area

     

    5. Select the checkbox for "Temporary Internet files", "Cookies", "History", "Form data", "Passwords"

     

    6. Click Delete button to proceed.

    Please close and re-open IE to see if the stale page still appear in browser window.


    If the issue still continues, we suggest that you post a new thread in our Internet Explorer newsgroup. The community members and support profressional are more farmiliar with it and can help you in a more efficient way.

    Discussions in microsoft.public.internetexplorer.general
     

    Hope it helps.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Edited by David Shen Tuesday, November 24, 2009 7:01 AM
    Tuesday, November 24, 2009 2:35 AM
  • Hi There,

    I would suggest you to follow the david suggestion and also please make sure

    a) you clean up the server for AV

    b) Test it on different PC and test the behavior

    I think we havent seen this issue earlier with customers.


    David , do we support IE in this forum ? ( earlier we used to forward the requests to IE newsgroup, so just though of confirming)
    Tuesday, November 24, 2009 6:04 AM
    Moderator
  • Hi Sainath,

    Generally speaking, if the IE issue happens on Windows Server system, we will provide customer with some suggestions here in this forum. For IE related issue, it is better to be answered in IE newsgroup.

    Thank you for your support.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, November 24, 2009 7:08 AM
  • Hi David,

    Thanks for detailed explanation :)

    will continue supporting IE as per your advice :)
    Tuesday, November 24, 2009 7:20 AM
    Moderator
  • Hello,

     

    In order to narrow down the cause of the issue more efficiently, let us refer the following steps to perform a Clean Boot.

     

    Step 1: Perform a Clean Boot

     

    1. Click "Start", go to "Run", and type "msconfig" in the open box to start the System Configuration Utility.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click Disable All (if it is not gray).

     

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    4.  Restart your computer. When the "System Configuration Utility" window appears, please check the box and click "OK".

     

    Step 2: Clear Internet Explorer browsing history

     

    1. Click IE

     

    2. Click Tools

     

    3. Internet Options

     

    4. Click Delete… button in Browsing history area

     

    5. Select the checkbox for "Temporary Internet files", "Cookies", "History", "Form data", "Passwords"

     

    6. Click Delete button to proceed.

    Please close and re-open IE to see if the stale page still appear in browser window.


    If the issue still continues, we suggest that you post a new thread in our Internet Explorer newsgroup. The community members and support profressional are more farmiliar with it and can help you in a more efficient way.

    Discussions in microsoft.public.internetexplorer.general
     

    Hope it helps.


    This posting is provided "AS IS" with no warranties, and confers no rights.

    I did this, except that I could not delete the cookies, passwords and form data.  I depend on those stored items, otherwise I cannot log into the websites that I need.  But when I tried again I still have stale pages in the browser.  Its really weird.  I have no problem with IE8 on my windows 7 machines.

    I guess AV as suggested by the person below is anti-virus, but when I tried to install Security Essentials it said it would not install on my operating system. 
    Tuesday, November 24, 2009 9:33 AM
  • Hi There,

    thanks for the information , there might be some cookie / bad meta content which might be causing this behavior, and a better way is to take the back up of your cookies and forms and then delete the passwords, cookies, forms etc and also any 3r party plug-ins
    Wednesday, November 25, 2009 4:14 AM
    Moderator
  • I guess AV as suggested by the person below is anti-virus, but when I tried to install Security Essentials it said it would not install on my operating system. 

    Security Essentials is not supported on Servers.
    Wednesday, November 25, 2009 2:41 PM
  • Hi Nmstough

    did you had a chance to work on the issue ?

    Thursday, November 26, 2009 1:12 AM
    Moderator
  • Hi nmstough,

    If the issue still exist, I suggest you post it in Discussions in microsoft.public.internetexplorer.general for more support. It is better to be answer there.

    Thank you for your understanding.

    Hope the issue will be resolved soon.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by David Shen Monday, December 7, 2009 2:10 AM
    Tuesday, December 1, 2009 7:24 AM