locked
Office install takes hours on RDS server RRS feed

  • Question

  • We have several 2008R2 RDS servers in an RDP farm. When installing office, it takes hours to install. Windows updates are also extremely slow. Any suggestions?
    Thursday, May 9, 2013 4:03 AM

Answers

  • Hi,

    I have no details about 2008r2 server and environment. In general,there could be caused by some 3rd party application.
    Pls try the following steps and check the result.

    Perform clean boot i.e. disable all the non Microsoft programs to find the culprit and check the result.
    a. Open the article: http://support.microsoft.com/kb/929135
    b. From the article, follow "Step 1: Perform a clean boot" Executing these steps will disable all the non Microsoft programs running on the computer.
    c. Check if the issue persists.
    d. If the issue does not persist in clean boot, it means that some non Microsoft program is causing the issue.
    e. To find out the program that's causing the issue, try "Step 2: Enable half of the services" to "Step 6: Resolve the problem"
    f. Once you find the culprit, check if there are any updates or patches for the program. If you find any, install them and check the difference or reinstall the latest program.
    g. From the article, follow "Step 7: Reset the computer to start as usual"

    In addition,using Performance Monitor to monitor the performance of the server status, if the memory or CPU loading is too high. Then you can find which process ID causing the problem.

     

    More information:

    Using Performance Monitor

    http://technet.microsoft.com/en-us/library/cc749115.aspx

     

    Performance Monitor Wizard

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=31fccd98-c3a1-4644-9622-faa046d69214

    regards,

    Clarence


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, May 13, 2013 9:55 AM