locked
Silently Deploy RemoteApp and Desktop Connection RRS feed

  • Question

  • Hi,

    When I'm trying to deploy RemoteApp and Desktop Connections through GPO, it works but then it fails to update.

    Start-Process -FilePath rundll32.exe -ArgumentList 'tsworkspace,WorkspaceSilentSetup', "\\shares\feed.wcx" -NoNewWindow -Wait

    the Feed.wcx file:

    <?xml version="1.0" encoding="utf-8" standalone="yes"?>
    <workspace name="Enterprise Remote Access" xmlns="http://schemas.microsoft.com/ts/2008/09/tswcx" xmlns:xs="http://www.w3.org/2001/XMLSchema">
      <defaultFeed url="https://remote.domain.com/RDWeb/Feed/webfeed.aspx" />
    </workspace>

    Applying the previous works perfectly for the first time, but when I update the connection from Task Scheduler it fails with the following error in event viewer:

    An error occurred. Contact your workplace administrator for assistance.
    Connection name: Work Resources
    Connection URL: https://remote.domain.com/rdweb/feed/webfeed.aspx
    Error code: 0x800700B7, 0x0

    Now, when I manually add the connection in control panel, the update task works normally without any issues.

    Do you have any idea why silently deploying the connection causes an issue with the update task?

    Thanks in advance,

    Housam Smadi,


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer". This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    Thursday, August 2, 2018 7:24 PM

All replies

  • Hi,

    >when I manually add the connection in control panel, the update task works normally without any issues.
    Please follow the deploy steps mentioned in below articles to configure again and check the update scheduler.

    Automating the silent deployment of RemoteApp and Desktop Connection.
    https://blogs.msdn.microsoft.com/dsadsi/2011/11/30/automating-the-silent-deployment-of-remoteapp-and-desktop-connection/

    Configure RemoteApp and Desktop Connection on Windows 7 Clients:
    https://gallery.technet.microsoft.com/scriptcenter/313a95b3-a698-4bb0-9ed6-d89a47eacc72

    If problem persists, as scripting is beyond the support scope, I would recommend you to post on TechNet – The Official Scripting Guys Forum, relate expert may provide you more suggestion:
    https://social.technet.microsoft.com/Forums/en-us/home?forum=ITCG&filter=alltypes&sort=lastpostdesc

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 6, 2018 5:31 AM
  • Hi,

    I've followed the same documentation before, with no success.

    This is what I get:

    I will try to post it again on The Official Scripting Guys Forum.

    Thanks,

    Housam Smadi


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer". This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    Monday, August 6, 2018 11:25 AM
  • Hi,

    Thank you for detail updating.

    Please provide more information about your deployment, and I will try to re-product it on my test environment:
    1. Windows Server OS version - run winver and check the OS build and version.
    2. General description about your RDS deployment, such as server number and installed RDS server role.
    3. Client OS version – run winver and check the OS build and version.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 7, 2018 1:48 AM
  • Hi,

    We are running Windows server 2016 Version 1607 (OS Build 14393.2248) on all of our servers.

    The RDS Deployment:

    AD - RDWA - RDCB - RDGW - RDSH01 - RDSH02

    RDSH01 is a Session host for desktops

    RDSH02 is a RemoteApp Server

    The idea here is to deploy RemoteApp and Desktop Connections on the RDSH01 so users will be able to access the RemoteApps.

    By following the links you provided earlier, I was able to add the connection, but the connection update still failing.

    Hope you can find something that help addressing this issue.

    Regards,

    Housam Smadi


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer". This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    Tuesday, August 7, 2018 12:16 PM
  • Hi,

    Thank you for detail sharing, I will try to re-produce it and check the details. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 8, 2018 7:21 AM
  • Hi Eve,

    I was just wondering if you were able to re-produce it and check the details.

    Regards,

    Housam Smadi


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer". This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    Wednesday, August 15, 2018 12:17 PM