none
WIndows 2012 R2 VM not listening on port 3389 RRS feed

  • Question

  • Hello All -

    I have an issue I would like to fix instead of just reloading the OS.  I have a server that is not listening on port 3389.  Below are the steps I have taken to try and correct the issue without any success

    1) Firewall is not running or blocking

    2) A/v client is not blocking / I have disabled as a test

    3) I have shutdown any other application services in case there might have been a port conflict

    4) netstat -aon confirms server is not listening on 3389

    5) I have confirmed the Remote Desktop service is running

    6) I have confirmed the port is correct in HKLM\current control set\control\Terminal Server\Winstations\RDP-TCP

    7) I have imported a working 2012 R2 Server RDP-TCP reg key into the server

    8) I have  made sure Remote Desktop is enabled in server manager

    9) Allow remote connections is active (via group policy) and is selected in 'System Properties'

    10) I have added, as a test, the Remote Desktop Services role, and was still unable to get the server to accept connections on 3389

    11) I have changed the port in the RDP-TCP registry key to something other than 3389, rebooted, ran netstat -aon, and was still unable to see the server as accepting connections on my new port

    12) I am unable to telnet to 3389 on that server

    13) I can create RDP connections out to other servers from the server not accepting RDP connections.

    14) I have ran Proc Mon and TCP mon and restarted the service and haven't been able to find anything, although I could be missing what is going wrong when the Remote desktop service starts svchost -k termsvcs  

    I am out of ideas at this point.  Is there a way to reinstall just the remote management portion of windows 2012 R2?  Or any other thoughts?

    Thanks

    Justin  

    Monday, November 23, 2015 9:02 PM

Answers

All replies

  • You can try a repair install.

    https://support.microsoft.com/en-us/kb/2255099

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Monday, November 23, 2015 9:13 PM
  • It's an old issue, but I had exactly the same problem with several Windows 2012R2 installations and also tried all the things Justin listed above - no luck, no process listening on port 3389.

    But in the end I could solve the problem without reinstalling Windows: In device manager, for any reason the "UMBus Root Bus Enumerator" was missing in subtree "System devices". I added the driver by "Action->add legacy hardware->select manually->System devices->Microsoft->UMBus Root Bus Enumerator". After installing the driver and server restart port 3389 returned alive and RDP connection to the server worked again.

    • Proposed as answer by DominikS66 Friday, February 9, 2018 12:36 PM
    Friday, February 9, 2018 12:29 PM