none
Errors with VM creation/config/start

    Question

  • I have been using the Hyper-V betas flawlessly but ever since using the Hyper-V RC, I have had a ton of problems.  I cannot seem to reliably create a VM and try to start it.  If I try to create a VM without connecting it to a Network I get:

    [Window Title]
    New Virtual Machine Wizard

    [Main Instruction]
    The server encountered an error while configuring memory on Test. Wizard failed in rolling back the created virtual machine. Please delete it manually afterwards.

    [Content]
    Failed to add device 'Microsoft Synthetic Ethernet Port'.

    [Expanded Information]
    'Test' failed to add device 'Microsoft Synthetic Ethernet Port'. (VMID 209E241A-2FAF-4B59-8312-5D55B521B409)

    The Virtual Machines configuration 209E241A-2FAF-4B59-8312-5D55B521B409 at 'C:\HV\Hyper-V' is no longer accessible: The requested operation cannot be performed on a file with a user-mapped section open. (0x800704C8)

    Cake Hide details  [Close]

     

    After this error the VM is gone from the UI and the Virtual Machine Management Service is stopped.  The Event Log for VMMS shows Error events with IDs 16410 and 14140.

     

     

    If I create a VM connected to the network then open up the Settings dialog and save it then it at least will not get removed right away.  However, when I try to start it I get:

     

    [Window Title]
    Hyper-V Manager

    [Main Instruction]
    An error occurred while attempting to change the state of virtual machine Test.

    [Content]
    'Test' failed to start.

    Microsoft Synthetic Ethernet Port (Instance ID {CF502D0E-D34B-49DF-9785-704B8755645E}): Failed to Power On with Error 'The specified network resource or device is no longer available.'

    [Expanded Information]
    'Test' failed to start. (VMID 2B01ED2B-FF89-4E16-9011-6BA6E7565535)

    'Test' Microsoft Synthetic Ethernet Port (Instance ID {CF502D0E-D34B-49DF-9785-704B8755645E}): Failed to Power On with Error 'The specified network resource or device is no longer available.' (0x80070037). (VMID 2B01ED2B-FF89-4E16-9011-6BA6E7565535)

    Cake Hide details  [Close]

     

    After this the VMMS is stopped and the VM is removed from the UI the next time I start the VMMS.

     

    These errors have made Hyper-V pretty much unusable for me.  Does anyone have some help on what might be causing this?  I have rebuilt the server from bare metal twice now and removed and reinstalled the Hyper-V role numerous times trying to get it to work.  The server is a Dell 2970 with the latest BIOS and drivers.

     

    Thanks,

    Joseph

    Thursday, April 24, 2008 2:31 PM

Answers

All replies

  • I am assuming tha tyou are using VMs that you created prior to the RC0 upgrade?

     

    I am also guessing that you searched the forums and found an idea to delete and recreate your virtual networks?

     

    And, that to reuse your old VMs (that were created prior to upgrading the RC0) that you would need to create a new configuration and attache to the existing VHD?

    (snapshots and snapshot trees cannot be migrated from beta to RC0)

     

     

    Thursday, April 24, 2008 3:37 PM
    Moderator
  • I am trying to create brand new VMs with brand new VHD files, no previous VMs.

     

    I have tried this with deletion of the virtual networks and also with bare metal full reinstall of Windows Server 2008 and then putting the role in again brand new and updating and also removing the role and rebooting and then putting the role in again.  All have the same result.

     

    I am not trying to reuse an old VM, just create a blank new one that I can install fresh from an install ISO.

     

    Thursday, April 24, 2008 3:49 PM
  • I am pleased to say that I finally figured it out!!

     

    After reading another thread on the forum about issues with Trend AV and Forefront I suspected that it may be due to having ForeFront on the parent partition.  I excluded the VHD and XML file types from ForeFront and voila, no more problems.  I have been building and changing and swapping out virtual NICs all afternoon without issue.

     

    Hope this helps others.

     

    Joseph

     

    Tuesday, April 29, 2008 8:05 PM
  • I THANK YOU THANK YOU THANK YOU!!!!! You helped me GREATLY!  We use TrendMicro OfficeScan and I disabled that on the Microsoft Windows Server 2008 x64 Enterprise Edition and it worked LIKE A CHAMP!  THANK YOU!  I AM SO HAPPY!! YA!

    Goooo Hyper-V!
    Wednesday, June 25, 2008 7:32 PM
  • I have AVG antivirus and excluding the paths the virtuals are on  fixed it for me too :)
    Thursday, July 31, 2008 3:19 PM
  • Same, i removed Trend-micro antivirus for Windows server 2008 64bit and it worked. I was able to get it back up and running.

    Any idea why Hyper-v "loses" my Virtual Machines and snapshots?
    Friday, August 15, 2008 12:50 PM
  • I had logged exact same problem a while ago.
    (http://forums.technet.microsoft.com/en-US/winserverhyperv/thread/d7341f32-ce86-4638-a0d7-0b0f9cb2f78d)

    Thanks for the clue I've put in both my Hyper-V machines with Forefront.
    Cheers.
    • Marked as answer by David Shen Monday, August 18, 2008 5:36 AM
    Monday, August 18, 2008 5:08 AM
  • I am running TrendMicro "Worry-Free Business Security" and have been unabled to solve the start-failure due to the network adapter problem. I put every directory I could think of in the exclusion list and it did not help.

    After some snooping I finally discovered why the failed virtual machine disappears from the Hyper-V Manager.

    You can recover a virtual machine that disappears after getting the start-failure due to the network adapter.

    - Stop Hyper-V services. Yes, this is a pain but the VM config files are locked by Hyper-V.

    - Use Notepad to open the config file for the failed virtual machine. It will be in the virtual machine directory. The name will be the GUID of the virtual machine with an XML extension.

    - Go to the bottom of the file. You will find the following corruption:

      </settings>
    </configuration>ght type="integer">100</weight>
        </processors>
      </settings>
    </configuration>

    - Delete the bolded part.

    - Save the file and restart Hyper-V Services. Your missing virtual machine should reappear.

    - Connect to the virtual machine. Click File/Settings/Network Adapter. Set and save.

    You should be able to start the virtual machine. However, the VM will not recognize the NIC.

    One problem down, one (or more) to go.

    I seriously hope this problem is resovled in R2. I'm not sure it's worth the trouble to upgrade to Svr 2008. Svr 2003 with VSvr 2005 works.

    Follow-up:
    I discovered that deleting the network adapater and adding a legacy network adapater allows the VM to recognize the NIC. It seems that the "Network Adapater" is usable only when integration components are installed on the guest OS. That would not be a problem except most OS'es do not come out of the box with hyper-v integration components installed and Hyper-V does not give you a choice of the adapter type when creating a new VM. In fact the VM creation fails if "Not Connected" is chosen.

    The next problem to resolve is getting Ubuntu to recognize the virtual display adapter. But that's an entirely different community of people.

    Enjoy!

    • Edited by SuitedPair Sunday, January 11, 2009 4:36 PM Follow-up
    Sunday, January 11, 2009 2:52 PM
  • SuitedPair, please send me one of your problem XML files before making any changes to it. I'm researching this issue.
    Saturday, January 17, 2009 3:45 PM
    Moderator
  • Hi,

    I have the same problem on a failover Cluster of Windows 2008 enterprise x64 with all updates and recommended hotfixes.
    I removed Trend some time ago, could it be a problem with a client accessing the files on the EMC SAN while hyper-V Management Service is down?

    Here is an extract of the XML file :

    <?xml version="1.0" encoding="UTF-16" standalone="yes"?>
    <configuration>
      <_2497f4de-e9fa-4204-80e4-4b75c46419c0_>
        <EnabledState type="integer">3</EnabledState>
      </_2497f4de-e9fa-4204-80e4-4b75c46419c0_>
      <_83f8638b-8dca-4152-9eda-2ca8b33039b4_>
        <controller0>
          <drive0>
            <pathname type="string">M:\SRV-DC.vhd</pathname>
            <type type="string">VHD</type>
          </drive0>
          <drive1>
            <pathname type="string"></pathname>
            <type type="string">NONE</type>
          </drive1>
        </controller0>
        <controller1>
          <drive0>
            <pathname type="string">I:\WIN2K8.ISO</pathname>
            <type type="string">ISO</type>
          </drive0>
          <drive1>
            <pathname type="string"></pathname>
            <type type="string">NONE</type>
          </drive1>
        </controller1>
        <enable_track_cache type="bool">True</enable_track_cache>
        <version type="integer">5</version>
      </_83f8638b-8dca-4152-9eda-2ca8b33039b4_>
      <_8e3a359f-559a-4b6a-98a9-1690a6100ed7_>
        <port0>
          <connection type="string"></connection>
        </port0>
        <port1>
          <connection type="string"></connection>
        </port1>
        <version type="integer">2</version>
      </_8e3a359f-559a-4b6a-98a9-1690a6100ed7_>
      <_8f0d2762-0b00-4e04-af4f-19010527cb93_>
        <controller0>
          <drive0>
            <pathname type="string"></pathname>
            <type type="string">VFD</type>
          </drive0>
        </controller0>
        <version type="integer">1</version>
      </_8f0d2762-0b00-4e04-af4f-19010527cb93_>
      <_ac6b8dc1-3257-4a70-b1b2-a9c9215659ad_>
        <base_board>
          <serial_number type="string">6425-6568-2740-6594-9289-5126-95</serial_number>
        </base_board>
        <bios_guid type="string">{DDC539B2-49C8-41B4-9262-F1BF377986ED}</bios_guid>
        <bios_serial_number type="string">6425-6568-2740-6594-9289-5126-95</bios_serial_number>
        <boot>
          <device0 type="string">Optical</device0>
          <device1 type="string">HardDrive</device1>
          <device2 type="string">Network</device2>
          <device3 type="string">Floppy</device3>
        </boot>
        <chassis>
          <asset_tag type="string">7861-6295-0528-2969-6285-3858-81</asset_tag>
          <serial_number type="string">6425-6568-2740-6594-9289-5126-95</serial_number>
        </chassis>
        <num_lock type="bool">False</num_lock>
        <version type="integer">2</version>
      </_ac6b8dc1-3257-4a70-b1b2-a9c9215659ad_>
      <_b71aecab-1e44-4bba-80a7-68346e390d43_>
        <ChannelInstanceGuid type="string">{7484dc13-289e-411a-914f-4b3dc889c033}</ChannelInstanceGuid>
        <FriendlyName type="string">Carte réseau</FriendlyName>
        <IsConnected type="bool">False</IsConnected>
        <MacAddress type="string">00-15-5D-0A-33-0B</MacAddress>
        <MacAddressIsStatic type="bool">False</MacAddressIsStatic>
        <PortName type="string"></PortName>
        <SwitchName type="string"></SwitchName>
      </_b71aecab-1e44-4bba-80a7-68346e390d43_>
      <_db8b9818-b4bb-4725-b99d-b4612716b6b4_>
        <SPD_A0 type="integer">3257965116</SPD_A0>
        <SPD_A2 type="integer">352717719</SPD_A2>
        <SPD_A4 type="integer">2316913409</SPD_A4>
        <SPD_A6 type="integer">3633832653</SPD_A6>
        <version type="integer">0</version>
      </_db8b9818-b4bb-4725-b99d-b4612716b6b4_>
      <global_settings>
        <disk_merge_pending type="bool">False</disk_merge_pending>
        <owner>
          <sid type="string">S-1-5-21-1183404426-1438797297-709122288-15670</sid>
        </owner>
        <power>
          <host_shutdown>
            <action type="integer">2</action>
          </host_shutdown>
          <host_startup>
            <action type="integer">0</action>
            <delay type="integer">0</delay>
          </host_startup>
        </power>
        <snapshots>
          <list>
            <size type="integer">0</size>
          </list>
        </snapshots>
        <unexpected_termination>
          <action type="integer">0</action>
        </unexpected_termination>
      </global_settings>
      <manifest>
        <size type="integer">8</size>
        <vdev001>
          <device type="string">58f75a6d-d949-4320-99e1-a2a2576d581c</device>
          <flags type="integer">1</flags>
          <instance type="string">58f75a6d-d949-4320-99e1-a2a2576d581c</instance>
          <name type="string">Microsoft Synthetic Mouse</name>
        </vdev001>
        <vdev002>
          <device type="string">f3cf6965-e8d3-44a9-9b7d-a04245ea7525</device>
          <flags type="integer">1</flags>
          <instance type="string">f3cf6965-e8d3-44a9-9b7d-a04245ea7525</instance>
          <name type="string">Microsoft Synthetic Video</name>
        </vdev002>
        <vdev003>
          <device type="string">84eaae65-2f2e-45f5-9bb5-0e857dc8eb47</device>
          <flags type="integer">1</flags>
          <instance type="string">84eaae65-2f2e-45f5-9bb5-0e857dc8eb47</instance>
          <name type="string">Microsoft Heartbeat Component</name>
        </vdev003>
        <vdev004>
          <device type="string">2a34b1c2-fd73-4043-8a5b-dd2159bc743f</device>
          <flags type="integer">1</flags>
          <instance type="string">2a34b1c2-fd73-4043-8a5b-dd2159bc743f</instance>
          <name type="string">Microsoft Key-Value Pair Exchange Component</name>
        </vdev004>
        <vdev005>
          <device type="string">9f8233ac-be49-4c79-8ee3-e7e1985b2077</device>
          <flags type="integer">1</flags>
          <instance type="string">9f8233ac-be49-4c79-8ee3-e7e1985b2077</instance>
          <name type="string">Microsoft Shutdown Component</name>
        </vdev005>
        <vdev006>
          <device type="string">2497f4de-e9fa-4204-80e4-4b75c46419c0</device>
          <flags type="integer">1</flags>
          <instance type="string">2497f4de-e9fa-4204-80e4-4b75c46419c0</instance>
          <name type="string">Microsoft Time Synchronization Component</name>
        </vdev006>
        <vdev007>
          <device type="string">5ced1297-4598-4915-a5fc-ad21bb4d02a4</device>
          <flags type="integer">1</flags>
          <instance type="string">5ced1297-4598-4915-a5fc-ad21bb4d02a4</instance>
          <name type="string">Microsoft VSS Component</name>
        </vdev007>
        <vdev008>
          <device type="string">2fc216b0-d2e2-4967-9b6d-b8a5c9ca2778</device>
          <flags type="integer">1</flags>
          <instance type="string">b71aecab-1e44-4bba-80a7-68346e390d43</instance>
          <name type="string">Microsoft Synthetic Ethernet Port</name>
        </vdev008>
        <version type="integer">260</version>
      </manifest>
      <properties>
        <global_id type="string">50482D81-F1C2-45BC-BF82-D0AB8EAEB798</global_id>
        <last_powered_off_time type="integer">128846952068618699</last_powered_off_time>
        <last_powered_on_time type="integer">128846952165555769</last_powered_on_time>
        <last_state_change_time type="integer">128851955453211085</last_state_change_time>
        <name type="string">SRV-DC</name>
        <notes type="string"></notes>
        <type_id type="string">Virtual Machines</type_id>
      </properties>
      <savedstate />
      <settings>
        <global>
          <logical_id type="string">50482D81-F1C2-45BC-BF82-D0AB8EAEB798</logical_id>
        </global>
        <memory>
          <bank>
            <size type="integer">1024</size>
          </bank>
        </memory>
        <processors>
          <count type="integer">1</count>
          <limit type="integer">100000</limit>
          <reservation type="integer">0</reservation>
          <weight type="integer">100</weight>
        </processors>
        <stopped_at_host_shutdown type="bool">False</stopped_at_host_shutdown>
      </settings>
    </configuration>tdown type="bool">False</stopped_at_host_shutdown>
      </settings>
    </configuration>


    Please help, I was just migrating Active Directory and Exchange in those VMs! That is real bad luck :(

    Regards,

    JC

    EDIT : TREND WAS BACK FROM ____
    REMOVE TREND AND SING ALLELUIAH!
    Wednesday, April 29, 2009 8:49 AM
  • Just another post to explain my cleanup :

    REMOVE TREND!!!!!!!!

    open a notepad in administrator
    open faulty XML file
    clean anything left after

    </settings>
    </configuration>
    And just before saving by using CTRL+S stop service "Hyper-V Management" by CMD or services console. Be fast as in cluster the service will restart immediatly.

    You can now put back online your Virtual Machine.

    Regards,

    Jaycee
    • Edited by jaycee79 Wednesday, April 29, 2009 11:28 AM forgot service to stop name!
    Wednesday, April 29, 2009 11:11 AM
  • This problem is still present with WS08 R2. There is no need to REMOVE Trend, just to exclude the directory where you keep your config (and probably vhd files too).
    Monday, October 12, 2009 4:50 PM
  • Hi,

    Try the hotfix from MS - http://support.microsoft.com/kb/952265

    I dont have forefront installed on my test environment, but this hotfix resolved the issue for me.

    Milton

    Tuesday, May 22, 2012 1:48 AM
  • That worked for me too!!

    We have Trend Micro Security and I couldn't figure out why we always had problems while adding new hardware to virtual machines.... Now we know why even though it doesn't make sense... Microsoft issues...

    Thank you very much for your comments
    Thursday, January 9, 2014 6:34 PM
  • Excellent. Resolved my issue!!!!
    Tuesday, September 5, 2017 4:15 AM