W2008 R2 adding a source drive fails "The Filename, directory name, or volume label syntax is incorrect"

    General discussion

  • I've a scheduled backup running to multiple removable disks. Some are offsite. Windows server 2008 R2.

    I have added a new volume to the server that needs to be backed up to the same set of removable disks. 

    However from the GUI when I try to modify the backup to include the new source volume, I get the "The Filename, directory name, or volume label syntax is incorrect".

    Have I got to take all my offiste disks onsite, delete the entire backup job (and loose all my backup history) and recreate for the new source set, adding one target volume at a time? OUCH!

    Sunday, August 29, 2010 4:45 PM

All replies

  • Hello,

    This is a known issue. Please refer to the following article on how to resolve it:


    Sriram [MSFT]

    Monday, September 06, 2010 2:31 AM
  • I am asking about source disks not target disks. I already have multiple target disks, ad I know how to manage them.

    I want to add a new source disk to an existing backup schedule including multipl offsite target disks.

    I have tried GUI and wbadmin command, both give the same error.


    Monday, September 06, 2010 5:37 AM
  • This is not expected.

    Can you pl. copy the failure traces under %windir%\Logs\WindowsServerBackup\*.etl to a folder, compress the folder and send it to (pl. remove -nospam phrase from the mail-id to get the correct one)?


    Sriram [MSFT]

    Sunday, September 12, 2010 3:26 AM
  • I am experiencing exactly the same problem as mentioned above.


    What was the resolution to this problem as I do not want to bring all offsite disks onsite to re-configure source items in the backup?


    Please advise asap.

    I.T. Construct
    Thursday, March 10, 2011 5:28 AM
  • There was no resolution. I had to destroy my backup task, re-create it and add the drives one by one as they came in to be used.
    Thursday, March 10, 2011 7:32 AM
  • I hate to revive an old thread but the wbadmin command did resolve this issue for me.
    Saturday, November 05, 2011 1:47 PM
  • Hi,

    I have the same issue. I have a Server 2012 running with three hard drives. Two of them show up correctly and are added to the Full Backup. The third and most important is not showing up in the list of drives, and it is not being backed up. I tried using recover.

    I have used the wbadmin in comman console for destination disks, but I can not find a way to add a source disk. I have never encountered a backup program that will not automatically add a hard drive when it is set to Full backup, or manually let me add one.

    Any solution to this problem would be appreciated.


    Friday, November 30, 2012 11:21 PM
  • Same issue on same version server.

    This is not a complicated process Microsoft - we need a fix!

    Friday, September 20, 2013 3:38 PM
  • PowerShell
    Saturday, September 13, 2014 5:24 PM
  • Doesn't apply to this OS (at least not according to the article)
    Saturday, September 13, 2014 5:28 PM