Trying to install Canon TS8050 Printer RRS feed

  • Question

  • Anyone suggest anything on this. Bought a Canon TS8050 printer to install on Windows 7 64 bit. Unpacked, unwrapped put ink in.

    Turned on, loaded CD... Nothing other than an annoying message.

    "To install the software you must be logged on to an administrator account. Log on as an admin and run again" 

    I AM AN ADMIN I AM I AM!!!!!

    Checked my user info

    ME, Rob = Administrator = member of (Administrators Group)

    So Mr Canon, What's your problem?

    Needless to say Canon help was the first point of call. Response, Hmmm, speak to Microsoft It's THEIR FAULT.

    Not terribly helpful, surely SOMEONE must have had a similar problem installing?

    Can anyone suggest a fix, as far as I can tel I am an admin, this should just install, never had problems before. Otherwise I have a $250 paperweight.

    Thanks in advance for any suggestions. McP.

    Friday, April 7, 2017 10:11 AM

All replies

  • Try to download an adequate driver (for Windows 7 64-bit).

    I suppose you used a driver NOT for your OS.

    Friday, April 7, 2017 12:44 PM
  • Suppose nothing, 

    The driver was ON the Printer install DVD, correct driver.

    Compatibility listed as ok on DVD for multiple versions of OS'es.

    Also contacted Canon who provided JUST the drivers, they install ok and I can connect to the printer and print. However I cannot install the Software for the printer from either the DVD or direct from the Canon site.

    Still get the "You need to be an admin message" Well I AM!

    So not much further forward.

    Friday, April 7, 2017 4:04 PM
  • Hi Rob,

    Sorry, my suggestion was nothing helpful.

    If an account "Rob" (you) is a member of Administrators group and you login with the account ”Rob", nevertheless you still get the message "To install the software you must be logged on to an administrator account. Log on as an admin and run again", I do not have any idea.

    Friday, April 7, 2017 10:38 PM
  • Hi,

    Have you tried to take ownership of this file? If not, please try it.

    Take Ownership of a File or Folder


    Have you temporarily tried to disable User Account Control and then see if you can install it?

    1. Access User Control Panel from Start Menu -> Control Panel -> User Accounts and Family Safety -> User Account

    2. Click on User Account Control settings link.

    3. Move the Slider to Never Notify

    4. Click OK to make the change effective

    5. Reboot.

    Once you have successfully installed the software, then go back to Control Panel and re-enable UAC.

    In addition, if it is a domain account, being a domain Admin isn't good enough. You need to go into the local groups and specifically add MYDOMAIN\Administrator to the administrators group (even though MYDOMAIN\Domain Admins is already in there).

    Best Regards,


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Tony_Tao Wednesday, April 12, 2017 8:55 AM
    Monday, April 10, 2017 2:32 AM
  • I've fixed this on my Windows 10 laptop as below. I believe the settings for Windows 7 will be similar.

    1- Go to start menu and Click on "Settings".

    2- Click "Accounts".

    3- Click "Other Users".

    4-  Click "Add someone else to this PC".

    5- Click "I don't have this person's sign-in information".

    6- Choose "Add a user without a Microsoft account".

    7- Fill all the required fields and create the account.

    8- Click on the created account name and choose "Change account type".

    9- Choose Account Type as "Administrator".

    10- Log off and log on again with the new user.

    11- Right click on the exe and choose "Run as administrator".

    12- When the setup is finished, you will also be able to use the printer with your original account.

    Saturday, June 20, 2020 11:07 PM