none
RDP to Windows 10 VM, connection timeout multiple times a day... RRS feed

  • Question

  • I just recently upgrade a virtual machine to Windows 10 Pro.  To access the VM, I use RDP.

    I had never ran into any issues connecting to the VM through RDP when it was Windows 7.  The connections always went through with no timeouts or errors.  Unfortunately after I performed to Win10 upgrade, it seems like I receive multiple connection timeouts throughout the day.  The only way to get RDP to connect is to reset the VM using Vsphere and then it will work for a little while.  As soon as it is left alone for a little while (I tried keeping track of time frame but it varies from 5 minutes to 2 hours), the RDP will start timing out again when trying to connect.

    I've looked through the power settings, turned off hibernation, and added registry entries to keep it from locking or sleeping but nothing has solved the issue.

    Has anyone experienced this before?  Any feedback or assistance would be greatly appreciated.

    Thank you all in advance

       
    Wednesday, November 6, 2019 2:04 PM

All replies

  • Hi,

    Please run Winver on Windows 10, check current OS build number in order to determine the system patch level.

    If it is newly upgraded/installed system, in general, it is recommended to patch the system fully with windows update/hotfix. It would be helpful for resolving some known issues and improving the performance. 

    Windows 10 update history:
    https://support.microsoft.com/en-us/help/4498140/windows-10-update-history

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 7, 2019 6:59 AM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang    

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 14, 2019 1:36 AM
    Moderator
  • Hi,

    Is there any update?

    Please click “Mark as answer” if any of above reply is helpful. It would make this reply to the top and easier to be found for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 19, 2019 2:05 AM
    Moderator