none
Task Scheduler Service (Schedule) cannot be stopped in Windows 2008 R1 + RRS feed

  • Question

  • Beginning in Windows 2008 it seems as though the windows task scheduler service can no longer be stopped from services.msc. If you right click on the service and go to properties the service is started/set to automatic and the start/stop/pause and resume buttons are greyed out. (http://imgur.com/HTGPX.gif )

    This TechNet article (http://technet.microsoft.com/en-us/library/dd363713%28WS.10%29.aspx ) mentions:
    "The Task Scheduler service is automatically started by Service Control Manager (SCM). The Task Scheduler service cannot be stopped or disabled by administrators using the Services Microsoft Management Console (MMC) snap-in user interface, unless special permissions are added to the administrator token."

    How do I assign special permissions to the administrator token? Anyone have any ideas?

    Thanks
    Brad

    Wednesday, April 7, 2010 8:18 PM

Answers


  • Hi,

    It’s not suggested to disable Task Scheduler in Vista or Windows 7. Vista and Windows 7 actually uses Task Scheduler to perform system tasks.

    If you really need to disable it, try the steps below:

    1. Open up your regedit
    2. Navigate to this location
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Schedule
    3. Find the DWORD called start, change its value from 2 to 4.

    Restart and test.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, April 12, 2010 12:18 PM
    Moderator

All replies


  • Hi,

    It’s not suggested to disable Task Scheduler in Vista or Windows 7. Vista and Windows 7 actually uses Task Scheduler to perform system tasks.

    If you really need to disable it, try the steps below:

    1. Open up your regedit
    2. Navigate to this location
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Schedule
    3. Find the DWORD called start, change its value from 2 to 4.

    Restart and test.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, April 12, 2010 12:18 PM
    Moderator
  • Thank you very much for this advice.

    It worked

    Friday, March 18, 2011 3:47 AM
  • you may also disable (or change) the startup process on the SCHEDULE service with the following:

    PSEXEC -i -s CMD

    (this opens a CMD prompt with the "NT Authority\SYSTEM" account)

    SC CONFIG SCHEDULE start= demand (changes start to MANUAL)

    SC CONFIG SCHEDULE start= disable (changes start to DISABLED)

    SC CONFIG SCHEDULE start= auto (changes start to Automatic)

    in any case, once you have this SYSTEM CMD prompt, you do NOT need to change the startup mode for the SCHEDULE service, but rather simply STOP the service as follows:

    SC STOP SCHEDULE

    or NET STOP SCHEDULE

    Hope this helps.... :-)

    • Proposed as answer by techklone Thursday, May 24, 2012 4:39 PM
    Thursday, May 24, 2012 4:39 PM