none
Not enough server storage is available to process this command

    Pregunta

  • Hi experts,

    I got "Not enough server storage is available to process this command" error on server which also cause to disappear shares, I checked all related services which are in running states.

    Did not get any eventid which point to irpstack issue.

    Even when I try to run net statistics server command I got the same error.

    Once I reboot the server error goes.

    Please can anyone provide me the permanant fix for this error as it is not possible for me to reboot server everytime.

     

    Regards,

    Shashi

     

    viernes, 14 de mayo de 2010 11:46

Respuestas

  • I found similar situation in my other engagement also.

    I observed that it is due to the NonPagedPool and PagedPool high utilization.

    This can be caused by different application process. Figure it out and apply the necessay fix to it.


    Shashi

    • Marcado como respuesta Shashi.Surve sábado, 15 de junio de 2013 4:32
    sábado, 15 de junio de 2013 4:32

Todas las respuestas

  • It is most like the IRPStack issue even without the corresponding Event ID.

    The IRPStackSize controls the amount of number of stack locations in I/O request packets (IRPs) for applications on the OS.

    http://support.microsoft.com/kb/285089

    I would increase the value of this to be between 30 and 50 (decimal) and reboot your server for the change to take affect.

    >>>Even when I try to run net statistics server command I got the same error

    This is an application requesting I/O....fits the IRPStack issue.

    >>>Once I reboot the server error goes.

    After a reboot you have freed your IPRStack usage.  Overtime as you applications start to work, you deplete your IRPStack.

     

     

    viernes, 14 de mayo de 2010 13:58
  • Do you have any third party applications installed on this computer?  Anti-virus?  Take a look at this article:

     

    http://support.microsoft.com/kb/177078

     

     


    Santhosh Sivarajan | MCTS, MCSE (W2K3/W2K/NT4), MCSA (W2K3/W2K/MSG), CCNA, Network+ Houston, TX http://blogs.sivarajan.com/ http://publications.sivarajan.com/ This posting is provided "AS IS" with no warranties, and confers no rights.
    viernes, 14 de mayo de 2010 23:19
  • Hi,

     

    According to your description, this issue might be caused by Windows setup file corruption.

     

    To resolve this issue, you may try the following methods:

     

    1.     Rename the setupapi.dll in the C:\windows\ directory, copy the setupapi.dll file from other Windows 2003 Server.

    2.     Insert the Windows 2003 Operation CD, Run "SFC /SCANNOW" and restart the server.

    3.     Perform a clean boot of the system to see if the issue continues.

    Windows 2000, Windows XP, or Windows Server 2003

    To manually perform a clean boot of your computer in Windows 2000, Windows XP, or Windows Server 2003, follow these steps:

    1.     Click Start, click Run, type msconfig, and then click OK.

    2.     On the General tab, click Selective Startup, and then click to clear the following check boxes:

    o    Process SYSTEM.INI File

    o    Process WIN.INI File

    o    Load Startup Items

    3.     On the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.

    4.     Click OK, and then click Restart to restart your computer.

    Sincerely,

    Wilson Jia


    This posting is provided "AS IS" with no warranties, and confers no rights. Please click "Mark as Answer" when you get the correct reply to your question.
    • Marcado como respuesta Wilson Jia lunes, 07 de junio de 2010 8:31
    • Desmarcado como respuesta Shashi.Surve jueves, 08 de julio de 2010 15:08
    lunes, 17 de mayo de 2010 3:31
  • Hi All,

     

    I have set the irpstack settings which did not helped me.

    I cannot proceed the solution provided by Wilson as my server is in production.

    One more thing I would like to share about the issue.

    I cannot browse \\servername UNC path whereas I can access the \\servername\<shared folder> from network.

    Regards,

    Shashi

    jueves, 08 de julio de 2010 15:11
  • Did you figure this issue out?

    I'm running into the exact same problem...

    Cheers,
    Ben

    martes, 04 de septiembre de 2012 15:11
  • Does anyone found the solution for this?

    I am still working with the workaround of rebooting the server


    Shashi

    martes, 04 de diciembre de 2012 13:28
  • Strangly enough, in my case it was an issue with firewall settings (NOD32 was not configured correctly, OK when folder sharing was allowed in the firewall settings)
    martes, 04 de diciembre de 2012 13:34
  • I found similar situation in my other engagement also.

    I observed that it is due to the NonPagedPool and PagedPool high utilization.

    This can be caused by different application process. Figure it out and apply the necessay fix to it.


    Shashi

    • Marcado como respuesta Shashi.Surve sábado, 15 de junio de 2013 4:32
    sábado, 15 de junio de 2013 4:32
  • Hi,

    I also face this problem with my Windows Server 2008 Standard 32 bit.

    My Symantec Endpoint antivirus is working as expected. Do I need to apply the IRPStackSize registry tweak ?


    /* Server Support Specialist */

    martes, 03 de septiembre de 2013 0:23
  • hi,

    There solucipon for this post?:

    "Insufficient storage space on the server to process this command"

    I have windows server 2008 R2.

    miércoles, 13 de noviembre de 2013 19:47
  • Hi,

    I am also getting the same error message. 

    I am on Win 7 OS.

    I am getting this issue while trying to decrypt encrypted text using RSA Algorithm.

    Thanks,

    Bishnu.


    Ricky

    viernes, 03 de enero de 2014 10:54
  • I had the problem as well. I am running a Windows 2003 fileserver that I could not connect to the shares. It turns out that a bunch of users were not logged off of the server. I Right Clicked on Computer -> Clicked on Manage -> Shared Folders -> Sessions. I then Closed all of the old sessions which allowed me to access the shares. I hope that helps.

    Thanks,

    Tareq Ibrahim


    • Editado Tareq Ibrahim martes, 07 de enero de 2014 21:12
    • Propuesto como respuesta Tareq Ibrahim viernes, 17 de enero de 2014 18:02
    martes, 07 de enero de 2014 21:07
  • That worked.. Thank YOU!!
    jueves, 16 de enero de 2014 19:34
  • Great
    viernes, 17 de enero de 2014 17:53