My Hyper-V no longer works - and it show VHDPARSER as unkown under devices

    Diskusi Umum

  • A guy at work patched a win2k8 data center server with the latest patches today, It took 21 patches (it had been a couple months) When it rebooted it sat at the (configuring windows fo updates) for over an HR, now keep in mind this is a (2)6 core Intel 3.4 Ghz (Dl380 g7) server so it shouldt take that long. The boss said sorry coudnt take it down any longer so he hit the power button. When it came back up it's VM's wouldnt start. thats when I got involved, I vpn'd in and tried to start them and they said a device wasnt connected. When I look in device manager (with hidden devices shown) I see one unknown device (which is yellow) it belongs to VHDPARSER. Several of the events say to reinstall Hyper-V so I tried that, (Server manager, remove role) Only thing is it whont completely uninstall when it reboots it goes into configuring fetures and bombs and reverts back. Anyone have any other ideas how I can uninstall and reinstall Hyper-V ?
    17 Juni 2012 2:40

Semua Balasan

  • Hi,

    When it came back up it's VM's wouldnt start
    >> Did you get any errors when you tried to start the virtual machines? Please also check whether there are any other Hyper-V errors in Event Viewer.


    17 Juni 2012 6:56
  • OK, This is STILL an issue but after many hours of troubleshooting I can duplicate the pproble. There seems to be an issue with the LTO 5 Tape library (HP) that is attached to this server. If the library is plugged into the external controller when the system is booted, the VHDParser.sys will not start. If I UNPLUG the the tape library the system comes up everything works fine - the VM's will start and everything (it shows VHDParser.sys as started) Once everything is back up, I plug in the tape library and it comes up and works fine. the following is the event that appears everytime I try and start a VM when Ive booted the server with the tape library attached

    'W2k8-QTS-VAPP14': Failed to open attachment 'E:\Server.Files\W2k8-QTS-VAPP14\W2k8-QTS-VAPP14.vhd'. Error: 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine ID 65ADED36-1D00-4D56-A477-493DC1FE52F6)

    20 Oktober 2012 14:37
  • So this is still an issue - Are people just ignoring this board or what ?
    27 April 2013 15:50
  • There is a reason that the message says "PLEASE don't power down the computer" while updates are installing. Windows updates can make significant changes to critical system files. Who knows where in the process the system was when you hit the power button... and also what damage that caused to your system files and/or drivers. It certainly sounds like an issue that has multiple layers stemming from that one event. My best suggestion would be a fresh install of the operating system. Then you'll know for sure whether you have a real issue or if you're fighting a battle against something you can't see.
    28 April 2013 4:07