RemoteApp Programs are not showing icons over RD Web Access


  • Hello,

    I am using a W2k8 R2 Std standalone server (Server A) and I am trying to get the RemoteApp Programs to work over the RD Web access.

    The server is in domain-A and my workstation-B is in Domain-B and I am using a VPN connection to access the server. On the managment firewall we opened the 443 port so that I could browse to the RD Web Access (https://server-a/RDWeb).

    I can successfully loggin using my Domain-A\user account. There are 3 tabs (RemoteApp Programs|Remote Desktop|Configuration).Using the functions of Remote Desktop|Configuration are working fine, for example, connecting to every server in domain-A. But I don't have the Icons on RemoteApp Programs, eventhough the RemoteApp Manager (see picture): RemoteApp Manager

    What does work is :

    • launching .rdp files from my workstation (in Domain-B which has not relation with Domain-A)
    • Using the MSI files - install them - use the apps - this works fine.

    What doesn't work is seeing the icons on the RemoteApp Programs. Neither on the internet explorer of the Server-A itself!

    I tried below articles :

    • I tried logging in with other users from domain-A

    One thing is that I can't really add my workstation-B in the TS Web Access Computers because it doesn't have any relation with Domain-A. I did add the server-A in it, and I accessed the server-a using IE but I can't really see the icons neither.

    But now I am getting a bit lost with possible solutions. Any ideas?



    14 Juni 2012 16:20

Semua Balasan