Unable to remove Read-Only attribute from a shared folder on Server 2008


  • I am having problems removing the read-only attribute from a shared folder on Server 2008 32-bit. I have tried using the steps highlighted in but still the Read-Only is ticked on the folder properties. The folder contains an MS Access database file and user's have full control in share permissions. Any advice how I can permanently uncheck the read-only on this folder will be most appreciated.
    venerdì 4 novembre 2011 10:31


Tutte le risposte

  • Have u tried with -r -s switch at a time? attrib -s -r will be the command you can try it once.
    sabato 5 novembre 2011 10:13
  • try to run attirb command in the run as administrator mode

    Darshana Jayathilake
    domenica 6 novembre 2011 15:34
  • Hi,

    Please run "attrib <path_of_the_folder>" to see if it is still a read-only folder. Though you seethe check box is selected in Properties.

    Read-only check box for folders is not available because it does not apply to the folder. You can use this check box to set the Read-only attribute for files in the folder. However, you cannot use Windows Explorer to determine whether a folder has the Read-only and System attributes set. To determine the attributes that are set on a folder, or to change these attributes, you must use the Attrib command at a command prompt.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact
    mercoledì 9 novembre 2011 06:51
  • Hi,

    This is what I have done so far based on advice posted.

    1) using run as administrator mode, i ran attrib -r -s d:\folder

    2) using run as administrator mode, i ran attrib d:\folder and got a display D:\Folder .

    Folder still displays as read-only when I click properties in windows explorer.

    Please how can 1 confirm read-only has been removed from this shared folder?

    mercoledì 9 novembre 2011 07:23
  • Hi,

    slightly change the commnad. Use attrib -s -r. Keep -s first. One more thing remove the share first.

    I was facing same problem. It got rectified through this commnad only.

    venerdì 11 novembre 2011 06:27
  • hi im in the same situation can uncheck read only option on a folder it always goes back to check option after unticking it.
    mercoledì 3 aprile 2013 08:22
  • I have exactly this problem with a shared disk under Windows 10. attrib E:\Folder responds with just E:\Folder. attrib -s -r does not change anything, I am also unable to cd to the folder using the command line.

    martedì 22 marzo 2016 16:03