RemoteApp printing is pushing page through but no content

    Discussione generale

  • Hi Group,

    We are starting to use our custom application in RemoteApp. It needs to print address labels. We use a Dymo 400 label printer. But, really it should work for any label printer.

    The server is windows server 2008 R2. The clients are w7.

    Initially, the symptoms were that the page in the label printer would come out but no data/text would be on it. It would be blank. So the printer got the print command but did not get the data.

    We then took Wordpad and published it in RemoteApp. We typed on the page and printed to the label printer. Same thing, blank page came out. Then, went to print preview on wordpad. This took a few seconds. But once that was done, then, data started to show up on the label printer. We also changed a flag on the printer properties to only start printing when all the data was received.

    We then opened our custom application and tried to print an address label. It worked. We thought, great, its fixed.

    We then tried on our end-users computer. It is still printing blank pages from wordpad and our custom software.

    It seems like some kind of caching/timing issue with the data transmission to the printer. Does anyone have any advice on how to solve this issue?

    Thank you.

    giovedì 14 febbraio 2013 15:33

Tutte le risposte

  • Working with rd_bigdog...

    Settings we have adjusted in effort to rseolve the issue:

    In GPMC.MSC on the DC's Default GP we editted the following:
    Computer Config > Policies > Admin Templates > Windows Components > RDS > RDS Host > Printer Redirection:

    1. Do not allow client printer redirection - Disabled

    2. User Remote Desktop Easy Print printer driver first - Disabled

    The remainder is left as "Not configured".

    Used the following OS versions:

     * Windows 7 Ultimate N (X64)
     * Windows 7 Home (X64)


    No successful results.


    On Windows 8 Pro, the following has worked in order to print labels. This has proven not to work on Windows 7

    Adjusted the printer settings as per the following settings on Windows 8 Pro:

    1. deleted printer.config from c:\Users\username\My Documents\ProgramFolder\ on RDS Server

    2. Installed latest Dymo 64bit driver on the local windows 8 pc
      • in printer properties for the dymo on the local machine - selected Start printing after last page spooled & uncheked print spooled documents first and enable advanced printing features.

    3. Tested printing Locally from wordpad:
      • wrote 1234
      • file-->print-->selected Dymo and apply then closed

      • file-->print-->print preview-->print = OK

    4. Tested printing from Wordpad published app
      • wrote 5678
      • file-->print-->selected Dymo and apply then closed

      • file-->print-->print preview-->print = OK

    5. Tested printing from publised app
      • configured label printer
      • opened test accountt-->selected Dymo Label Writer 400 (redirected 9) = Printed OK

    6. closed published app. unplugged dymo printer, deleted printer and restarted local PC
    7. upon restart, reconnected to published app and printed lab label OK

    Does anyone out there have any further ideas...?

    giovedì 14 febbraio 2013 18:42
  • Hi,

    How are things going? I just want to check the status of the issue. If you have any update or concern, please feel free to let us know.

    Best Regards,


    If you have any feedback on our support, please click here

    Aiden Cao
    TechNet Community Support

    venerdì 22 febbraio 2013 02:55
  • Were you able to resolve this issue?  I have a brand new RDS deployment and we're facing the same issue when printing labels, the print job comes out but is blank.  When printing label from the software directly on the clients (not in an RDS session) the labels print out just fine.

    lunedì 23 dicembre 2013 04:35