Printer Redirection not working


  • Hello,
    I am trying to print through terminal services from a Windows XP with Serive Pack 3 intalled and .NET Framework 3.5 installed but there is not success
    the Printer is HP 1005 and it is working fine locally

    how can I get it to work?
    sabato 18 aprile 2009 11:21


  • Make sure server is Windows 2008 (also with .NET Framework 3.5) and that when connectiong the RDP client on "local resources" has printers checked. Try installing on both .NET Framework 3.5 SP1

    Best regards,
    lunedì 20 aprile 2009 11:44

Tutte le risposte

  • What is your server OS? Are you using legacy printer redirection or the new easy print feature which was introduced in Windows 2008?  In case of legacy printer redirection, it is required to have matching printer driver on both client and server machines


    lunedì 20 aprile 2009 03:00
  • Make sure server is Windows 2008 (also with .NET Framework 3.5) and that when connectiong the RDP client on "local resources" has printers checked. Try installing on both .NET Framework 3.5 SP1

    Best regards,
    lunedì 20 aprile 2009 11:44
  • Thank you Mauel Alves,

    I am so sorry for the late feedback I already have .NET Framework 3.5 (NOT SP1 -- Do I really have to install the service pack) installed on both the windows XP computer and the Windows 2008 server and I have the printer redirection checked in the Remote Desktop Connection and I even tried the webaccess but no luck yet.

    I have the following roles installed:

    Active Directory Domain Services - DNS Server - Network Policy and Access - Terminal services - Web Server

    Please inform me if there is any other information needed

    mercoledì 6 maggio 2009 11:08
  • If the Windows Server 2008 is also Domain Controller and if the print job shows on the server queue but disappears and does not get to the local computer and an "Access is denied" Error shows up on the system log you might need to "adjust" security permissions on C:\Windows\System32\spool

    Just change permissions on \windows\system32\spool and on all child objects
    Try giving "everyone full control" to check if it solves the problem. If that's the problem you might have to twick permissions on that directory tree.

    • Proposto come risposta TC10284 martedì 9 agosto 2011 00:05
    mercoledì 6 maggio 2009 11:13
  • The problem is I do not have any printers in the printers folder in the control panel so giving premisions to the spool folder does not make any sense because there is not printers intalled in the terminal services session
    mercoledì 6 maggio 2009 11:44
  • In Windows Server 2008 Terminal Services you never install printers on the server.

    If you can't see your local printers on the remote sesion check:

    1. Make sure the printer is working correctly on the client
    2. Make sure that RDP configuration on server is not disabling printer redirection
    3. Connect to the TS Server and check printers (RDP client on "local resources")
    4. Check on the remote session if printer shows in printers folder

    Check logs on both server and client... Sorry if it's of little help...
    mercoledì 6 maggio 2009 11:51
  • Thank you for your tips, I made sure that all the steps you mentioned are applied and I cecked the even viewer on both computers: On the Windows 2008 server all the events are about the TS starting, shutting down, or the Licence and the Windows XP computer I found nothing relivant what shall I do?
    mercoledì 6 maggio 2009 12:04
  • I have a feeling the problem is that somehow printing is disabled on the server

    1. Check that spooler service is running on the server
    2. Check the following server settings:
         a. Launch tsconfig.exe->RDP-Tcp properties->Windows printer (should be unchecked)
         b. Launch gpedit.msc->Admin templ.->Windows comp.->Terminal Serv.->Terminal Server->Printer Redirection (best if all are "Not configured")
    3. On the server check that "Terminal Services UserMode Port Redirector" service is running
    • Proposto come risposta mrTwister lunedì 28 maggio 2012 09:13
    mercoledì 6 maggio 2009 17:57
  • Hi - I have this exact issue with Windows 2008 Terminal Services. The printer redirection settings are enabled in the local policy, domain group policy, ts config on the rdp connection, etc. Doing a gpresult shows nothing disabled. The print spooler is running, as is the "Terminal Services UserMode Port Redirector".

    I am using several different Windows XP SP3 clients with both locally defined and Windows 2003 printer server based printers.

    Group Policy is set to only redirect the client default printer.

    I have 6 Windows 2008 Terminal Servers and printer redirection does not work on any of them. There is nothing in the event logs even mentioning ts printer redirection, either success or failure.

    Yes, the option to redirect printers is ticked for MSTSC.

    In Device Manager->System Devices, the Terminal Server Device Redirector is enabled.

    All Windows 2008 servers are Windows 2008 standard SP2 64-bit.

    I'm pulling my hair out now, can someone please offer some advice?

    mercoledì 8 luglio 2009 03:20
  • Dear Sir

    I am using Windows Server 2008 and atleast 15 terminal service connection users are working on that remotely. I am facing a problem on Print re-Direction. Many a times the "Terminal Services UserMode Port Re-Direction" is not working.  I use to get a complaint from the users that many a times the local printers which are connected to their macine is suddenly getting disapppeared or the printing is not happening.

    Whenever i get a calll on this, I try to re-start the "Terminal Services UserMode Port Redirection". That time that the service couldn't restart. It was taking some time and finally the status of the service is showing "Stopping". Then I have to restart the server and then the printers are avaialble to the clients normally.

    I have updated alll latest windows update on the sever.

    Can you please help me out or advise me to come of this issue.


    martedì 1 settembre 2009 05:09
  • I am having the same problem. I cannot get any Redirected Printers to show up on terminal server 2008 or 2008 R2.
    sabato 19 settembre 2009 01:48
  • Same problem on 2008 and 2008 R2.  Redirection only occurs on userids that are administrators.   Normal user ids don't redirect

    Opened up a problem with Microsoft, with no solution yet
    venerdì 23 ottobre 2009 17:01
  • This is a shot in the dark, but if your users don't have rights to create files in their temporary directories or %TEMP% variable doesn't exist, it might explain the problem you are seeing.

    In default environment Easy Print and printing redirection work, there's no question about it, thousands of people are using it every day. So if you can tell us more about how you setup your machine: changed user permissions, applied security templates, changed environment variables. Anything that affects the machine globally is helpful.

    Also, any suspicuos even entries especially from UmRdpService or spooler are definitely worth reporting.
    sabato 24 ottobre 2009 00:18
  • Same problem, so far my solution is restarting the server every night, but yet by the end of the day the server can't "catch" local printers/disk/resources.
    And the only reason i'm not tearing my hair is only because my bosses are up on this

    Something else, the server opens a new printer port for every user session (x number of users's printers).

    Is there any tool to clear all these printer ports, created by users without restarting the server?

    venerdì 6 novembre 2009 14:11
  • This morning I was pleasantly suprised by the server update with a function of unused printer ports clearing. Hope that this will solve the problem, will try to provide feedback in few days.

    Grr my bad, this update do not delete unused printer ports, it deletes jobs and printers from spooler, so I'm back on pulling my hair off...

    And I would like to repeat my question once again - Is there any way to delete unused printer ports - even manually?

    martedì 17 novembre 2009 09:16
  • Hi RumenGI, printer ports (TCP/IP ones) are stored under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Port\Ports. You could delete the unused ones from the registry and restart the print spooler. If you try this, please do it on a test system first as I have not tested the results.
    • Modificato Rob.Ford martedì 17 novembre 2009 19:04 Wrong path
    martedì 17 novembre 2009 19:01
  • Hi Rob.Ford, thank you for your reply, but the problem is that normally there are about 30 users on the server, so stopping or restarting the print spooler, while users are working (printing) does not sound like good idea.
    So more likely I am looking for solution like this:
    but compatible to windows 2008 server.

    Thank you again for the reply I will try to test it somehow.
    venerdì 20 novembre 2009 15:57
  • For my issue on this I found a solution linked from this thread here:

    We are a small outfit and our server is both our remote desktop server and a domain controller.  That appears to have been the issue.

    This article here fixed it for me.

    I sure hope this helps others.  If your server is also a domain controller, I bet that's what happened.
    giovedì 10 dicembre 2009 19:59
  • Here is my problem:  similar but not exact.  All the windows client's are having no problem with printer redirection.  It is with all the MAC OSX users.  The local printer does not appear in the printer selection list when trying to print.  I have turned on the use printer in the MAC RDC preferences.  Still no luck.

    Since it is all MAC users, it leads me to believe something on the server (Server 2008 R2 - Enterprise) is not set up correctly.  I am frustrated and cannot find a resoultion.  hopefully somebody on this thread might be able to help.




    Dale Peronteau

    giovedì 1 luglio 2010 18:24
  • Dale,


    I've been frustrated with this since EasyPrint came out.  The problem is that the Mac RDC client does not support EasyPrint as it makes use of .net technology.  CoRD, an RDC alternative also does not support it.  I've been looking for a work around for well over a year and have come up empty.  RDC is a great tool for Mac users and it disappoints me greatly that MS can't figure out a fix for this nagging issues.  I have to turn clients away because they are mac users and need to print through the server. 


    I've tried everything from setting GPOs to Third Party solutions and nothing has worked.

    giovedì 29 luglio 2010 06:45
  • HI Bakesale,

    That is odd as it was working on another Server 2008-R2 machine just fine.  It is just when I bought and installed my own 2008 server, I can't get it to work.

    And, I have another friend with both Mac OSX and a 2008 machine and they work fine on his machine except when he logs into my machine remotely, printer redirection isn't functioning.

    This leads me to believe I have a setting wrong. Its just nobody seems to be able to point me in a direction.

    Thanks for your input.  When I find the solution, I will post it here for everybody to see.  It shouldn't be this difficult.


    Dale Peronteau

    venerdì 30 luglio 2010 21:10
  • Dale,


    I have found a bit of a work around however it is rather finicky.  The trick is to download drivers for the HP Laser Jet 4350 PS.  copy them into your \windows\system32\driverstore\filerepository\


    install a new printer with the add printer wizard, point it to those drivers and map the printer to a TS printer port.  It has worked for all but one of my clients and I'm hoping that by upgrading his OS to 10.6 and his printer drivers as well it will be solved.

    venerdì 30 luglio 2010 21:14
  • I know this is an old thread but I figured I would post a possible solution for anyone that stumbles across it.

    I couldn't get printers to redirect on a new WS08R2 instance either until I installed the Remote Desktop Services Role.  After the restart, the printer redirected as expected.

    venerdì 27 gennaio 2012 02:29
  • anyone have a updated fix for this issue? I have anew 2008R2 RDP server deployed.. local printers are redirected for a day or two then disappear. only a server restart fixes the issue,.

    The server is not a DC

    grrrr. :(


    venerdì 10 febbraio 2012 15:39
  • This was exactly the problem.  After setting the permissions, it prints every time with the new easy print driver.  Kudos Manuel, many a forum buzzed before I found this solution.
    • Proposto come risposta licences venerdì 29 agosto 2014 22:19
    • Proposta come risposta annullata licences venerdì 29 agosto 2014 22:19
    giovedì 15 marzo 2012 21:16
  • Just change permissions on \windows\system32\spool and on all child objects
    Try giving "everyone full control" to check if it solves the problem. If that's the problem you might have to twick permissions on that directory tree. That Fixed it for me.
    martedì 3 luglio 2012 11:42
  • I agree with Juztone, i had the same issue and changed the permission.

    1. GPO - Allow printer redirection
    2. RDP Client - Allow local resources
    3. Change permission of the Spool directory in C:\Windows\System32\Spool -> Authenticated Users: Full control

    This worked for me. Good luck

    mercoledì 8 agosto 2012 09:43
  • this has helped me to resolve the issue..Thanks
    lunedì 29 ottobre 2012 13:05
  • I did not receive an access denied event, but updating the permissions did resolve this issue immediately for me.
    giovedì 6 dicembre 2012 18:05
  • I just had an issue with printing redirect and pulled a hotfix off this page.  Thanks Da Big R
    venerdì 28 dicembre 2012 21:48
  • While I found that all services were running, restarting the "Remote Desktop UserMode Port Redirector" corrected this issue for me.
    mercoledì 31 luglio 2013 17:19
  • Thank yo very much this fix my problem, issue started when we made a DC run TS for a small company, I have spent hours going through GP and no success, simply changing the permission on the Spool folder like you say cure the RDP printing issue, Thank you such.
    mercoledì 2 aprile 2014 14:08
  • Who could guess one day this useful piece of information helps someone in Iran. God bless you!

    lunedì 15 febbraio 2016 12:50
  • I have this problem as well but in my case just one printer M1132 Laser jet  is not working in any site ,but its working locally when they print ,but can not print from Terminal server applications even i added the drivers in all Terminal servers and 2 DCs , so what will be the solutions for troubleshooting this issue, i have also used the security policy for that and the Easy print is setup and configured.


    mercoledì 22 febbraio 2017 11:06