Add driver packages to boot image wizard: GUI Hang while 'mounting image' in WDS


  • Hi All,

    This is a fresh install of Server 2008 Datacenter Edition. DHCP is running on a different server, and my clients boot, that's no problem.

    The problem is: Using the GUI to insert drivers into boot/capture images. After right click > Add driver to boot image in the WDS MMC snap-in, this happens every time:
    1. The WDS MMC locks up solid; The only way out is to kill the process.
    2. According to resmon, the aforementioned mmc is stuck in a 'deadlock'.
    3. The mounted wim just sits there; it must be unmoutned manually by using command prompt using /dism /Unmount-Wim /MountDir:<dir> /discard  and then trying again, which inevitably leads us back to step 1.

    I've googled, and several people have had this problem, and the accepted workaround seems to be to take the image off-line, use the command prompt with dism, type long convoluted commands to insert drivers into the off-line image and re-add it to the WDS server. This is a process I am familiar with, however I'm in an environment where I need to add drivers to boot/capture images quite frequently, and taking the image off-line, typing a bunch of commands and putting it back each time is simply not an option, it's far too time consuming. Instead, I'd like to get this server role working as intended.

    I've had the same problem on two separate fresh installations with different driver packages. It worked for me ONCE where I was able to insert the drivers for an Intel gbE NIC into the boot image, but after that, every driver I've tried (including re-adding the Intel gbE driver which worked previously to 'clean' boot.wim) failed miserably with the same symptoms.

    Is there a fix for this somewhere? Or is this one of those "take it or leave it" situations?

    2011年4月16日 0:05


  • Hi,


    First let’s test the issue in Clean Boot


    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.


    Note: Please click Continue if the "User Account Control" window pops up.


    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.


    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".


    If the issue persists, you may re-initialize WDS:


    1.    Uninitialize WDS (wdsutil /unintialize-server)

    2.    Inititialize WDS (wdsutil /initialize-server /reminst:PATH)


    Tim Quan

    2011年4月18日 6:37