File opened in another folder cannot be renamed


  • I'm trying to rename a file that is on the domain network.

    No files are currently opened.

    This happens sometimes:
    1. Open windows explorer afresh
    2. Nagiviate to the folder is I want to rename that is on the server.
    3. Windows says a file is opened in another window and cannot rename.
    What's happening here?
    Sometimes waiting for like 15min then returning to rename the folder works.

    Is there a solution to this problem?

    I tried these:

    Method 1:

    When you have trouble in opening the file from the client computer, I would suggest you to open the file directly from Server computer and check if you get the same error there as well.


    Method 2:

    If you don’t receive the same error on server machine, then I would suggest you to place the client computer in clean boot state and then try to open the file.

    You can start Windows by using a minimal set of drivers and startup programs. This kind of startup is known as a "clean boot." A clean boot helps eliminate software conflicts.

    Note: After checking in clean boot, follow step: 3 from the article to reset the computer to normal boot.


    Method 3:

    Perform System File Check to fix the corrupted system files on client computer and then try to open the file.

    Note: It may ask for Windows DVD to fix and to enable SFC to make more than minor repairs. Some files saved on your computer might get deleted when fixing corrupted files.


    Can't try Method 1 as I don't to the Server computer.  However, from what I hear from our IT adminstrator, it is doing the same thing as well.
    Tried Method 2 ..But still happening.  No change.
    Method 3 seem to work for a while.  I'll see if it behaves.  ...nOPE!  only lasted for awhile. then the problem returns.
    Something I noticed, if I wait for a few minutes, I can then rename or move the file.

    terça-feira, 12 de fevereiro de 2013 21:18


  • Hi,

    If you do not have permission to access the server system, it may a little difficult to troubleshoot this issue. Sometimes though we closed a open file, the session is still existing for a while, which locked the file from edit. We could go to server system to check the session to see the exact cause. Also there is a tool named handler.exe which could help us check the result. See:

    Also it may be caused by programs such as scurity, backup program etc on server side.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact

    quinta-feira, 14 de fevereiro de 2013 09:09