Problem with 3TB raid1 in configuration in windows 2012 with HP proliant microserver N40L



    I have purchased HP Proliant microserver N40L with 2 Seagate 3TB HDD for RAID1 configuration. I configured RAID1 from the bios utility and installed Server 2012. After the 1st clean install, I went and checked my RAID drives and It surprised by when I saw two separate 3TB hard drives in the disk management, Disk-2 is allowing me to create a GPT parition and Disk-1 is completely unaccessible. Ideally, Windows should have now shown me two separate drives at all in the hardware RAID1 mode. I tried lot of fixes without success, I even tried windows 2012 Essential hoping it might fix the probelm

    I than install Windows 7 to check if it is my hardware, and to my surprise it worked, it showed me a one 3 TB drive and allowed me to create a one GPT parition of all full size, I copied some files and tested a fail safe scenario removing single hard drive and restarting and accessing those files.

    I have also checked this in WHS 2011 without any problem

    I now giving up, I don't understand why windows server 2012 has problem with my 3 TB disks. Windows 7 and WHS 2011 are older and I was thinking they would have problems with my 3 TB hard drives instead, they worked fine and Server 2012 is giving me a trouble, inpiste of being a new windows server OS

    Immediate help will be appreciated




    segunda-feira, 4 de fevereiro de 2013 19:48

Todas as Respostas

  • I'd get in touch with HP about operating system compatabilty / drivers for Windows Server 2012




    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    segunda-feira, 4 de fevereiro de 2013 20:25
  • when I saw two separate 3TB hard drives in the disk management, Disk-2 is allowing me to create a GPT parition and Disk-1 is completely unaccessible

    Can you send snapshot of diskmgmt to me? Are these disk visible in diskmgmt? At times I too have seen disks not getting visible in diskmgmt



    terça-feira, 5 de fevereiro de 2013 06:09
  • Thanks Satish and Patrick,

    As I mentioned, I gave up with Windows server 2012 because of this issue so I can't send you the snapshot of diskmgmt of server 2012.

    One thing I can tell you for sure is, 2012 was not taking Hardware RAID1 disks as 1 dist and disk-1 was failing over whatever I try to do (Initialize, create volume, convert to GP etc)

    Right now I have windows 7 installed on this machine and both the disks (1 disk) configured properly. Please find the attached screenshot. I have also tested fail safe scenario withing windows 7 successfully

    Please let me know if you really required the error screenshot, I will install server 2012 and send you the screen shot

    Unfortunately I am not able to attach an image here, it says your account must be veryfied though I am MSDN premium scubscriber. Please let me know how can I attach a screenshot here?

    terça-feira, 5 de fevereiro de 2013 15:16
  • Hi,

    You could upload your screenshot to skydrive. If the hardware RAID1 cannot be recognized correctly in Windows 2012, as Patrick mentioned, you could have a try to contact with hardware provider to see if there is any update (driver/firmware) needed.

    Here are the steps to upload a picture.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact

    quinta-feira, 7 de fevereiro de 2013 06:24
  • Thanks

    Now it is asking me email ids of you guys when I try to Share, I don't have share with everyone option.

    segunda-feira, 11 de fevereiro de 2013 21:11
  • Sharing with public should not be an issue. We already have multiple people shared their content. You can generate a link using right click on the item and it would give you further options,



    terça-feira, 12 de fevereiro de 2013 06:25
  • I give up now, I can't upload the screenshot there

    Do you really required error screenshot? Did anybody tried to recreate the issue?

    segunda-feira, 18 de fevereiro de 2013 16:12
  • I am having the same issue.

    I could create a funktional RAID in Windows Server 2012 with the AMD RaidXpert (2x4TB WD RAID Edition). But the configuration is not in sync with RAID Controller BIOS. As far as i have found out, the new Drivers do not "talk" with the RAID BIOS correctly. HP would ne to update the AMD RAID BIOS to a Minimum of Version 3.3.1540.11 (and Later).

    I hope HP will do this soon......

    sexta-feira, 12 de abril de 2013 07:17
  • Configuration: N40L, Windows 2012 Essentials, 1 hp 250GB, 2x4TB wd40efrx.

    I made using raid bios two logical drives:

     - ld1 - raid ready i am using the 250GB hd for OS

     - ld2 - raid 1 using the two 4tb disks.

    Using the drivers/software from windows 2008R2 : and i was able to obtain a functional raid configuration using RaidXpert.

    You need to install SB8xx_RAIDXpert.exe version 3.2.1540.10. Btw i experienced the same issue when i used RaidXpert version 3.3.1540.19.

    In the end windows is reporting correctly 1 disk for the raid1. 

    sábado, 19 de outubro de 2013 22:12
  • Sorry to resurrect such an old thread - had a similar issue happen recently with my Server 2012 R2 Essentials machine.  It's a custom build that's been upgraded from Windows Home Server, and when I was doing my weekly maintenance checks today, I noticed that the Raid 5 Storage Array had disappeared!  It's a RAID 5 array running on an AMD 2+1 controller (integrated into an ASUS F2A85-M Pro motherboard), using UEFI.

    "No Biggie," I thought - I've got backups.  But Windows Server Backup wouldn't run, even after rebooting the server and double checking the services - so I started digging a little deeper.  The AMD RaidXpert2 application saw the Array without a problem, but the Server OS still couldn't "see" it, even after removing and reinstalling the drivers. 

    I tried a couple "trial-ware" recovery programs from C-Net, but they couldn't pickup any data from the array, even though they could "see" it was there.  Finally, I found Rod Smith's GPT fdisk on his website at  Being primarily command line driven, I had to dust off my memories of basic and DOS, but managed to get it working without too much trouble (NOTE:  Before you run off and download, and start mucking about, READ THE INSTRUCTIONS AND README files!!  This tool is very powerful, and you can do irrevocable damage, if you aren't careful!!).

    A quick scan later showed that the GPT tables were corrupted, but that the information stored in the backup tables appeared to be good.  I restored the backup table, "wrote" the changes to disk, and before I could even exit the program, got the message from my AV software that it had initiated a scan on a recently connected disk.  Voila!  Data's back!

    Again, sorry for bringing Frankenstein back - but if this thread was still showing up when I searched today, hopefully this info will help someone out.



    sábado, 12 de setembro de 2015 06:06