Cant kill process on Windows Server 2008!! - Thread in Wait:Executive State


  • Hi there all,

    I hope someone can help me with our issue we are having. We have a major issue with a  process that we can not kill and the only way to get rid of the process is to reboot the machine.

    I have tried killing it from the normal task manager but no joy.

    I have tried killing it using the taskkill /F command from a command prompt and no joy. The command reports as sucessful but the process remains.

    I have tried to start task manager with system rights by calling "psexec -s -i -d taskmgr" and attempting to kill the process but no joy

    I have tried killing it from Process Explorer but again the process remains.

    Nothing I do will kill this process. Even logging off and logging back on will not kill this process.

    Using Process Explorer I notice that there is on stubborn thread that is in the Wait:Executive state.  I have tried to kill this thread using Process Explorer but again no joy.

    We are using Windows Server 2008 R2 64-Bit.  The server is brand new and windows is freshly installed.

    Now heres the thing. We have brought two identical servers from Dell with the same specs and the same OS installed and I can not replicate this issue on the other server. Only on this server, under certain circumstances does this server process hang and can not be restarted! 

    I have also changed the compatability mode by setting it the process to "Windows 2003" but this has not helped.

    I have noticed in Process Explorer that DEP is turned on but im not sure this has got any bearing on the issue ot not.

    Please, can someone help??

    15 สิงหาคม 2554 9:19