none
How do I remove the "Automatic Browser Configuration" from a GPO?

    Soru

  • Hi - in our company, we use Default Domain Policy (DDP) for a selection of settings (as expected).  I have started using a proxy, and since I want this setting to only affect certain users, I have created a new GPO and defined the Proxy settings within.  However, these settings are not being applied to any of my users.  

    After doing a GP wizard, it turns out the the DDP is winning, and overrides this setting.  But the only thing that is enabled in the DDP is the "Automatic Browser Configuration".  This setting is simply two tick boxes, both of which are unticked.   I want to disable this from the DDP, but no matter what I do, and cannot stop the DDP from controlling this option.

    Is this normal beahviour?   What am I missing?

    Many thanks


    • Düzenleyen Loin75 08 Mart 2013 Cuma 11:37
    08 Mart 2013 Cuma 11:24

Yanıtlar

Tüm Yanıtlar

  • Hi,

    How are you trying to apply the Proxy settings on the client? IE maintenance or GPP?

    As you may know, there are several ways to set proxy settings on a client.

    1. WPAD (Web Proxy Auto Discovery protocol http://en.wikipedia.org/wiki/Web_Proxy_Autodiscovery_Protocol) - it actually uses the Automatic browser configuration checkbox on your client and looks for the file wpad.dat on a specific web server that you Point out with either dns-record or DHCP option 252.

    2. Auto configuration script (pac script http://en.wikipedia.org/wiki/Proxy_auto-config) - uses the same kind of file as above. The difference is that you get the possiblity, like you want in your scenario to target what users that should get the script.

    3. Manual configuration, like the one you are trying to roll out with group policy now.

    What setting in your Default Domain Policy are setting "Automatic Browser Configuration" box checked? If you look in to settings in default domain policy, can you find anything  the following:

    User Configuration\Policies\Windows Settings\Internet Explorer Maintenance\Connection\Automatic browser configuration

    Try to remove all settings from the Default domain policy and apply new settings preferably via GPP .

     After you found the conflicting setting, I suggest you take a look in to pac scripts instead of setting the proxy manually in the browser. Otherwise, your users will have learn checking and unchecking the proxy when they get in and out from your network.

    Hope this helps you out.


    MCT | MCSE: Private Cloud/Server, Desktop Infrastructure





    09 Mart 2013 Cumartesi 14:46
  • Hi,

    Please also check this threads:

    Cannot Remove  IE Maintanence settings from group policy

    http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/4caa4c91-5cce-49bd-8e92-db04fbdbfa07/

    How to config proxy settings using group policy management

    http://techlib.barracuda.com/display/WSFLEXv41/How+to+Configure+Proxy+Settings+Using+Group+Policy+Management

    Hope it helps!

    Regards.


    Vivian Wang
    TechNet Community Support

    11 Mart 2013 Pazartesi 07:40
    Moderatör
  • Thanks for the replies.

    The article did the trick perfectly.  I was able to right-click on IE Maintenance (within the Default Domain Policy) and "Reset Browser Settings".  This allowed my other GPO to do it's job.

    Many thanks

    14 Mart 2013 Perşembe 15:47