none
Handful of Public Folders not replicating

    问题

  • I've got a small handful of subfolders that are not replicating between the two Public Folder databases. I've increased logging but so far no errors stand out. The server that is missing the data does appear to not be generating any "Event 3030: Replication Incoming Messages" and only has "Event 3020: Replication Outgoing Messages". I've attempted to Update Content and Update Hierarchy with no success.

    In addition, on the server that DOES have all the folders, I am unable to launch ExFolders. It gives an error: "An error occurred while trying to establish a connection to the Exchange server. Exception: Cannot open mailbox." I have already checked ADSIedit for an old CN=Server container but it is not present.

    The server that is missing data runs ExFolders just fine, connecting to both public folders databases.

    Edit: At least some of the folders that are failing to replicate are mail enabled and are experiencing additional problems receiving incoming mail.

    2018年7月12日 23:05

全部回复

  • Hi AKDWilliamson,

     

    How many Exchange servers do you have? They are all Exchange 2010 servers? Did you migrated from Exchange 2003 server?

     

    For the server that DOES have all the folders, please open ADSIedit and navigate to CN=Configuration,DC=,DC=,/Services/Microsoft Exchange//Administrative Groups/Exchange Administrative Group (FYDIBOHF23SPDLT)//Servers/MBXServerWithIssue

     

    Right-click Microsoft System Attendant, and then click Properties to display the  Attributes list and find the homeMDB attribute, check if it points to a valid mailbox database:

     


     

     

    Test the following guide if it will help:

     

    Troubleshoot public folder replication for Exchange Server

    https://support.microsoft.com/en-ca/help/10042/troubleshoot-public-folder-replication-for-exchange-server

    Regards,

    Gavin Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    2018年7月13日 6:01
  • There are a total of eight exclusively Exchange 2010 servers; four mailbox configured in a DAG, three cas/hub, one journal mailbox. I'm not certain if the system was migrated from Exchange 2003 to Exchange 2010 or if Exchange 2007 was an intermediary step as it happened before I came on board.

    Checked the homeMDB: it has a valid database though only one of the three mailbox databases and not the public folder database.

    I will work through that troubleshooting guide and report results.

    2018年7月14日 1:05
  • Hi AKDWilliamson,

     

    Thanks for your feedback, if there is any update, please feel free to let me know, I am looking forward to your reply.

    Regards,

    Gavin Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    2018年7月16日 7:44