none
exchange 2016 访问遇问题 RRS feed

  • 问题

  • 各位 你好

    1.今天安装了CA证书后重启邮件服务器就无法登陆网页版管理界面如图。

    2.查看日志信息错误ID为74及ID8198.

    2.查看exchange服务全部都没运行如题。


    2020年3月5日 9:23

答案

  • 您好,

    您复制的命令有误,前几位应为:

    Windows Registry Editor Version 5.00

    在查到的类似问题里,虚拟机、windows更新DNS错误、硬盘空间不足、防火墙、框架损坏禁用IPv6 等都可能是导致Exchange相关服务无法自动启动。

    请注意:由于该网站不是Microsoft托管的,因此链接可能会更改,恕不另行通知。 Microsoft不保证此信息的准确性。

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.


    2020年3月18日 9:01

全部回复

  • 您好,

    请问该证书目前的状态是什么?您为该证书分配了什么服务?您可以运行以下命令来查看:

    Get-ExchangeCertificate | Format-List FriendlyName,Subject,Services

    另外,您是可以打开ECP但无法登录成功,对吗?似乎没有看到您无法登录ECP的报错截图,麻烦您重新上传。

    请打开IIS Manager按下图检查Default Web Site和Exchange Backend,是否将正确的证书分配给了端口:

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年3月6日 2:59
  • 您好

    1.可以正常登陆上ECP输入完密码后进入woa界面报错。

    2.把Ex和AD两台服务器重启,发现Ex服务器内的Exchang服务都没有运行,请问这是什么情况?

    3.当初证书导入Exchange后重新打开页面还是警报才进行服务器地重启,重启后页面就报错。

    4.查看了端口位置证书还是采用microsoft exchange证书没有采用我的新证书,是否可以断定我的证书没有导入试用?

    2020年3月6日 3:18
  • 您好,

    请问刚刚我提供的命令运行了吗?方便的话,希望您能将结果截图。

    我想先知道此证书是否已被成功导入/安装,如果状态为invalid,则可能导入失败了,您可以参考此文章重新导入证书。

    以我的经验,即使导入成功,端口上的证书也是需要手动更改的。在端口上您可以找到您新安装的证书的选项吗?

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年3月6日 7:30
  • 您好,

    1.下午查看证书运行命令如图。

    2.每次我重启Ex服务器后查看相关服务均没运行打开wao页面登录就会出现我的提及的报错,当我手动运行Ex服务,Ex各项功能皆正常,请问这是原因导致的?我应该从哪方面进行排查错误?

    • 已标记为答案 ang789 2020年3月10日 6:08
    • 取消答案标记 ang789 2020年3月10日 6:08
    2020年3月9日 12:17
  • 您好,

    十分抱歉之前忘记在命令中加入status了,希望您重新运行下以下命令:

    Get-ExchangeCertificate | Format-List FriendlyName,Subject,Services,status

    您之前查看过端口,请问SSL证书一栏上是否能找到您安装的证书?

    关于您说的exchange服务没有自动运行,建议您重启DC和Exchange服务器里的Microsoft Exchange AD服务后,再重启Exchange服务器,如果仍有此问题并前往Event Log查看是否有相关错误被记录于Windows Logs-Application栏或者System栏中,比如EventID 2604。

    如果想快速解决这个问题,您可以将相关服务设定为延迟启动,具体方法为:

    1. 开始>Administrative Tools > Services.

    2. 选择一个服务,右键属性, 改为第一项

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.


    2020年3月10日 9:03
  • 您好

    1.端口443的绑定都是新建的证书。

    2.Ex服务器重启后报错ID如图,请问这个报错是如何引起?我不怎么会看

    3.按你方法进行服务延迟启可以但是错误不清楚如何引起的,以后Ex服务器可能存在有其他的问题。

    4.关于Ex服务器重启后不会自动运行,我重装过几遍了过程无报错,都每次装完都会出现这个问题。

    2020年3月11日 6:46
  • 您好,

    请检查此服务是否是running状态,还是您说的需要手动启动,手动启动后是否还会收到Event 4027?或者您可以尝试只将此服务设置为延迟启动,测试是否能正常使用Exchange。

    您提供的两个报错很可能都是因为该服务没有启动引起的,总体来看您的最大问题依旧是重启服务器后不能自动启动Exchange相关服务,根据您之前说的“当我手动运行Ex服务,Ex各项功能皆正常”,我认为只要解决了Exchange AD Topology服务不能自启动的问题,本帖里所有提到的报错/无法登录都会解决。

    如果您赞同以上观点,可以根据以下问题进行排查:

    1.网络条件是否良好?能否顺利Ping DC?(是否将Exchange安装在DC/GC上?)是否有使用三方软件?

    2.此Exchange服务器是虚拟机吗? 为其分配了多少内存?

    3.再去EventLog中查找是否有与Exchange AD Topology有关的错误,或者您可以多上传截图。


    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年3月11日 9:16
  • 您好

    1.手动情况下没看见到4027错误,延迟启动是可以正常使用Exchange。

    2.有一点我可能说的不是很清晰,重启后Ex全部的服务不会自动运行,手动运行Exchange AD Topology服务可以进入ECP界面(输入账面密码页面)输入密码后进入WAO页面报错代码HTTP500,我需要手动启动关于Exchange全部的服务才可以正常运行(我也不清楚开启Ex哪些服务才能正常运行,就全部开了)。

    3.不单止Exchange AD Topology不会启动,其他服务都是这个样子哦。

    4.Ex为虚拟机分配内存为10G硬盘200G无装其他软件就安装Exchange,Ex与Ad通信正常。

    2020年3月12日 1:43
  • 您好,

    您可以尝试以下命令是否能一次启动所有的相关服务:
    Get-Service | Where-Object { $_.DisplayName –like “Microsoft Exchange *” } | Start-Service

    请问您的DC最近有发现问题吗?是否很长时间没有开启过了?

    在类似的帖子中看到原因可能是IIS或者.NET框架损坏,工程师推荐的处理方式是重新部署。

    另外,我注意到您环境里有EVENT ID 3025/3018,建议您按照以下步骤修改注册表:

    1.打开记事本,复制以下内容:

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
    "SystemDefaultTlsVersions"=dword:00000001
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]
    "SystemDefaultTlsVersions"=dword:00000001

    2.将文件保存为NET4X-UseSchannelDefaults.reg

    3.双击该文件,点击是

    4.重启服务器使其生效

    参考链接:

    https://techcommunity.microsoft.com/t5/exchange-team-blog/exchange-server-tls-guidance-part-2-enabling-tls-1-2-and/ba-p/607761

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.



    2020年3月17日 8:37
  • 您好

    1.使用命令可以一次性启动服务(如图),都重启后服务依旧不能自动。

    2.关于重新部署,已经部署过两次服务依旧都是不能自启。

    3.IIS或者.NET框架损坏,安装完Exchange重启后查看服务,都是显示不在运行状态。安装过程无提示报错等情况。

    4.这种情况遇到多嘛?我查论坛都没相关帖子。

    5.注册码提示错误如图。

    2020年3月18日 2:15
  • 您好,

    您复制的命令有误,前几位应为:

    Windows Registry Editor Version 5.00

    在查到的类似问题里,虚拟机、windows更新DNS错误、硬盘空间不足、防火墙、框架损坏禁用IPv6 等都可能是导致Exchange相关服务无法自动启动。

    请注意:由于该网站不是Microsoft托管的,因此链接可能会更改,恕不另行通知。 Microsoft不保证此信息的准确性。

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.


    2020年3月18日 9:01
  • 您好

    换上物理机安装应该能解决问题,谢谢一直的协助!

    2020年3月23日 7:23
  • 您好,

    感谢你的反馈,如果仍有相同问题欢迎继续来论坛提问,我会请教更多工程师帮助排查该问题。

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年3月23日 7:28