locked
"You don't have permission to save in this location" RRS feed

  • 问题

  • I believe I have set myself as administrator.  Administrator appears beneath my name at sign on.  I skipped creating a password as I am the only user. When downloading a file for my canon scaner I got the message "C:\Program Files (x86)\Canon\Cannon Download\tb4135_en.exe.  You don't have permission to save in this location.  Contact the administrator to obtain permission.  Would you like to save in the ..........folder instead? "  I have tried selecting other directories but get the same result.  I successfully downloaded Another program from Canon only minutes before.  How can I instal this file/programe?  Without it my scanner is useless.
    I realise that it is not good sense to run permanently as administrator.  Can I set up a separate administrator sign in once I have set up all the programs I lost when installing Win7
    2009年10月31日 15:23

答案

  • Hi,

     

    You may try the following suggestions one by one to check the issue.

     

    Suggestion 1: Temporarily disable antivirus program.

     

    Suggestion 2: Click Start, All Programs, right click Internet Explorer and click Run as administrator.

     

    Suggestion 3: Click Start, type inetcpl.cpl into Search box and press Enter. Switch to Security tab, uncheck “Enable Protected Mode (requires restarting Internet Explorer)” and click OK.

     

    Suggestion 4: Click the Start Button, type "User account control" and press Enter. When the User account control settings box appears, move the slider to Never notify and click OK.

     

    What’s the result?

     

     


    Arthur Li - MSFT
    2009年11月2日 5:28

全部回复

  • Hi

    If this is simply an update for the Canon driver/software, the easiest solution is to download the file to the Desktop. Right click the file and select the Run As Administrator option to install.

    Some tips.

    You should always assign a password to all Administrator accounts, even though you are the only user. This helps when a malicious file tries to gain access to the system and is also necessary for all of the built-in security components to work properly.

    Remember, in Windows 7, all Administrator accounts operate as normal user accounts unless you explicitly 'elevate' a function by using the run as administrator option or approve the UAC prompt when it pops up.  

    Hope this helps.

    Thank You for using Windows 7

    Ronnie Vernon MVP

    2009年10月31日 18:45
  • ...the easiest solution is to download the file to the Desktop....

    Although correct, I do not believe this i the best advice or practice.  Downloaded files saved to 'Desktop' are messy/unsightly/cumbersome.  It is best practice to use the 'Downloads' folder which is located within the user account folder, and for which an entry is present on the Start Menu.  this is the system 'default' save location for downloads.

    All downloaded files can be safely and conveniently stored there.  Sub-folders can be created and used for help with organising and retrieving.  If downloaded files are program patches or updates they can be launched from there, and will find the program install folder to patch successfully.


    If downloads have been stored elsewhere on the system already the user may not be currently getting prompted to store files in the default 'Downloads' folder.  This is easy to correct.  When the next download is conducted, when prompted for a save location browse to:

    System drive -> Users folder -> User account folder -> Downloads.

    Afterwards, the system will prompt with the correct download folder, for subsequent downloads.



    Cheers
    2009年10月31日 22:06
  • Hi,

     

    You may try the following suggestions one by one to check the issue.

     

    Suggestion 1: Temporarily disable antivirus program.

     

    Suggestion 2: Click Start, All Programs, right click Internet Explorer and click Run as administrator.

     

    Suggestion 3: Click Start, type inetcpl.cpl into Search box and press Enter. Switch to Security tab, uncheck “Enable Protected Mode (requires restarting Internet Explorer)” and click OK.

     

    Suggestion 4: Click the Start Button, type "User account control" and press Enter. When the User account control settings box appears, move the slider to Never notify and click OK.

     

    What’s the result?

     

     


    Arthur Li - MSFT
    2009年11月2日 5:28
  • I figured out the solution to this problem in Windows 7. I assume this will work with other OS too.
    1.  Right-click on the drive that is causing the problem.
    2.  Left-click on Properties.
    3.  Click on the Security tab.
    4.  In the first window click on Administrators (your computer name-PC Administrators).
    5.  Just below the window click on Edit.
    6.  Click on Administrators (your computer name-PC Administrators) again.
    7.  Here's the key to making it work. If Apply is grayed-out, check a box in the Deny column. It will then bring up Apply.
     
    8.  Check a box in the Allow column. It should check all of the boxes except the last one and uncheck all of the boxes in the Deny column.
    9.  Click Apply. It should run a scan of the files in the drive. When the scan is finished, click Ok. The first box should still be open.
    10. In the first window, click on Users (your computer name-PC\Users) and repeat steps 5-9, of course clicking on Users (your computer name-PC\Users)
    instead of Administrators (your computer name-PC Administrators).
    NOTE:  You may not have to click in the Deny column after the first scan is completed for step 10 as indicated in step 7.


    • 已建议为答案 DotCav 2011年5月31日 8:27
    2011年5月31日 8:22
  • Thanks DotCav, worked for me saving PDF995 files on my new Win 7 box (previously got "You don't have permission to save in this location" etc errors at the File Save As dialog box).

    Regards

    2011年6月1日 2:45
  • Thanks DotCav, worked for me. I was having problems printing/saving .xps files from Internet Explorer. I could print/save .xps files from other applications, but not ie. This fixed it.
    2011年7月23日 15:28
  • Hey DotCav

    I've done exactly what you said and I get an error shortly after the scan begins that says

     

    An Error occured while applying security information to:

    D:\System Volume Information

    Access is denied.

     

    D:\ is a partition on my hard drive I made to store all my documents, etc.  It worked fine for awhile but has recently denied me access.  I think it might have something to do with sharing D:\ in my homegroup.  I shared it a few days before I found this problem.  I've stopped sharing the drive to try an fix the issue but I keep getting this error.

     

    Any ideas?

    2011年8月3日 23:22
  • Sorry I took so long to reply. I didn't get a notification stating someone replied to this thread. I just happened to come back to check and see if anyone replied to this thread. 

    I'm kind of stumped on that one for the moment. If I think on it for a while I might be able to figure it out. For now, the only thing I can suggest is to do a System Restore to a point before you started the sharing. 

    2011年8月26日 19:51
  • I can't change my host file either. I did all the changes listed above, as described, but when it was running the scan there are several that came up, including C:\Windows, that it says is denied!!!

    What is going on with this WIN 7....I need to change the host file and can't....no matter what I do it seems access is denied.

     

    What esle could it be ??

    2011年8月31日 20:59
  • If I'm not mistaken, a host file has to do with the OS and IP address names. The method I posted is a solution I figured out for an issue I had where my external hard drive was being denied access when I first plugged it into my new Windows 7 computer that had no problems when plugged into my XP one.
    So, I'm not sure that this method can work for an issue with a host file as I haven't come across that.

    • 已编辑 DotCav 2011年9月12日 22:24
    2011年9月12日 22:24
  • Hi!

    I just created a profile here just so that I could respond to this and hopefully provide the solution you are looking for.

    I've come across this lil hiccup a couple of times out of the blue, and it always takes me a minute to remember the solution.  Each time, I forget it's for the exact same simple rediculous technical reason. 

    What happens is I'll be trying to upload a photo or attach one to an email.  As I'm viewing the preview thumbnails to select for attachment, I'll think to myself "hmm its a lil too large, let me resize it first".  And since I can already see the thumbnail image in the attachment windows, I just went ahead and right clicked "open with" my image editor,  rather than closing that whole attachment/upload process, and accessing the image via libraries>pictures (Win 7) BEFORE clicking the item/photo in the image viewer to view the photo in full view right clicking "open with". 

     It's a really rediculous technical glitch, but thats where the issue lies. 

    So next time, try "open with" on the full view of the actual item or image you are working with instead "open with" on the thumbnail, and see if that resolves your issue with being able to save your work after.

    I hope this helps :)



    2011年12月4日 8:14
  • I figured out the solution to this problem in Windows 7. I assume this will work with other OS too.
    .... ....
    7.  Here's the key to making it work. If Apply is grayed-out, check a box in the Deny column. It will then bring up Apply.
     
    ... ...

    No, sorry, no "Apply" button at all, not grey, not black, not there. Any other ideas???? Oh, wait... You mean in the second window (My god, MS is mad about window over window over window). OK, added a check, removed it, clicked Apply, got "Access is denied". That seems to say You can't change your administrator permissions because you are not alllowed to change your permissions. Reminds me of my parents: "Why? Because I said so!"
    • 已编辑 Lance666 2012年1月23日 10:18
    2012年1月23日 10:13
  • Here's how I edit the C:\Windows\System32\drivers\etc\hosts file.

    It gave "You don't have permission to save in this location.." but I solved it in this way:

    1. Right click on the file. In my case, "hosts"

    2. Select Properties -> Security.

    3. Click "Edit" to change permissions. If you only find: 

    • System
    • Administrators (yourComputerName\Administrators)
    • Users(yourComputerName\Users)

    You need to click "Add..", where you "Enter the object names to select": 

    • userName (Simply the name you see when you login to Win7)

    Click OK.

    4. Return back to the list. Now you will see:

    • System
    • userName(yourComputerName\userName)
    • Administrators (yourComputerName\Administrators)
    • Users(yourComputerName\Users)

    Select userName(yourCompusterName\userName from the above list, and then

    Change the "Permissions for userName": 

    • Read & Execute (Allow)
    • Read (Allow)
    • Write (Allow)

    Make sure you have the above allowed. Click OK.

    5. Click OK and close the properties for the file.

    Now you can edit the file!



    2012年2月9日 9:34
  • Didn't you know? In order to create a market Windows is available to any dummy who can muster up the cash to buy it.

    Renee


    "MODERN PROGRAMMING is deficient in elementary ways BECAUSE of problems INTRODUCED by MODERN PROGRAMMING." Me

    2012年2月10日 7:11
  • If you are logged in to administrator account, you can try disabling the UAC in the computer to resolve the issue. This one worked for me. No need to disable antivirus application and windows firewall.

     
    • 已编辑 Jibendu 2012年3月24日 21:54
    2012年3月24日 21:51
  • This is an annoying problem that seems to come from a change in the windows 7 OS settings. On a PC I bought last year, I had no problem, but on a new one I cannot save where I want with the message "you dont have pemission to save to this folder" etc. Its a real simple solution. You think you have administrator rights but you  dont, even if it says administraor on your user account. Run whichever programme you are using as an administrator by right clicking and choosing "run as administrator". So if you are downloading to a folder where you cannot save to then right click Internet explorer, or whatever browser you use, and run as admin then save etc.
    2012年4月21日 16:55
  • DotCav's solution is right on the money. The writer obviously understands the problem behind the error message and therefore offers a real solution. If I had spent another couple of hours (or days) reading Windows 7 Inside Out, I might have arrived at the solution for myself, but I certainly prefer to act on someone else's having got there (in effect) first. Taking the long way--reading the book--is enlightening in general, but it also supplies a lot of information for which one will never have any use and wastes finite space in the head that is needed for other uses.
    • 已编辑 kinderwe 2012年7月9日 15:13
    2012年7月9日 15:11
  • Had the same issue on Win 8 RC 9200. Trying to edit the hosts file - even though I am in the Administrators group which has full access to the file, I was denied on the save write operation. I edited the permission and explicitly set my user account to full read and write and I was able to save. Looks like a possible bug?
    2012年9月13日 0:00
  • Thanks Arthur_Li

    I tryed two and four and it worked you are very gook I didt have to reinvernt the wheel. I am just getting started with Windows 7 Home and IE9 and the learning ccurve is a lot harder than others I used

    Thanks rod 

    2012年9月29日 18:18
  • Hi: Athur_Li

    I tryed your fixx for permission  two and four and it worked great. I am useing a peogram called doPDF 7. Iused it in Win XP and IE8. I changed over to windows 7 and IE9 whitch I am sorry I did. I waited this long to make the switch. The problem I am having noe is the file wont save to the folder? 

    Thanks for your help rod 

    • 已建议为答案 rodlll 2012年9月30日 14:31
    2012年9月30日 14:30
  • Greetings.  I have been having this same problem on an ASUS ee121 Tablet since I bought it.  It is the one computer I have that has almost no hard drive space left and I am desperate to be able to save files on my server computer.  Thanks to this thread, I discovered that I am set up as administrator OK, but still have very limited rights and am unable to change the settings.  When I get into Permissions for explorer and click on Administrator, I only have "Read % execute" and "Read"  and can't check any other boxes--grayed out...  This may not be my proeblem, but all my other computers give me all kinds of control like some of the folks have talked about on this forum....and the other wierd thing is that I can save files from the tablet to any other shared drive in my system except for the Server.  I recently upgraded (?) to Win8 and nothing changed.  Any hel would be appreciated!!
    2012年11月13日 0:33
  • Dotcav, i tried your solution and it didn't work, I then tried raejean99's and thankyou muchly it worked! my issue was that I couldnt save changed file settings in CFF Explorer, and now i can :) thankyou everyone who posted for trying to help, much appreciated!
    2012年11月27日 0:56
  • Man you are awsemone..thanks!!!
    2012年12月16日 23:51
  • This solution worked out for me.

    Thank You

    2013年11月28日 14:07
  • None of the solutions on this page worked for my issue but I did come up with a solution. 

    My problem began after installing Windows on a new hard drive. I keep most of my files on a second hard drive for ease of use when the OS goes goofy or hard disk fails. I could save to most folders on this preexisting hard drive I call E:/, but one if particular would not allow me to do so even after the suggestions in this thread.

    I was able to save the files I needed to where I desired without issue when and if I ran the program to begin with selecting it directly from the Start Menu and choosing Run as Administrator. While that works, it's frustrating. It slows down computing. I tried all the permissions suggestions as well as adding a fresh username and allowing all permissions afterward.

    My solution, we'll call the problem folder E:/DOCUMENTS-1 for ease.

    Go to E:/

    Create a new folder called DOCUMENTS-2

    Go into folder DOCUMENTS-1, press ctrl+a to select all, press ctrl+c to copy all files

    Go back to E:/

    Go into newly created folder, DOCUMENTS-2

    Press ctrl+v to paste all the files over. Should be very quick if they're on the same drive.

    Attempt creating a new file with Word or Paint, etc and saving into DOCUMENTS-2, if it works you're golden.

    Delete previous problem folder DOCUMENTS-1 and then proceed to rename the new folder whatever it is you actually wanted to it be called. 

    Seems asinine for the system to not allow you to save a file to a folder but then ALLOW you to copy everything and the delete everything. Goofy to have to do this but I can save, read, write etc within all my folders.

    Hope this helps somebody

     

    • 已建议为答案 Alan Hope 2016年9月14日 8:38
    2014年3月2日 20:37
  • Thank you Datcav.  The solution provided worked for me in Win8 also.  Thank you very very much.

    2014年5月5日 4:26
  • Hi,

     

    You may try the following suggestions one by one to check the issue.

     

    Suggestion 1: Temporarily disable antivirus program.

     

    Suggestion 2: Click Start, All Programs, right click Internet Explorer and click Run as administrator.

     

    Suggestion 3: Click Start, type inetcpl.cpl into Search box and press Enter. Switch to Security tab, uncheck “Enable Protected Mode (requires restarting Internet Explorer)” and click OK.

     

    Suggestion 4: Click the Start Button, type "User account control" and press Enter. When the User account control settings box appears, move the slider to Never notify and click OK.

     

    What’s the result?

     

     


    Arthur Li - MSFT


    2014年11月2日 16:12
  • Thank you this worked for me I am using Windows 8. 
    2015年1月17日 16:42
  • Hi, I seem to be having this problem on windows 7. I get it when saving anywhere other than my documents, even in folders I have created (eg C:/editing files) I have tried the recommendations to set the security permissions but I just get access is denied. I am using the only account on my computer as admin.
    2015年4月7日 22:57
  • Windows has a little vulnerability that you can use to successfully put a file in the C: drive. First, save it to the documents folder, then once it has downloaded, drag and drop the application/folder/file into the C: drive in file explorer. I do realize this answer is a bit late, but I post it anyway for users who come here to day with the same problem I just had.
    2015年5月24日 23:22
  • I had this problem and tried everything and finally fixed it after my Surface pro 3 started having the same issue and I remembered just prior to the problem starting on my SP3, a home group app appeared on my desktop and I never put it there. it removed itself from desktop shortly after so I searched for the message (you need administrative permission to save in this location) and included the words 'home group'.

    Long story short, I stopped home group file sharing and in the property tab, I returned file locations to default. It worked. After months of searching, I am finally able to save in any location I choose. The fix was instant and didn't even require a reboot.

    The reason it asks for administrative permission to save in any location even though you are on the administrative account is because even though you are logged in as administrator, the user file is actually just a standard account with an administrative title which is why the computer identifies you as a standard user account. It sounds crazy but it isn't good to open the true administrator user file. It is for your own protection that it is done this way.

     I am so glad to finally have a fix that doesn't involve lowering security or messing up user and registry files.

    Good Luck and please post if you have success.


    • 已编辑 camatz 2015年5月31日 1:42
    2015年5月31日 1:36
  • Sure. All files should be saved on the desktop. No wonder Windows is on the way out.
    2015年7月8日 9:02
  • Didn't work for me.
    2015年7月8日 9:09
  • my OK vote is wrong.

    i expected something to deceide between OK <--> Not working

    It does not work on my PCs!

    2015年7月27日 15:11
  • Hey justinwacker

    Thank you. I have been struggling with this and reading up on forums all day. I've just installed Windows X and everything went nuts and I couldn't save anywhere. This has just sorted it out.


    2015年7月31日 14:32
  • You're the man (woman) raejean99! Your solution worked just beautiful for me. Cheers!
    2015年8月6日 20:21
  • Thanks for this suggestion.  Sounds reasonable.  Unfortunately, in newly downloaded Windows 10, it didn't work.  I got to step 8 and could not check any box in "Allow" column.  When trying to proceed by clicking Apply (it did come up when I checked a box in Deny column), I got the same aggravating "donk" sound and something about permissions.  So, I quit.

    Curiously, all of these "permission" or "no access" problems are on "My XXXX" folders.  My Documents, My Pictures, etc.  In the Windows Explorer tree, I also see "Documents" and "Pictures" folders.  Fortunately, both of these open, and I can access all of my files.  Its just the "My XXX" folders that have that disgusting sound and security notice.

    In further reading, I keep running into something about a .dll file being corrupted.  Then, I get messages about fixing it in the registry, which I really an not qualified to do.  I also get solicitations from strange sources to "use this program to fix it rather than spend hours trying to fix it yourself".  I stay away from these solicitations, as I suspect they are malicious and only want to put something evil in my registry.

    But, I digress.  Any further suggestions to fix this security problem would be much appreciated.

    2015年8月15日 12:50
  • One other thought.  This is why many people migrate to Mac.  Since I have iPhone and iPad, I am also considering this, although I've been a faithful and mostly happy user of PC for decades.

    Too bad Microsoft can't seem to get this right.

    Working between PC and my iPhone/iPad for storage, etc., is not always a successful experience.  For whatever reason, they DO NOT play well together ...... guess its because they are competitors.  Sadly, its just the user community that suffers from this sour relationship (PC v. Mac).

    2015年8月15日 13:10
  • I apologize if I repeat instructions already posted but I had this problem for months and tried everything, some of which was scary because I am no genius with computers.  I finally went on a limb with my own instincts thinking it was related to home group settings and indeed in my case it was. All I had to do was stop sharing files. Problem solved. I still can't believe it went on as long as it did and was something as simple as home group share settings but I do hope this post spares others of the months of headache I went through trying to figure it out.
    2015年9月5日 3:03
  • Does this procedure work with Google Chrome?    I am going nuts over this problem of not being able to print PDF files after they are scanned.  Access Denied...Same story I am adminstrator,, etc.  Can I run through these procedures with Chrome since I don't use Internet Explorer?

    Thanks for any help you can throw my way.  I am going nuts fighting this...Windows 10 Chrome

    2016年1月14日 1:27
  • Thanks Arthur Li your suggestion 1 put me on the right track. 

    My screenshot program (Greenshot) was prevented from saving to Dropbox with the "You don't have permission to save in this location" message.

    Fix: In my AV program (BitDefender) I added Greenshot to the trusted programs list in the "Ransomware Protection" module. 




    • 已编辑 tartist 2016年2月13日 10:51
    2016年2月13日 10:33
  • worked !!! but i had to reboot first
    2016年2月22日 18:02
  • Thank you DotCav! I was having a similar issue in Windows 10. Your solution fixed the problem straight away!
    • 已编辑 stbelgiq 2016年7月1日 0:29
    2016年7月1日 0:28
  • Well go to start go to all apps and right click it and then press more then set as administer and click yes when a alert comes up (It worked for me!!)
    • 已建议为答案 Gamer124 2016年8月9日 5:57
    2016年8月9日 5:56
  • Oh My Goodness....... 

    Jut installed Windows 10 and have the same setup as someone above - Data on a second Hard Drive - OS and Programs on SSD and since install of 10, i keep getting the error above.

    Tried taking ownership, I was already administrator.... very frustrating!!

    Completed your suggested method and Bingo.... Problem Solved!

    Many Thanks!!

    2016年11月12日 22:13
  • Does not work
    2016年12月14日 1:59
  • Spot on Arthur! You ROCK dude. Concise answers, solved this problem...no fuss no muss!
    2016年12月30日 17:22
  • Worked like a charm on Windows 7 for a QB file I we needed to back up to restore on a different computer.
    2017年2月13日 19:44
  • THANK YOU! This saved me.
    2017年4月27日 15:21
  • OMG!! UAC was the reason!! thanks for the solution.

    2017年6月22日 23:28
  • DotCav's solution is right on the money. The writer obviously understands the problem behind the error message and therefore offers a real solution. If I had spent another couple of hours (or days) reading Windows 7 Inside Out, I might have arrived at the solution for myself, but I certainly prefer to act on someone else's having got there (in effect) first. Taking the long way--reading the book--is enlightening in general, but it also supplies a lot of information for which one will never have any use and wastes finite space in the head that is needed for other uses.

    Kudos to Kinderwe. The affirmation stated regarding learning from other people's solutions instead of having to ferret out every answer yourself is important when you're mortal. That work has already been done. Most of Kinderwe's statement could be transcribed to most of this forum's topics and still be on-target, no matter date or subject matter. Thank you for moving the ball down field there also, DotCav. It's August 2017 now and your solution still works.

    What's up with the "finite space in the head" thing there Kinderwe? You running out? I doubt it. (only part I had a problem with!) 


    • 已编辑 Shay D 2017年8月6日 8:21
    2017年8月6日 8:20
  •  
    2017年10月29日 18:20
  • Thank You! That was the most simple fix. Just right click on the program you want to open and run it as administrator. As long as you are the Administrator you can save in the desired location.
    2017年12月30日 2:09
  • Thank you saved me. I had similar problem and now i can save to the desktop without any prompts of restricted modes.
    2018年6月6日 8:27
  • this does not fix the issue. this works around the issue. we are not trying to save to the desktop we are trying to save to the folder we for some reason dont have access to on our own computer. can you help resolve this issue and not work around it?
    2020年7月17日 16:45
  • i did that. it told me there was a problem changing it. can you guys do something on YOUR end to resolve this? this seems like a whole lot of unneccessary work just to save something to the correct folder on the pc i paid so much for. no workarounds please, we want fixes.
    2020年7月17日 16:46