none
Hyper-V 集成服务问题 RRS feed

  • 问题

  • 您们好:

      我通过hyper-v做了模板(更新了集成服务),但通过vdi创建集合创建的虚拟机,集成服务版本与模板的不一致。

    请问:

    1. hyper-v的集成服务是安装在哪个位置?是否可以卸载?

    2. 通过模板将虚拟机部署到不同的宿主机上,创建出来的虚拟机集成服务与原模板不一致,是否正常?为什么会出现此情况?

    2019年8月5日 0:59

全部回复

  • Hi ,

    >>hyper-v的集成服务是安装在哪个位置?是否可以卸载?

    hyper-v集成服务类似于驱动程序,用来优化host和虚拟机之间的集成,以及增强虚拟机的操作系统性能。通常都是建议将集成服务更新到最新的版本的。

    这篇blog有关于hyper-v集成服务,可以参考一下:

    Hyper-v VM intergration services (请注意:此链接非微软官方托管,链接随时可能失效,微软无法保证信息的准确性。

    如果安装的操作系统的版本是低于server 2012的,需要通过插入集成安装盘来手动安装Hyper-V 集成服务。

    如果安装的操作系统的版本是高于server 2012的,在安装操作系统的时候会自动安装hyper-v集成服务。

    您VM操作系统是什么版本的?host的系统版本是多少?现在集成服务的版本和模板的版本分别是多少?不一样的情况是低了还是高了?如果是低了的话,尝试升级一下看看。

    >>通过模板将虚拟机部署到不同的宿主机上,创建出来的虚拟机集成服务与原模板不一致,是否正常?为什么会出现此情况?

    不同的宿主机上是指的什么操作系统的主机? 我怀疑是由于主机上的操作系统更新,将VM的集成服务升级到了最新的版本。

    此致

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    2019年8月5日 3:08
  • 非常好,我收藏了!
    2019年8月5日 3:34
  • 感谢您的回复

    宿主机是window server 2012 r2,虚拟机是win7 sp1企业版

    模板的集成服务是6.3.9600.18692,部署出来的虚拟机集成服务是6.1.7601.24000

    部署出来的集成服务可以手动升级

    我的疑问是为什么这个集成服务与模板的不一致,如果要手动升级的话,相对于我用这个模板部署出来 的所有虚拟机都需要再手动升级一次。

    请问是否有官方文档说明这种现象是正常的?(这种现象指通过模板部署出来的虚拟机集成服务版本不一致)

    谢谢

    2019年8月5日 5:26
  • Hi ,

    >>请问是否有官方文档说明这种现象是正常的?(这种现象指通过模板部署出来的虚拟机集成服务版本不一致)

    从hyper-v层面考虑,目前没有找到官方文档有说明这个情况,由于是通过vdi创建集合创建的虚拟机,建议也可以将问题PO在对应的RDS论坛,以下是RDS论坛的链接:

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/home?forum=winserverTS

    同时,我将会继续更进查找相关的资料,一旦找到官方文档的说明,会立即在此贴进行更新。

    若您在此过程中,有任何的进展,也可以随时在贴下进行回复。

    此致

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    2019年8月5日 7:37