none
关于framework 2.0和4.0的兼容性问题。 RRS feed

  • 问题

  • 我装了framework 4.0, 最近想安装 sql server 2005图形管理器时被告之必须安装2.0, 奇怪了,4.0难道不兼容2.0? 该怎么办呢? 各位大侠帮帮忙哈!
    2010年7月30日 7:24

答案

  • 你好,

    framework并不像其他DirectX一样包含以前版本的内容,而是在原有版本的情况下增加新内容,所以有可能在安装新版本之前需要计算机中已经安装旧版本来作支持。

    如果是Windows XP系统,需要手动安装Framework 2.0之后才能安装4.0版本。


    请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。 - MVP | Windows Desktop Experience | Virtualization Sino
    • 已标记为答案 kikips 2010年8月2日 4:53
    2010年7月30日 11:42

全部回复

  • ..net Framework 4 并不像 3.5 那样包含早期的版本,安装 4.0 后依然需要单独安装早期的版本。
     
    你可以直接安装 3.5 with SP1,安装程序将添加 2.0、3.0、3.5 的所有版本,它们都包含在 3.5 with SP1 中。
     
    Windows 7/Vista 无需执行此安装,系统已经包含。
     
    --
    Alexis Zhang
     
    https://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "kikips"
     
    我装了framework 4.0, 最近?氚沧?sql server 2005图形管理器时被告之必须安装2.0, 奇怪了,4.0难道不兼容2.0? 该怎么办呢? 各位大侠帮帮忙哈!
     
    2010年7月30日 10:18
    版主
  • 你好,

    framework并不像其他DirectX一样包含以前版本的内容,而是在原有版本的情况下增加新内容,所以有可能在安装新版本之前需要计算机中已经安装旧版本来作支持。

    如果是Windows XP系统,需要手动安装Framework 2.0之后才能安装4.0版本。


    请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。 - MVP | Windows Desktop Experience | Virtualization Sino
    • 已标记为答案 kikips 2010年8月2日 4:53
    2010年7月30日 11:42
  • 不是的,Windows XP 可以在不安装 2.0、3.0、3.5 这些版本的前提下直接安装 4.0。
     
    4.0 并不包含这些版本,也不要求必须首先安装它们才能安装 4.0。
     
    --
    Alexis Zhang
     
    https://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "Squaredy"
     
    你好,
    framework并不像其他DirectX一样包含以前版本的内容,而是在原有版本的情况下增加新?谌荩?
     
     
    2010年7月31日 10:00
    版主