Using Osdimg to create an ISO Windows PE


  • Hi Everyone,

    I'm being puzzled with the error when I try to build an ISO of Windows PE.

    The command I use is:

    Oscdimg -n –bc:\winpe_x86\ c:\winpe_x86\ISO c:\winpe_x86\winpe_x86.iso

    (And Typed it in not copy and paste since there is a bug about that)

    I get an the following:

    ERROR: Could not open boot sector file "c:\winpe_x86\

    Error 3: The system could not find the path specified.

    I can ask for help to anyone? Please?



    2007年3月1日 0:57


  • It cannot find the file

    Make sure it is in the location you specified... in your case:



    2007年3月1日 13:42
  • Hi everyone,

    I found the problem.

    It seems that the file that was in the root directory is not a valid copy, I copied the one that was installed on c:\winpe_x86\boot to the root.



    2007年3月1日 17:13
  • It cannot find the file

    Make sure it is in the location you specified... in your case:



    I'm encountering the same problem as above... But even when I'm searching for the bootfile on the entire C:\ I'm unable to find the file... Where should I look for this file? And am I supposed to just copy the file?


    I was using the ia64 instruction for a server installation. When I'm using the x86 instruction it prompts automatically... So I'll use another server to test install this. Thanks anyways!
    2010年2月4日 11:19
  • note that there is no space between the -b and the bootfile path!!!
    2010年2月13日 3:43
  • I'm having the same issue. I'm using ia64 but it will not find the
    2010年7月2日 19:10
  • I have the same issue. only in the directory that I specify in command, but it comes back with the error message. Any ideas on this please?
    2010年8月20日 20:48
  • Not sure if you guys found the solution, but had the same problem.

    I copied the command from the instructions and pasted it into the command window. I resolved it by typing the command directly, it seems that the copying messed up the double quotes.



    2010年9月24日 5:58
  • I'm having the same issue. I'm using ia64 but it will not find the

    Has this been Resolved? (its not a cut and past thing)


    I’m having the same exact problem…

    2010年10月7日 18:54
  • I had a space between the -b and the path.


    Once I tightened it up, I was fine. I put the two WAIK files I needed in WAIK-bits: oscdimg.exe and 


    So, to create a bootable ISO, this worked for me.



    .\WAIK-bits\oscdimg.exe -m -n -b.\WAIK-bits\ .\DVD-FILES .\DVDout.iso



    --Jeremy Moskowitz, Group Policy MVP
    2011年1月14日 20:25
  • Dear Lewis,

    i also faced the same problem.

    First verify the paths and filenames are correct and type the full command manually.




    • 已建议为答案 tojoe101 2011年12月26日 16:46
    • 取消建议作为答案 tojoe101 2011年12月27日 15:45
    2011年2月12日 0:46
  • Hi

    I  used the  file named efisys.bin because the files was missing too. This is on an ia64 processor and it worked I tried different ways that did not work but it seems this will work.


    oscdimg.exe -n -bc:\winpe\efisys.bin C:\winpe\ISO C:\winpe\winpe.iso



    • 已编辑 tojoe101 2011年12月28日 13:10 did not work by copy and paste from an amd64 processor.
    2011年12月27日 16:03
  • Only use ia64 if you are using an Itanium processor. Otherwise use amd64.

    • 已建议为答案 Wayniack 2013年1月2日 19:19
    2012年4月16日 21:33
  • Thanks SW...I think you deserve some points for this. I'm using the x64 environment and ran into the missing error. Turns out I had used ia64 instead of amd64 and that was the problem. I also just noticed that you posted this on my birthday! Thanks for the gift.

    Wayne S. CompTIA A+ CompTIA Network+ Microsoft MCP

    • 已编辑 Wayniack 2013年1月2日 19:26
    2013年1月2日 19:22
  • Thank you

    it worked .

    2018年1月14日 13:23