none
Object reference not set to an instance of an object RRS feed

  • 问题

  • 您好:


         请教 下在Exchange2013与Exchange2016混合环境中,在Exchange2016 创建dag后,右边显示“Object reference not set to an instance of an object” 系统邮箱与管理员邮件快速迁移到Exchange2016 。
    请教下以上情况,可有解决方案

      
    2020年6月16日 10:42

全部回复

  • 您好,

    请尝试将仲裁邮箱和管理员邮箱迁移到Exchange 2016服务器的数据库中:

    New-MoveRequest –Identity Administrator –TargetDatabase "Mailbox Database 2016" Get-Mailbox -Database "Mailbox Database 2013" -Arbitration | New-MoveRequest -TargetDatabase "Mailbox Database 2016"

    之后请尝试用最新版本的IE浏览器登录EAC,并查看是否仍有此报错。

    另外,您环境中是否有使用Exchange online? 一般我们将Exchange本地和Exchange online一起部署的称为混合环境,本地和本地一起部署的成为共存环境。

    另外,提醒一下,DAG要求其成员所处的Exchange版本一样,2013的服务器不能加入您这个DAG的。

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年6月17日 5:20
  • 您好:

    1、仲裁邮箱和管理员邮箱迁移到Exchange 2016服务器的数据库--已经执行过
    2、您环境中是否有使用Exchange online?——没有

    3、本地和本地一起部署的成为共存环境——是共存环境

    4、DAG要求其成员所处的Exchange版本一样 ——PCO有使用过的与测试过

    感谢你们回复1

    2020年6月17日 6:19
  • 您好,

    1.请确认您登录EAC使用的账号为administrator账号的logon name:

    2.请问您的Ex2013的版本是?如果是低于CU21的,您可以尝试升级到CU21或之后的版本后,再检查是否仍有问题。

    参考链接:https://support.microsoft.com/en-us/help/4133618/error-get-databaseavailabilitygroupnetwork-cmdlet-exchange-server-2013

     

    3.请前往”网络连接“中心,确保可以看到两个NIC,按下alt找到高级-高级设置,选中MAPI网络适配器并点击右边的↑,之后重启EAC,检查是否有效。

    参考链接:https://social.technet.microsoft.com/Forums/en-US/8e6e1533-5797-47ea-83c5-e554209a598c/8220object-reference-not-set-to-an-instance-of-an-object8221?forum=Exch2016SD

     

    4.官方是明确表示不支持不同版本的部署的,您是否考虑将Ex2013升级到2016呢:

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    • 已标记为答案 winsungu 2020年6月18日 9:01
    • 取消答案标记 winsungu 2020年6月19日 7:59
    2020年6月17日 8:51
  • 您好:

    1.请确认您登录EAC使用的账号为administrator账号的logon name:——是的

    2、请问您的Ex2013的版本是?如果是低于CU21的,您可以尝试升级到CU21或之后的版本后,——低于CU21

    3.请前往”网络连接“中心,确保可以看到两个NIC,按下alt找到高级-高级设置,选中MAPI网络适配器并点击右边的↑,之后重启EAC,检查是否有效。—— windows server 2016 怎调这个设置?

    4、官方是明确表示不支持不同版本的部署的,您是否考虑将Ex2013升级到2016呢 。现就是计划升级 ,dag 成员是相同版本

       
    2020年6月17日 9:54
  • 您好,

    这个系统邮箱所在的服务器在您的DAG中吗?

    您可以参照以下链接尝试删除并重建所有系统邮箱:https://evotec.xyz/exchange-2013-health-mailbox-has-been-corrupted/

    请注意:由于该网站不是Microsoft托管的,因此链接可能会更改,恕不另行通知。 Microsoft不保证此信息的准确性。

    此致,

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.



    2020年6月18日 7:04
  • 您好,

    长时间没有收到您的回复,请问问题解决了吗?

    如果您需要进一步的帮助,请提供相关信息,我们会继续为您提供帮助。

    此致, 

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年6月29日 3:20
  • 您好:


    问题还未解决。
    2020年6月29日 3:32
  • 您好,

    您是否尝试了升级到新版CU?

    检查适配器的顺序您可以右键右下角的网络图标-打开网络中心-改变适配器, 按下alt 点开Advanced setting,应该得到类似下图的结果,将MAPI调到最上方即可:

    此致, 

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    • 已标记为答案 winsungu 2020年6月29日 3:53
    • 取消答案标记 winsungu 2020年6月29日 3:53
    2020年6月29日 3:47
  • 您好:


       这个系统server2016 不能这样调整,需要命令调整,有调整过优先级,显示正常过一些时间。第二天报错又出再了!
    2020年6月29日 3:56
  • 您好,

    十分抱歉之前对于Windows Server 2016的了解不够。

    请问第二天报错时,优先级是按照您用命令修改后的显示的吗?

    出现此错误并迁移系统邮箱和管理员邮箱后,是否有尝试过移除DAG并重新配置?

    此致, 

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年6月29日 8:44
  • 请问第二天报错时,优先级是按照您用命令修改后的显示的吗?是的

    是迁移系统邮箱和管理员后进行新建DAG配置。多次测试结果一样!

    2020年6月29日 8:48
  • 您好,

    请问除了EAC中这个异常的提醒,是否还遇到了别的现象?

    更换浏览器登录EAC,是否仍有该现象?

    此致, 

    Eric Yin


    如果以上回复对您有所帮助,建议您将其“标记为答复”. 如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们:tnsf@microsoft.com.

    2020年6月30日 9:18