none
hyper-v出错 RRS feed

  • 问题

  • 在hyper-v管理器里点击连接到服务器,然后点击本地计算机,点确定,然后就出现一个窗口,写着:“在尝试连接本地服务器时出错,出现请检查虚拟机管理服务是否正在运行及是否授权你连接到此服务器”,下面还有一行小字:无法解析计算机“***”,请确保正确键入计算机名称并且拥有网络访问权限
    2020年8月17日 2:42

答案

  • 我自己发现问题了,是因为我给我的电脑起的名称太长了,导致应用无法读取全部名称。我把它缩短了一点,就解决了
    • 已标记为答案 MartinLeis 2020年8月22日 6:47
    2020年8月20日 7:08

全部回复

  • ***是我电脑的名称,我自己设的
    2020年8月17日 2:43
  • 你好,

    请尝试以下方法是否奏效:

    1. 打开CMD,运行以下命令重建WMI组件:

    MOFCOMP %SYSTEMROOT%\System32\WindowsVirtualization.V2.mof

    2. 打开 "Window Security"
    打开 "应用和浏览器控制"
    点击最下面的 "Exploit protection 设置"
    选择 "程序设置"
    找到 "C:\WINDOWS\System32\vmcompute.exe"
    Click "Edit"
    Scroll down to "Control flow guard (CFG)" and 去掉 "Override system settings"的勾
    打开powershell "net start vmcompute"

    如果回复有帮助的话,请帮忙标记为答案。

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2020年8月17日 7:24
  • 你好,

    请问上述回复对你有帮助吗?如果有的话,请帮忙标记为答案,如果需要进一步帮助,请随时反馈。

    感谢您的时间!

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2020年8月19日 7:10
  • 我自己发现问题了,是因为我给我的电脑起的名称太长了,导致应用无法读取全部名称。我把它缩短了一点,就解决了
    • 已标记为答案 MartinLeis 2020年8月22日 6:47
    2020年8月20日 7:08
  • 你好,

    很高兴您的问题解决了,感谢您分享解决方法。

    如果没有其它问题的话,可以将该案件中有帮助的帖子标记为答复,以此结束该案件。如果之后需要进一步帮助,欢迎随时回复。

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2020年8月20日 7:11