none
客户端安装问题? RRS feed

  • 问题

  •  

    我在安装完客户端后,在站点维护--任务中将相应任务设置错误,导致有一部分已经安装好的客户端在“成功部署客户端报表”中被清除掉,客户端标志还显示为Yes,因不知道哪些客户端被清除掉,我便在“所有系统”集合中运行安装客户端将全部客户端再重新安装,并将修复安装选中,再次安装就出现有一部分客户端不能被安装,有一部分能正常安装(也有可能是之前未安装客户端的电脑)。我在维护任务里设置了在星期六清除安装标志,时间为1天,这样又出现有一部分客户端的安装标志被清除掉,显示为NO。星期一,我又找了几台已经安装好的客户端再运行“客户端安装”,仍然不能被安装。而新加入的客户端却能正常安装。查看不能安装客户端的日志文件显示如下信息,

    <![LOG[Starting BITS download for client deployment files.]LOG]!><time="14:02:37.402+000" date="10-13-2008" component="ccmsetup" context="" type="1" thread="5672" file="ccmsetup.cpp:6544">
    <![LOG[Download Update: A recoverable error has occurred.  A retry attempt will be made.]LOG]!><time="14:02:38.419+000" da

    有二台电脑晚上没有关机,第二天查看日志文件,发现晚上1点到2点却在下载所需文件,有一台便在这个时间段已经重新安装好客户端,另外一台还没有下载完成,一过2点就又显示错误信息。我在计算机客户端代理的BITS栏已经设置为无配置。请问这是什么原因导致会出现此种情况,因怎样才能解决重新安装客户端时能正常安装。我的服务器端为Windows2008企业版+SQL2005 SP2企业版+SCCM2007 With SP1,均为英文版。

    这时凌晨1点到2点的安装日志信息。

    <![LOG[Download Update: A recoverable error has occurred.  A retry attempt will be made.]LOG]!><time="00:55:29.668+000" date="10-14-2008" component="ccmsetup" context="" type="1" thread="2344" file="ccmsetup.cpp:6634">
    <![LOG[Download Update: 58373 out of 49202688 bytes transferred.]LOG]!><time="01:00:29.670+000" date="10-14-2008" componen

    <![LOG[Download Update: 7280494 out of 49202688 bytes transferred.]LOG]!><time="01:55:29.743+000" date="10-14-2008" component="ccmsetup" context="" type="1" thread="2344" file="ccmsetup.cpp:6622">
    <![LOG[Download Update: A recoverable error has occurred.  A retry attempt will be made.]LOG]!><time="02:00:29.745+000" date=

     

     

    另我在报表里运行“成功部署客户端报表”时,里面的安装时间和客户端安装时间不相符合,比当前时间晚了八个小时左右,报表中显示的是UTC,而我在Win2008的时区设置中已经设置为北京时间。查看系统状态里的各项信息显示的也是北京时间。应怎样调整报表显示时间。将服务器配置好后,初次分发软件,时间设置为北京时间的15点安装,而客户端实际安装软件时间却是凌晨一点左右。过了几天又恢复正常,可以按照指定时间分发软件。我在客户端强制刷新策略也不行。为何会需要凌晨才能将分发的软件安装好。

    还请大家帮忙解答这几个问题。

    2008年10月14日 7:39

答案

  •  

    SMS / SCCM 中强烈建议要有充分的耐心, 毕竟组件太多,很多都是schedule 工作的,而且很多相关联,呈链式。 控制台上一个操作最终落实到客户机,很可能需要几个小时,甚至几天,取决于这些任务的schedule。

     

    没有更多的信息,暂时看不出重装客户端的问题所在。

     

    软件安装时间问题,同toolkit 中的工具看看客户端接收到底的策略中的时间是多少。另:客户机和服务器时区设置,时间设置一致吗?

    2008年10月21日 6:17
    版主

全部回复

  •  

    SMS / SCCM 中强烈建议要有充分的耐心, 毕竟组件太多,很多都是schedule 工作的,而且很多相关联,呈链式。 控制台上一个操作最终落实到客户机,很可能需要几个小时,甚至几天,取决于这些任务的schedule。

     

    没有更多的信息,暂时看不出重装客户端的问题所在。

     

    软件安装时间问题,同toolkit 中的工具看看客户端接收到底的策略中的时间是多少。另:客户机和服务器时区设置,时间设置一致吗?

    2008年10月21日 6:17
    版主
  • 很久没来论坛了。后来我将不能安装客户端的电脑晚上不关机,就能在那个时间段安装好客户端。应该是跟BITS设置有关系。大约过了十来天。我发现有些客户端又失去联系。我又重新手动推送客户端,不管我手动点多少次安装客户端,并勾选上“始终安装(升级或修复现有客户端)”,客户端再也没有响应,ccmsetup.log没有记录任何信息。我担心可能是服务器哪里设置错了。我就直接将SCCM服务器删除掉,客户端也全部删除掉。重新安装服务器,服务器重新安装好,客户安装一切正常,都能安装上。后来有台电脑更改了电脑名,我便将其从集合里删除,重新发现。再手动推送客户端,又出现和重装前的情况,客户端又没有任何反应。不管是新安装的系统还是原有系统。只能安装一次客户端,重新安装都不起作用。请问版主,这是哪里出了问题导致客户端只能安装一次,不能再重新安装,我检查了服务器端设置也没有不妥的。

    2008年11月29日 2:20
  •  

    1.  客户端各个组件是否工作正常?  硬件和软件inventory,补丁分发,软件分发等等。客户端上的配置? 连接到哪个MP,设置都对吗? DB 中有这个client的信息吗?

     

    2. 客户端日志中,除了ccmsetup.log 其它的 execmgr.log, 等何种情况?

     

    3. wbemtest.exe 或者 CMIstudio 连接 WMI 的ccm名称空间, 执行 WQL 查询,可否正常工作?  不行就用 WMIdiag.vbs 检查。

     

    只能安装一次,一般是作为一个软件分发时,设置run once for computer,那么就会记录执行历史,但是这是要求ccm客户端正常工作。作为ccm客户端本身,应该是已经出问题了吧 ? 手工修复可以正常吗?

    2008年11月30日 14:56
    版主
  • 问题还是没有解决,仍然是只有第一次能正常安装,之后再推送客户端就没有响应。我把SCCM服务器重新安装,服务器我正常删除后,把服务器格式化。重新安装SCCM后,我通过ccmsetup /uninstall将客户端全部删除掉,有少许的文件不能完全清除掉,以前接收过的SCCM策略都能完全清除干净吗?

    2008年12月14日 6:23