none
PST格式邮件导入Exchange 2010失败 RRS feed

  • 问题

  • Exchange Server 2010 SP3(之前是SP2刚升级为SP3)

    使用以下命令导入无法导入邮件:

    New-ManagementRoleAssignment -Name "Import Export_administrator" -User "Administrator" -Role "Mailbox Import Export"

    Get-MailboxImportRequest -mailbox   username -filepath \\unc\username.pst



    • 已编辑 pjj1112 2017年10月27日 8:16
    2017年10月27日 5:18

全部回复

  • 您好,

    感谢联系我们社区。

    建议使用命令Remove-MailboxImportRequest先移除这些request 然后使用下面命令导入测试,一个一个导入:

    New-MailboxImportRequest -Mailbox user1 -FilePath \\SERVER01\PSTFiles\Recovered.pst -TargetRootFolder "RecoveredFiles" -IncludeFolders "#Inbox#"

    有什么错误代码或者信息请详细贴出。

    希望可以帮到您。

    Regards,

    Jason Chao


    如果以上回复对您有所帮助,建议您将其标记为答复

    如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们: tnmff@microsoft.com.

    2017年10月27日 8:35
  • 已删除原来导入请求,再导入还是出错

    2017年10月28日 1:14
  • 感谢回复。

    从这个事件,确实没有更详细的信息,建议点击详细信息,然后点击复制,

    确保您对这个PST文件路径有访问权限。

    另外运行Get-MailboxImportRequestStatiscs 查看具体信息。

    希望可以帮到您。


    Regards,

    Jason Chao


    如果以上回复对您有所帮助,建议您将其标记为答复

    如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们: tnmff@microsoft.com.


    2017年10月30日 7:46
  • 这个用户明明存在,为何提示用户:recovered  不存在呢?

    2017年10月31日 2:21
  • 感谢您的回复。

    看起来是您的view entire forest 设置为false了,建议运行下面命令进行设置:

    Set-AdServerSettings -ViewEntireForest $true -PreferredGlobalCatalog gc1.contoso.com

    提示:需要对高亮部分进行相应的更改。

    希望可以帮到您。


    Regards,

    Jason Chao


    如果以上回复对您有所帮助,建议您将其标记为答复

    如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们: tnmff@microsoft.com.


    2017年11月3日 1:50
  • 非常感谢您的解答

    运行的这个命令后还是提示失败,并在事件日志中记录以下错误:


    • 已编辑 pjj1112 2017年11月4日 0:26
    2017年11月4日 0:23
  • 感谢回复,

    从报错“mapiexceptionlogonfailed: unable to open message store. (hr=0x80040111)” 看起来还是对这个DB的访问权限问题,建议添加这台电脑对这个DB的Full control权限, 如下图在ADSIEdit里面:



    Regards,

    Jason Chao


    如果以上回复对您有所帮助,建议您将其标记为答复

    如果您对我们的论坛支持有任何的建议,可以通过此邮箱联系我们: tnmff@microsoft.com.


    2017年11月7日 9:45
  • 您好:

    在直接在邮件服务器上导入的,但还出现错误。

    2017年11月11日 0:33
  • 感谢回复,

    请检查这个邮箱以及所在数据库的状态用下面命令:

    get-mailbox <user name> | fl name, is*

    Get-MailboxDatabase db1 | fl name, is*, *mount*

    运行new-mailboximportrequest命令式确保是以管理员权限运行的Exchange Poweshell.

    另外还需检查 domain admin 对这个用户是否有full control的权限如下:

    感谢您的努力。


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    2017年11月14日 7:30
  • 按照您的方法,并且删除以下几个邮箱导入邮件,显示导入成功,但原来导入的邮件还是看不到?

    请教都删除这几个邮箱会有影响吗?

    显示已到入成功,事件中也无错误,但原来邮件数量并没有变化?

    2017年11月16日 5:10
  • 感谢回复,删除不会有影响,一般我们删除后都需要重建的按照下面方法。

    用安装文件运行Setup.com/Preparead 去重建他们,直到他们被启用用下面命令,否则他们是不工作的。

    Enable-Mailbox Arbitration SystemMailbox{Guid Value1}

    Enable-Mailbox Arbitration SystemMailbox{Guid value2}

    Enable-Mailbox Arbitration FederatedEmail.Guid Value

    Enable-Mailbox Discovery DiscoverySearchMailbox{Guid Value}

    重建完之后建议从新导入测试。


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    2017年11月16日 6:25