none
windows 2012 R2服务器无法安装KB3095113,kb3159706两个补丁,导致wsus不能给win10分发补丁 RRS feed

  • 问题

  • 为了让wsus能给win10正常分发补丁,需要在2012R2上安装KB3095113,kb3159706两个补丁。

    按照对应的x64位,R2版本下载补丁,但在服务器上无法安装,提示“此更新不适用于你的计算机”。

    KB3095113所需要的先决条件:若要应用此更新 Windows Server 2012 R2 中的,您必须具有2014 年 4 月更新 Windows RT 8.1、 Windows 8.1 和 Windows Server 2012 R2 (2919355) 的汇总。

    kb2919355经检查,已经安装于系统内。

    请帮忙看一下,怎么解决。

    非常感谢!

    2017年11月23日 5:14

答案

  • 经检查,所有exe和dll确实已经等于或高于列表中的版本。看来是不用安装标题的两个补丁了。

    后来发现2012r2上的wsus其实没问题,2016 ltsb需要安装一个补丁,就可以正常从wsus下载安装并提交报告了。

    而2015 ltsb直接可以正常连接wsus。

    非常感谢你的恢复。

    其他人发布的,可以参考。我的环境是64位2016 ltsb安装kb3189866就正常了,通过wsus更新后,该补丁似乎被其他补丁覆盖了,系统内将找不再找不到kb3189866

    最终确认结果:Win10 1607 32位打完kb3189866补丁就可以从WSUS下载补丁了,但64位我是打完了kb3194496才可以从WSUS下载补丁的。

    2017年11月30日 8:45

全部回复

  • 你好,

    1. KB3095113已经被KB4025336(2017-7月的月度安全质量汇总)替代了,而7月的月度更新又被8月的月度更新替代,8月的月度更新被9月的月度更新替代,以此类推,后面月度的月度更新取代前面月度的月度更新, 所以请检查一下该WSUS server是否安装过任意一个7月或7月以后的月度更新,如果是的话,那么提示不适用的报错是正常的现在,因为安装过后面的更新就不需要再安装之前的更新了。

    请检查是否安装过KB4025336, KB4034681,KB4038792, KB4041693, KB4048958, KB4039871中的任何一个,即上面说的取代KB3095113的更新。

    2. 请问安装KB3159706时出了什么问题,安装完KB3159706后我们需要手动执行下面文章中的操作,你是否已完成:

    https://support.microsoft.com/en-us/help/3159706/update-enables-esd-decryption-provision-in-wsus-in-windows-server-2012

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017年11月24日 7:28
    版主
  • 你好,

    请问上述回复对你有帮助吗,如果有的话,请将有用的回复标记为答案,如果你还有其他问题的话,欢迎反馈。

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017年11月27日 2:52
    版主
  • 非常感谢你的回复!

    KB4048958确实已经安装在系统内,所以KB3095113按照你的说法装不上是正常的,那么要解决wsus给win10分发补丁的问题,KB3095113应该可以不用安装了吧?

    安装KB3159706时,同样提示“此更新不适用于你的计算机”。

    2017年11月28日 8:57
  • 你好,

    >KB4048958确实已经安装在系统内,所以KB3095113按照你的说法装不上是正常的,那么要解决wsus给win10分发补丁的问题,KB3095113应该可以不用安装了吧?

    是的, KB3095113不需要安装了。

    >安装KB3159706时,同样提示“此更新不适用于你的计算机”。

    请按照下面KB中的信息(点开file information>windows server 2012R2),检查WSUS server上对应的系统文件的版本,如果对应系统文件的版本大于或等于列出来的版本,那么我们也不需要再安装KB3159706了,类似下图:

    https://support.microsoft.com/en-us/help/3159706/update-enables-esd-decryption-provision-in-wsus-in-windows-server-2012

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017年11月29日 9:53
    版主
  • 经检查,所有exe和dll确实已经等于或高于列表中的版本。看来是不用安装标题的两个补丁了。

    后来发现2012r2上的wsus其实没问题,2016 ltsb需要安装一个补丁,就可以正常从wsus下载安装并提交报告了。

    而2015 ltsb直接可以正常连接wsus。

    非常感谢你的恢复。

    2017年11月30日 8:39
  • 你好,

    很高兴听到这个反馈。

    如果你的问题已经解决的话,请将该帖子中有用的回复“标记为答复”,这样有用的信息就可以被凸显出来,其他遇到同样问题的人可以更好的找到有用信息。我们也可以结束对这个帖子的跟踪。谢谢。

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017年11月30日 8:44
    版主
  • 经检查,所有exe和dll确实已经等于或高于列表中的版本。看来是不用安装标题的两个补丁了。

    后来发现2012r2上的wsus其实没问题,2016 ltsb需要安装一个补丁,就可以正常从wsus下载安装并提交报告了。

    而2015 ltsb直接可以正常连接wsus。

    非常感谢你的恢复。

    其他人发布的,可以参考。我的环境是64位2016 ltsb安装kb3189866就正常了,通过wsus更新后,该补丁似乎被其他补丁覆盖了,系统内将找不再找不到kb3189866

    最终确认结果:Win10 1607 32位打完kb3189866补丁就可以从WSUS下载补丁了,但64位我是打完了kb3194496才可以从WSUS下载补丁的。

    2017年11月30日 8:45
  • 你好,

    可以将论坛上有用的信息标记为答复吗?这样更方便我们对论坛的管理。

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    2017年11月30日 9:05
    版主
  • 你好,

    请问能将该论坛上有用的可以作为解决方案的回复标记为答案吗?

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017年12月4日 2:58
    版主