none
windows server 2008 R2 .net Framework 3.5.1 问题 RRS feed

  • 问题

  • windows server 2008 R2 通过服务器管理-功能安装了.net framework 3.5.1 现实已安装,可是应用程序中。版本信息:显示Microsoft .NET Framework 版本:2.0.50727.4961; ASP.NET
    版本:2.0.50727.4955


    这需要怎么设置,请技术高手予以支持。
    2011年7月25日 9:30

答案

  • ..net Framework 2.0 包含于 3.5 SP1。
     
    换言之,安装了 3.5 SP1 就已经拥有了 2.0、3.0、3.5、3.5 SP1 的所有版本,只不过你看到的那个应用程序使用的是其中的 2.0 而已。
     
    --
    Alexis Zhang
     
    http://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "yuxz"
     
    我这个应该怎么配置呢,显示3.5的已经安装,可是系统里还是2.0的。
     
     
    2011年7月26日 10:53
    版主

全部回复

  • windows server 2008 是 oem版
    2011年7月25日 9:31
  • ..net Framework 2.0 包含于 3.5 SP1。
     
    --
    Alexis Zhang
     
    http://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "yuxz"
     
    windows server 2008 R2 通过服务器管理-功能安装了.net framework 3.5.1 现实已安装,可是应用程序中。版本信息:显示Microsoft .NET
    Framework 版本:2.0.50727.4961; ASP.NET
     
     
    2011年7月26日 6:16
    版主
  • 我这个应该怎么配置呢,显示3.5的已经安装,可是系统里还是2.0的。
    2011年7月26日 6:47
  • ..net Framework 2.0 包含于 3.5 SP1。
     
    换言之,安装了 3.5 SP1 就已经拥有了 2.0、3.0、3.5、3.5 SP1 的所有版本,只不过你看到的那个应用程序使用的是其中的 2.0 而已。
     
    --
    Alexis Zhang
     
    http://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "yuxz"
     
    我这个应该怎么配置呢,显示3.5的已经安装,可是系统里还是2.0的。
     
     
    2011年7月26日 10:53
    版主
  • asp.net版本只有2,0 ,4.0,没有3.0.3.5这些版本。网站编译成3.5,iis选择2.0就可以了


    【孟子E章】
    2011年7月27日 14:30
    版主