none
Windows 7 64位家庭普通版安装 VirtualBox虚拟机造成0x000000D1蓝屏问题,ndis.sys文件错误 RRS feed

  • 问题

  • 我用的是SONY的VPCCW15EC笔记本,CPU是奔腾双核T4300(2.10GHz),2G DDR2内存,64位Windows 7 家庭普通版系统。

    一直无法安装VirtualBox或者VMware这类虚拟机软件,每次安装完成后重启就会造成蓝屏,显示错误代码:0x000000D1,显示的错误文件名称是“ndis.sys”。

    我安装的杀毒软件是Avira AntiVir Personal-Free Antivirus,也就是小红伞的免费版。这里要提一下,我购买过小红伞的收费版,结果安装以后也是蓝屏,但忘记错误代码是不是一样的了,只好把收费版送朋友了。

    在网上查了下资料,D1的错误代码和ndis.sys文件应该是系统网络方面文件出了问题,安装虚拟机需要安装有关网络的组件,安装小红伞的收费版本也比免费版本增加了网络的实时监控功能。所以怀疑是不是有关网络的系统文件造成的蓝屏问题?

    该怎么解决这个问题呢?

    2011年10月31日 9:20

答案

  • 应该是虚拟机试图安装的虚拟网络适配器驱动,或者虚拟机试图映射的本地物理网络适配器驱动与虚拟机版本或 64 位 Windows 版本不兼容所致。
     
    --
    Alexis Zhang
     
    http://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "ccrecall"
     
    我用的是SONY的VPCCW15EC笔记本,CPU是奔腾双核T4300(2.10GHz),2G DDR2内存,64位Windows 7 家庭普通版系统。
    一直无法安装VirtualBox或者VMware这类虚拟机软件,每次安装完成后重启就会造成蓝屏,
     
     
    2011年11月1日 3:26
  • 非常感谢楼上各位给我的建议和帮助,我的问题解决了。

    我按照之前看到的方法,先禁用网络适配器中的有线网卡和无线网卡,重启后安装VirtualBox,再重启PC,没有出现蓝屏现象,但在重新启用无线网卡时又一次蓝屏了,经过几次测试,确定是由于无线网卡的问题造成的蓝屏,我的笔记本无线用的是“Atheros”的AR9285。于是想到更新驱动程序,在SONY官网上找到这款无线的更新驱动程序,重新更新了驱动,要提一下的是,第一次安装无线驱动程序更新的时候居然又蓝屏了一次,选择正常启动windows后再次安装才更新了驱动。驱动更新后再安装VirtualBox就没有问题了,安装完成后可以正常重启,不会再出现蓝屏的问题了。

    SONY无线驱动下载链接如下,只针对一些SONY VAIO笔记本的型号:

    http://service.sony.com.cn/vaio/Download/28870.htm

    该升级程序将升级Wireless LAN Driver(Atheros)程序到版本8.0.0.238,并修正了以下问题:
    1. 当使用计算机在设备管理器中添加新设备出现蓝屏的现象。
    2. 当在设备和打印机选项中添加新设备时,微软虚拟无线网卡出现黄色惊叹号。

    注意:
    此程序只针对安装有Atheros无线网卡的VAIO机型,请您在安装补丁前确认无线网卡名称。

    适用操作系统:
    Windows7 (32,64位)

    升级程序名称:          
    Wireless LAN Driver(Atheros)驱动程序_版本 8.0.0.238
    文件名称:EP0000211038.exe
    文件大小:31.6 MB (33,206,648 字节) 

    2011年11月4日 8:05

全部回复

  • 应该是虚拟机试图安装的虚拟网络适配器驱动,或者虚拟机试图映射的本地物理网络适配器驱动与虚拟机版本或 64 位 Windows 版本不兼容所致。
     
    --
    Alexis Zhang
     
    http://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "ccrecall"
     
    我用的是SONY的VPCCW15EC笔记本,CPU是奔腾双核T4300(2.10GHz),2G DDR2内存,64位Windows 7 家庭普通版系统。
    一直无法安装VirtualBox或者VMware这类虚拟机软件,每次安装完成后重启就会造成蓝屏,
     
     
    2011年11月1日 3:26
  • 谢谢答复,不知道这个问题有没有可以解决的办法?64位的WIN 7都无法安装虚拟机软件吗?
    2011年11月1日 12:36
  • 試試二選一的方案, 就是在 VirtualBox 或 VMWare 只安裝其中之一, 另外一個卸載掉.
    另外如果還有其他一些系統維護或優化軟件, 也建議先禁用或卸載, 然後進行觀察.
    Folding@Home
    2011年11月1日 14:09
  • 我就是安装的其中一个,先安装了VirtualBox,如果不重启电脑,就没有问题,只要重启电脑就会蓝屏。我试过卸载小红伞免费版,结果还是一样的,我没有安装其他系统维护软件或优化软件,平时都自己手动清理的。

    蓝屏后只有到安全模式下恢复镜像,由于VirtualBox安装的时候会自己设置一个还原点,所以很方便的还原到安装前的状态。

    之后安装VMware,当然不是正版,下载安装VMware只是为了测试是不是由于VirtualBox软件本身的问题。结果是安装完VMware后,就提示你重启,按照提示重启后,依然蓝屏。

    应该就是楼上Alexis说的原因,是虚拟机的虚拟网络适配器驱动,或者虚拟机试图映射的本地物理网络适配器驱动与虚拟机版本或 64 位 Windows 版本不兼容所致。

    我尝试过在安装VirtualBox的时候不安装网络部分的插件,结果软件无法安装成功,之前已经3次安装VirtualBox了,每次看到有新的版本更新,都会下载下来安装一下,每次都蓝屏,目前安装的版本是“VirtualBox-4.1.4-74291”。


    2011年11月2日 1:11
  • 你好,

    我之前也出现过类似的问题,这应该是由于64位系统与VirtualBox的虚拟网络适配器驱动不兼容导致。我建议你尝试安装VMware Workstation 8,因为我在安装此版本时似乎没有出现蓝屏问题。

    2011年11月2日 1:43
    版主
  • VirtualBox 我不太熟悉,它会不会像 VMware 那样在宿主系统中安装虚拟网络适配器?之前 VirtualBox 的卸载是否一切正常?
     
    如果 VirtualBox 会安装虚拟网络适配器,建议清理一下残留在系统中的历史信息,在控制面板“系统”属性的“环境变量”中添加一条
    devmgr_show_nonpresent_devices=1,然后在设备管理器中显示隐藏的设备,此时应该可以显示出以前安装过的历史网卡,将它们卸载,并且删除它们使用过的驱动文件。然后再试试。
     
    --
    Alexis Zhang
     
    http://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "ccrecall"
     
    我就是安装的其中一个,先安装了VirtualBox,如果不重启电脑,就没有问题,只要重启电脑就会蓝屏。我试过卸载小红伞免费版,结果还是一样的,我没有安装其他系统维护软件或优化软件,平时都自己手动清理的。
     
     
    2011年11月2日 2:14
  • 建議到 forums.virtualbox.org 論壇看看, 這個問題應該還有其他網友遇到, 看看有無 VirtualBox 相關人員提供的解決方案.
    另外如果跑虛擬機只是用於一些測試的話,並且電腦支持硬件虛擬化的話, 你也可以考慮通過評估版的 Windows Developer Preview 或 Windows Server 2008 R2 搭載的 Hyper-V 進行.
    Folding@Home
    • 已编辑 repl 2011年11月2日 2:33
    2011年11月2日 2:32
  • 我认为应该先对系统和虚拟环境进行检测,安装虚拟机等这类带有虚拟硬件之类的产品时,首先要禁用防护软件,比如关闭Avira AntiVir Personal-Free Antivirus。调试安装虚拟机时,排除杀毒和软件的不兼容性。再者,不要同时运行其他软件。祝你好运~
    学习并不是人生的全部。但,既然连人生的一部分——学习也无法征服,还能做什么呢?(The study certainly is not the life complete. But, since continually life part of-studies also is unable to conquer, what butalso can make?)
    2011年11月2日 3:21
  • 謝謝repl,系統我是不會更換的,筆記本自帶的WIN7 家庭普通版。

    我在forums.virtualbox.org 論壇看到的帖子,帖子的2樓中的情況跟我一樣,看了鏈接中的“ngh”提出的解決辦法,在安裝VirtualBox前將“network adaptores”禁用,然後重啟PC,再安裝VirtulBox,之後重啟PC,再打開network adaptores,我理解“network adaptores”為“網絡適配器”。

    這兩天比較忙,估計要到週末才能測試一下這個方法是否可行了。下面帖子鏈接供參考:

    https://forums.virtualbox.org/viewtopic.php?f=6&t=24847&hilit=W7+blue+screen+WINDOWS7&sid=397fb8c2983858f6d8102a40fc39f1ea

    2011年11月3日 1:22
  • Hi Alexis, 我周末的时候会按照你的方法试试看。谢谢帮忙!
    2011年11月3日 1:23
  • 呃。。。问了一下,VMware Workstation 8要$199,对我来说太贵了,如果是¥150左右的软件我都可以考虑。
    2011年11月3日 1:26
  • 非常感谢楼上各位给我的建议和帮助,我的问题解决了。

    我按照之前看到的方法,先禁用网络适配器中的有线网卡和无线网卡,重启后安装VirtualBox,再重启PC,没有出现蓝屏现象,但在重新启用无线网卡时又一次蓝屏了,经过几次测试,确定是由于无线网卡的问题造成的蓝屏,我的笔记本无线用的是“Atheros”的AR9285。于是想到更新驱动程序,在SONY官网上找到这款无线的更新驱动程序,重新更新了驱动,要提一下的是,第一次安装无线驱动程序更新的时候居然又蓝屏了一次,选择正常启动windows后再次安装才更新了驱动。驱动更新后再安装VirtualBox就没有问题了,安装完成后可以正常重启,不会再出现蓝屏的问题了。

    SONY无线驱动下载链接如下,只针对一些SONY VAIO笔记本的型号:

    http://service.sony.com.cn/vaio/Download/28870.htm

    该升级程序将升级Wireless LAN Driver(Atheros)程序到版本8.0.0.238,并修正了以下问题:
    1. 当使用计算机在设备管理器中添加新设备出现蓝屏的现象。
    2. 当在设备和打印机选项中添加新设备时,微软虚拟无线网卡出现黄色惊叹号。

    注意:
    此程序只针对安装有Atheros无线网卡的VAIO机型,请您在安装补丁前确认无线网卡名称。

    适用操作系统:
    Windows7 (32,64位)

    升级程序名称:          
    Wireless LAN Driver(Atheros)驱动程序_版本 8.0.0.238
    文件名称:EP0000211038.exe
    文件大小:31.6 MB (33,206,648 字节) 

    2011年11月4日 8:05