none
outlook2007频繁访问硬盘导致大量占用cpu RRS feed

  • 问题


  • 我创建三个pst文件,分别存放2007,2008,2009的邮件。当然现在只有存放2009的邮件的这个pst文件需要被修改。
    当然还有一个默认的邮件,存放收到,发送的邮件。但是通常我每星期一都会把上一个星期的邮件转移到2009.pst这个文件中。
    2007 pst有51M
    2008 pst有101M
    2009 pst有123M

    我发现outlook2007 在执行20--40分钟后会占用95%以上的cpu,而且一直占用这么多。但是当我点击tools/trust center后 其cpu占用率就会下降。
    另外,我看到 2007, 2008这两个pst文件的最会修改时间一直在更新,但是我们没有修改它们呀!!!
    而且通过任务管理中的performance/cpu usage history 发现 大部分是的时间属于 cpu kernel time。

    所以我怀疑, 是由于outlook 2007频繁访问pst文件导致了 占用 大量的cpu.

    另外我已经安装了outlook2007-kb933493-fullfile-x86-glb这个升级补丁了。 但是问题依旧。
    另外我已经关闭了所有的addin了。 但是问题依旧。

    此外, outlook的archive有什么用啊?
    此外, 有什么可以提高outlook性能的方法.



    Sorry for my English skill.I try my best to make the question clear.
    2009年6月12日 2:40

答案

  • 一些建议:

    1. 开始→运行→outlook /safe→回车,问题还存在吗?
    2. 在机器上查找下面几个文件:outcmd.dat、extend.dat、frmcache.dat、views.dat,找到后将其后缀修改为.old,注意它们可能位于隐藏的文件夹中,一般来说,它们位于C:\Documents and Settings\用户名\Local Settings\Application Data\Microsoft\Outlook\中;
    3. 开始→控制面板→邮件→显示配置文件→点击“提示要使用的配置文件”→添加→在“配置文件名称”下输入一个名称→确定→在邮件账户对话框中选择添加新的邮件账户,然后按照向导配置邮件账户→使用新的配置文件启动outlook,看问题是否解决;
    4. 开始→运行→regedit→确定,定位到注册表中下面的位置,导出备份后删除:HKEY_CURRENT_USER\Software\Microsoft\Office\Outloo k\Addins\
      HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlo ok\Addins
    5. 启动outlook→工具→信任中心→宏安全性→选择“不提供警告,禁用所有宏”→确定→重启outlook看问题是否解决;
    6. 用管理员用户登录,禁用拼写检查;
    7. 禁用杀毒软件;
    8. 删除Internet Explorer的临时文件。

    Microsoft Technet Observer 如果问题没有解决,请继续跟帖讨论;如果问题得到解决,请标记为答复。
    2009年6月12日 19:44
    版主

全部回复

  • 一些建议:

    1. 开始→运行→outlook /safe→回车,问题还存在吗?
    2. 在机器上查找下面几个文件:outcmd.dat、extend.dat、frmcache.dat、views.dat,找到后将其后缀修改为.old,注意它们可能位于隐藏的文件夹中,一般来说,它们位于C:\Documents and Settings\用户名\Local Settings\Application Data\Microsoft\Outlook\中;
    3. 开始→控制面板→邮件→显示配置文件→点击“提示要使用的配置文件”→添加→在“配置文件名称”下输入一个名称→确定→在邮件账户对话框中选择添加新的邮件账户,然后按照向导配置邮件账户→使用新的配置文件启动outlook,看问题是否解决;
    4. 开始→运行→regedit→确定,定位到注册表中下面的位置,导出备份后删除:HKEY_CURRENT_USER\Software\Microsoft\Office\Outloo k\Addins\
      HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Outlo ok\Addins
    5. 启动outlook→工具→信任中心→宏安全性→选择“不提供警告,禁用所有宏”→确定→重启outlook看问题是否解决;
    6. 用管理员用户登录,禁用拼写检查;
    7. 禁用杀毒软件;
    8. 删除Internet Explorer的临时文件。

    Microsoft Technet Observer 如果问题没有解决,请继续跟帖讨论;如果问题得到解决,请标记为答复。
    2009年6月12日 19:44
    版主
  • 在机器上查找下面几个文件:outcmd.dat、extend.dat、frmcache.dat、views.dat,找到后将其后缀修改为.old,注意它们可能位于隐藏的文件夹中,一般来说,它们位于C:\Documents and Settings\用户名 \Local Settings\Application Data\Microsoft\Outlook\中;

    按照这个提示,我看到 确实存在 extend.dat 这个文件, 然后把它重命名。
    但是过了几十分钟后, outlook自己创建了一个 新的 命名为 extend.dat 的文件。。


    Sorry for my English skill.I try my best to make the question clear.
    2009年6月15日 2:50
  • CPU使用率就又高上去了?
    Microsoft Technet Observer 如果问题没有解决,请继续跟帖讨论;如果问题得到解决,请标记为答复。
    2009年6月15日 8:45
    版主
  • 是的。CPU使用率又高了。2007.pst,2008.pst这两个文件的最后修改日期也跟着变化。。





    Sorry for my English skill.I try my best to make the question clear.
    2009年6月16日 2:57
  • 即使 没有extend.dat这个文件。 我说的现象还是会存在。
    没有extend.dat的话, 似乎两次出现的时间间隔 更长。

    此外。2007.pst,2008.pst, 2009.ps这些文件的最后修改日期也在更新。。但是 我并没有像这些文件写入东西。。

    事实上, 我把 C:\Documents and Settings\$(MyName)\Local Settings\Application Data\Microsoft\Outlook下的所有文件都删掉,然后启动Outlook 2007.  可是问题依旧!!!!



    Sorry for my English skill.I try my best to make the question clear.
    2009年6月16日 3:57