none
ECP查看证书失败 RRS feed

  • 问题

  • 两台Exchange 2013服务器都是全角色,Exchange AExchange B做成DAG,我将其中的一台Exchange A发布出去,当我登录ECP的时候查看证书信息的时候,只能有一台服务器证书信息可以被正常显示,也就是说比如我现在可以正常显示Exchange AExchange B就无法正常加载,这时候我把Exchange A服务器重启,Exchange B就可以正常加载显示证书了,Exchange A就无法显示了,反之也一样,报错如下

    <v:shapetype coordsize="21600,21600" filled="f" id="_x0000_t75" o:preferrelative="t" o:spt="75" path="m@4@5l@4@11@9@11@9@5xe" stroked="f">
     <v:stroke joinstyle="miter">
    <v:formulas>  <v:f eqn="if lineDrawn pixelLineWidth 0">
      <v:f eqn="sum @0 1 0">
      <v:f eqn="sum 0 0 @1">
      <v:f eqn="prod @2 1 2">
      <v:f eqn="prod @3 21600 pixelWidth">
      <v:f eqn="prod @3 21600 pixelHeight">
      <v:f eqn="sum @0 0 1">
      <v:f eqn="prod @6 1 2">
      <v:f eqn="prod @7 21600 pixelWidth">
      <v:f eqn="sum @8 21600 0">
      <v:f eqn="prod @7 21600 pixelHeight">
      <v:f eqn="sum @10 21600 0">
     </v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:formulas>
     <v:path gradientshapeok="t" o:connecttype="rect" o:extrusionok="f">
     <o:lock aspectratio="t" v:ext="edit">
    </o:lock></v:path></v:stroke></v:shapetype><v:shape alt="" id="图片_x0020_1" o:spid="_x0000_i1025" style="width:309pt;height:209.25pt;" type="#_x0000_t75">
    <v:imagedata o:href="cid:image001.png@01D245A6.9FEE54D0" src="file:///C:\Users\ZHANGG~1\AppData\Local\Temp\msohtmlclip1\01\clip_image001.png">
    </v:imagedata></v:shape>

    2016年11月23日 8:44

答案

  • 你好,

    这个问题确实很奇怪,需要与你确认以下几点,以便排错:

    1.当ECP出现该报错的时候,使用EMS运行“Get-ExchangeCertificate -Server ServerName"指令,能否正常查看证书?

    2.使用一台服务器上的ECP,然后通过选择不同服务器来查看证书,是否可行?如下图所示:

    3.出现问题的时候,是否有相关的错误日志生成?

    通过目前的报错来看,显示是访问被拒绝,可能是由于权限问题导致的,我们可以尝试将“Exchange Trusted Subsystem”群组添加到每台Exchange服务器的本地管理员群组中,然后再次查看是否有同样的问题。如下:

    谢谢!


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • 已标记为答案 吹牛皮 2016年11月24日 8:38
    2016年11月24日 7:49
    版主
  • 谢谢 niko,是权限问题。Exchange Trusted Subsystem被手工删除掉了。
    • 已标记为答案 吹牛皮 2016年11月24日 8:40
    2016年11月24日 8:39

全部回复

  • 你好,

    这个问题确实很奇怪,需要与你确认以下几点,以便排错:

    1.当ECP出现该报错的时候,使用EMS运行“Get-ExchangeCertificate -Server ServerName"指令,能否正常查看证书?

    2.使用一台服务器上的ECP,然后通过选择不同服务器来查看证书,是否可行?如下图所示:

    3.出现问题的时候,是否有相关的错误日志生成?

    通过目前的报错来看,显示是访问被拒绝,可能是由于权限问题导致的,我们可以尝试将“Exchange Trusted Subsystem”群组添加到每台Exchange服务器的本地管理员群组中,然后再次查看是否有同样的问题。如下:

    谢谢!


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • 已标记为答案 吹牛皮 2016年11月24日 8:38
    2016年11月24日 7:49
    版主
  • 谢谢 niko,是权限问题。Exchange Trusted Subsystem被手工删除掉了。
    • 已标记为答案 吹牛皮 2016年11月24日 8:40
    2016年11月24日 8:39